Trouble to configure HotSpot WIFI with RPi Zero W

Kernels & Hardware, configuring network, installing services

Trouble to configure HotSpot WIFI with RPi Zero W

Postby SJL » 2018-07-14 08:53

Hello,
I'am trying to set an hotspot on a pizero with dietPi distribution (V6.11)
I tried the official way through DietPi-config, but did not succeed and now I'm a bit lost with wifi configuration.
No hotspot is created and visible from other devices.

Thank you for your help.
--
# iwconfig returns
Code: Select all
wlan0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

# ip a returns
Code: Select all
(...)
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether b8:27:eb:fd:d9:68 brd ff:ff:ff:ff:ff:ff
inet 192.168.42.1/24 brd 192.168.42.255 scope global wlan0
valid_lft forever preferred_lft forever

My configuration
#/etc/hostapd/hostapd.conf
Code: Select all
interface=wlan0
   driver=nl80211
   hw_mode=g
   channel=7
   macaddr_acl=0
   auth_algs=1
   ssid=DietPi-HotSpot
   wpa=2
   wpa_passphrase=dietpihotspot
   wpa_key_mgmt=WPA-PSK
   wpa_pairwise=TKIP
   rsn_pairwise=CCMP
   

Note that: hostapd /etc/hostapd/hostapd.conf returns Illegal instruction

#/etc/network/interfaces

Code: Select all
#Please use DietPi-Config to modify network settings.

   # Local
   auto lo
   iface lo inet loopback

   # Ethernet
   allow-hotplug eth0
   iface eth0 inet dhcp
   address 192.168.0.100
   netmask 255.255.255.0
   gateway 192.168.0.1
   #dns-nameservers 8.8.8.8 8.8.4.4

   # Wifi
   allow-hotplug wlan0
   iface wlan0 inet static
   address 192.168.42.1


/etc/wpa_supplicant/wpa_supplicant.conf
Code: Select all
   country=GB
   ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
   update_config=1

   network={
       ssid="MySuperDooperWiFi"
       scan_ssid=1
       key_mgmt=WPA-PSK
       psk="0123456789"
   }
SJL
 
Posts: 2
Joined: 2018-07-14 08:44


Re: Trouble to configure HotSpot WIFI with RPi Zero W

Postby SJL » 2018-07-14 09:32

Thanks you for this quick answer.
I will post there even if I was not sure my issue was related to the PI.
SJL
 
Posts: 2
Joined: 2018-07-14 08:44



Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable