Replace repo wordpress with latest version

Kernels & Hardware, configuring network, installing services

Replace repo wordpress with latest version

Postby chris.w.noaa » 2018-07-18 15:40

So I've dug myself a bit of a hole on this one.
Two Wordpress specific plugins were requested by my users and yet we had no Wordpress server running. Standing up a new VM container was easy enough and after installing Stretch and following the available guides Wordpress 4.7.5 was installed from the repos and verified as running. After following the necessary guides the requested plugins were installed and AD integration was completed. Lastly available on-site Wordpress, plugins, and themes updates were done bringing the base version to 4.7.11.
Now I'm told that I have to update the Wordpress installation to at least 4.8, with the latest version being preferred.
Knowing that I cannot do that via the repos I would like to ask the community if there is any way to migrate the site from the repository version, 4.7.x, to the latest downloadable version from wordpress.org, 4.9.7 as of this post. Please note that the plugins used are licensed so I'm hoping that a move will be more forgiving than a reinstall, also the database is on another server.

Already having thought thru the issue I think it will go something like this. If you see any issues with this please let me know.
Download the latest version and extract it into /var/www/html.
Copy the contents of /var/lib/wordpress/wp-content into /var/www/html/wp-content.
Edit the /var/www/html/wp-config.php file to include the database settings from /etc/wordpress/config-default.php. Add the hashes and salts as needed.
Move the single blog section from the /etc/wordpress/htaccess file to the /etc/apache2/sites-enabled/000-default.conf file. Remove the comment characters.
Login and take care of any issues.
Remove the site file from /etc/apache2/sites-enabled/ for the repo installed version. Or just uninstall the repo version.
chris.w.noaa
 
Posts: 4
Joined: 2018-07-18 15:17

Re: Replace repo wordpress with latest version

Postby TonyT » 2018-07-19 10:27

Copy the contents of /var/lib/wordpress/wp-content into /var/www/html/wp-content.

You'll also need the contents of wp-admin and wp-includes, as well as all the standalone files in the wordpress root EXCEPT wp-config.php. Edit wp-config.php with the same db info and salt.
TonyT
 
Posts: 555
Joined: 2006-09-04 11:57

Re: Replace repo wordpress with latest version

Postby chris.w.noaa » 2018-07-19 12:27

TonyT wrote:You'll also need the contents of wp-admin and wp-includes, as well as all the standalone files in the wordpress root

Wouldn't copying those files basically copy the older version over the new one?
chris.w.noaa
 
Posts: 4
Joined: 2018-07-18 15:17

Re: Replace repo wordpress with latest version

Postby kedaha » 2018-07-19 14:44

I reckon you might be better off backporting the version currently available in sid and testing. This:
Code: Select all
$ rmadison wordpress |grep testing
wordpress  | 4.9.7+dfsg1-1              | testing            | source, all

If you're lucky and stevepusser's :wink: around, maybe he's already done that.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2869
Joined: 2008-05-24 12:26

Re: Replace repo wordpress with latest version

Postby chris.w.noaa » 2018-07-19 19:37

kedaha wrote:I reckon you might be better off backporting the version currently available in sid and testing.

That did not occur to me. The I can see a few downsides, besides the fact that it might not compile, such that it will still be stuck on Debian's release schedule which could make getting the latest security patches a bigger hassle.
However I see no harm in trying to at least build the package, even if I don't use it.

Some reading and working later I have what looks like a proper package, at the very least there were no errors in the final step. I'm still going to hold off on it as I would almost rather get on the official Wordpress release cycle instead. Any other ideas on that?
At least I have a good backup plan now if I don't get anymore help with my original plan.
chris.w.noaa
 
Posts: 4
Joined: 2018-07-18 15:17

Re: Replace repo wordpress with latest version

Postby Bulkley » 2018-07-19 19:51

chris.w.noaa wrote:Now I'm told that I have to update the Wordpress installation to at least 4.8, with the latest version being preferred.


Told by whom? This is not a frivolous question. Is this your boss at work or just some unknown blogger? My point is to ask whether you are going to a lot of work because of somebody's whim.
Bulkley
 
Posts: 5661
Joined: 2006-02-11 18:35

Re: Replace repo wordpress with latest version

Postby Wheelerof4te » 2018-07-20 09:02

Security patches are backported to the version in repo. See the latest wordpress DSA.
User avatar
Wheelerof4te
 
Posts: 1134
Joined: 2015-08-30 20:14

Re: Replace repo wordpress with latest version

Postby chris.w.noaa » 2018-07-24 12:50

Bulkley wrote:Told by whom?

One of the new plugins that is required for the site needs to have 4.8 or later to work properly and for the Service Agreement to be valid. Now it did install with the current WP version but it is having some issues that an upgrade will most likely fix.

Wheelerof4te wrote:Security patches are backported to the version in repo.

Of this I had no doubt but if I build the package from the testing repo for my own purposes I will need to check for updates and rebuild it when necessary. Not that I'm unwilling to do the work but it is just another thing to add to my already heavy update schedule.

I am hoping that someone sees this that is up for, and has the time and available system to, backporting the testing version to Stretch. That would be the easiest for me but I may just install the package I built just to get the users off my back.
chris.w.noaa
 
Posts: 4
Joined: 2018-07-18 15:17

Re: Replace repo wordpress with latest version

Postby stevepusser » 2018-07-24 17:25

Well, I did rebuild the upstream version for the MX 17 repo on a vanilla Stretch base in pbuilder, so it should be compatible:

http://mxrepo.com/mx/testrepo/pool/test/w/wordpress/

There's also a way to backport build and host the packages in a repo yourself on the openSUSE Build Service, if you want to try that. There's a guide in the HOWTO section here by yrs. truly, and Head On A Stick here also knows how to do it.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10273
Joined: 2009-10-06 05:53

Re: Replace repo wordpress with latest version

Postby debiman » 2018-07-31 12:29

there's no compiling wordpress - it's just a (huge) pile of PHP scripts.

you should go the backport version first, if possible - added benefit: it would also upgrade dependencies.

if that doesn't work, it is fairly standard practice to "install" CMSs straight from upstream, i.e. "unzip the archive" etc. - follow their installation instructions.
CMSs usually strive to be conservative with system dependencies, in order to be easily installable on a wide variety of systems. IMO, it should Just Work (tm) on debian stable.
User avatar
debiman
 
Posts: 3064
Joined: 2013-03-12 07:18


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable