[SOLVED] Failed to active SWAP

Kernels & Hardware, configuring network, installing services

[SOLVED] Failed to active SWAP

Postby Max500 » 2018-09-16 16:55

I installed Debian 9.5 (32bit) in VMWare. Then there was no problem.
Immediately after the installation was offered an update:

linux-image-4.9.0-7-686-pae -> linux-image-4.9.0-8-686-pae

From this point on, I see this at boot:
"Failed to active SWAP"
"Dependency failed for swap"

If I choose the old kernel when booting, it works perfectly.
Last edited by Max500 on 2018-09-17 15:49, edited 1 time in total.
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby arzgi » 2018-09-16 17:06

Welcome to the forums Max500!

Is there a swap in the system?
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: Failed to active SWAP

Postby Max500 » 2018-09-16 17:12

arzgi wrote:Is there a swap in the system?


Yes! If I choose the old kernel when booting, it works perfectly.
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby arzgi » 2018-09-16 17:32

VM does not help trouble shooting, as it is one movig part more, but let's try anyway.

In working Debian 4.9.0-7 kernel,
Code: Select all
cat /etc/fstab

post output.
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: Failed to active SWAP

Postby Max500 » 2018-09-16 17:45

Code: Select all
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=b2c2df73-fbd7-4c10-9115-89af200c0ee3 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=e88bd156-cfe5-4ef9-b8fd-b5e3f8ccf3c1 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby 4D696B65 » 2018-09-16 18:34

on both kernels as root
Code: Select all
blkid
User avatar
4D696B65
 
Posts: 2219
Joined: 2009-06-28 06:09

Re: Failed to active SWAP

Postby Max500 » 2018-09-17 03:28

On 4.9.0-7:
Code: Select all
/dev/sr0: UUID="2018-07-14-11-41-07-00" LABEL="Debian 9.5.0 i386 1" TYPE="iso9660" PTUUID="443f9803" PTTYPE="dos"
/dev/sda1: UUID="b2c2df73-fbd7-4c10-9115-89af200c0ee3" TYPE="ext4" PARTUUID="b8b3f226-01"
/dev/sda5: UUID="e88bd156-cfe5-4ef9-b8fd-b5e3f8ccf3c1" TYPE="swap" PARTUUID="b8b3f226-05"


On 4.9.0-8:
Code: Select all
/dev/sr0: UUID="2018-07-14-11-41-07-00" LABEL="Debian 9.5.0 i386 1" TYPE="iso9660" PTUUID="443f9803" PTTYPE="dos"
/dev/sda1: UUID="b2c2df73-fbd7-4c10-9115-89af200c0ee3" TYPE="ext4" PARTUUID="b8b3f226-01"
/dev/sda5: UUID="e88bd156-cfe5-4ef9-b8fd-b5e3f8ccf3c1" TYPE="swap" PARTUUID="b8b3f226-05"
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby p.H » 2018-09-17 08:41

Does the system display information about why it failed to activate the swap ?

Can you activate the swap manually ?
Code: Select all
swapon -v -U e88bd156-cfe5-4ef9-b8fd-b5e3f8ccf3c1
swapon -v /dev/sda5
p.H
 
Posts: 645
Joined: 2017-09-17 07:12

Re: Failed to active SWAP

Postby Max500 » 2018-09-17 13:26

Boot screen: here

swapon -v -U e88bd156-cfe5-4ef9-b8fd-b5e3f8ccf3c1
and
swapon -v /dev/sda5
Code: Select all
swapon: /dev/sda5: found signature [pagesize=4096, signature=swap]
swapon: /dev/sda5: pagesize=4096, swapsize=1608515584, devsize=1608515584
swapon /dev/sda5
swapon: /dev/sda5: swapon failed: Invalid argument
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby p.H » 2018-09-17 13:38

I cannot view the boot screen at the moment, will review it later.
Can you check the latest kernel messages with dmesg right after the swapon failure ?
p.H
 
Posts: 645
Joined: 2017-09-17 07:12

Re: Failed to active SWAP

Postby Max500 » 2018-09-17 14:04

Only one line:
Code: Select all
[ 2587.754654] Truncating oversized swap area, only using 0k out of 1570812k
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby p.H » 2018-09-17 14:33

A quick search with this message suggests it is a regression on 32-bit PAE kernels due to the Intel L1TF vulnerability mitigation patches.
https://lkml.org/lkml/2018/8/20/172
A Debian bug exists but it does not seem to have much activity :
https://bugs.debian.org/cgi-bin/bugrepo ... bug=906992
p.H
 
Posts: 645
Joined: 2017-09-17 07:12

Re: Failed to active SWAP

Postby Max500 » 2018-09-17 15:19

Thanks for the help! Helped a lot.
I changed to non-pae kernel and everything works perfectly.
Sorry for any mistakes. English is not my native language
Max500
 
Posts: 7
Joined: 2018-09-16 16:39

Re: Failed to active SWAP

Postby arzgi » 2018-09-17 15:40

Max500 wrote:Thanks for the help! Helped a lot.
I changed to non-pae kernel and everything works perfectly.


Great news! If case is now clear, can you please edit the your first post's header in the thread, and add [SOLVED] to the front. So every one browsing would see, that thread does not require more actions, or something searching for help would see possible solution.
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: [SOLVED] Failed to active SWAP

Postby p.H » 2018-09-17 19:06

Using the non-PAE kernel is not a perfect solution, but rather a workaround.
The main drawback is that it does not support the NX bit (preventing execution of data pages).
p.H
 
Posts: 645
Joined: 2017-09-17 07:12


Return to System configuration

Who is online

Users browsing this forum: Dylanus and 3 guests

fashionable