libssl1.0.0 pre-depends on multiarch-support ?

Kernels & Hardware, configuring network, installing services

libssl1.0.0 pre-depends on multiarch-support ?

Postby 1885 » 2018-09-24 02:18

How do you use multiarch-support from command line to install libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb ?

I'm experimenting with Debian 10 and trying to install Packettracer
I need to install libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb
to satisfy a dependency. I can install libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb using the Package Manager GUI

But I'd really like to understand what is going on .

I get the following errors:

# dpkg -i libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb
dpkg: regarding libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb containing libssl1.0.0:amd64, pre-dependency problem:
libssl1.0.0 pre-depends on multiarch-support
multiarch-support is not installed.

dpkg: error processing archive libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb (--install):
pre-dependency problem - not installing libssl1.0.0:amd64
Errors were encountered while processing:
libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb

Thanks
1885
 
Posts: 111
Joined: 2014-06-05 04:23

Re: libssl1.0.0 pre-depends on multiarch-support ?

Postby Head_on_a_Stick » 2018-09-24 05:03

1885 wrote:I'm experimenting with Debian 10

There is no Debian 10.

Testing is a development branch, that is why libssl is not available at the moment, you should not expect that branch to be usable at any given time.

1885 wrote:I'd really like to understand what is going on

See viewtopic.php?f=12&t=134762&p=655783 :mrgreen:
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8322
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: libssl1.0.0 pre-depends on multiarch-support ?

Postby p.H » 2018-09-24 10:16

multiarch-support is a Debian package. It must be installed prior to installing libssl1.0.0.
Actually I am surprised that is it not already installed, as many packages depend on it.
Why do you want to install the package with dpkg ? dpkg does not install rmissing dependencies. Using any APT tool would automatically manage missing dependencies.
p.H
 
Posts: 645
Joined: 2017-09-17 07:12

Re: libssl1.0.0 pre-depends on multiarch-support ?

Postby 1885 » 2018-09-24 11:07

p.H wrote:multiarch-support is a Debian package. It must be installed prior to installing libssl1.0.0.
Actually I am surprised that is it not already installed, as many packages depend on it.
Why do you want to install the package with dpkg ? dpkg does not install rmissing dependencies. Using any APT tool would automatically manage missing dependencies.


I am trying to install PacketTracer on Debian 9+ (Buster) (https://www.debian.org/releases/buster/ ... ller/index)
https://www.debian.org/devel/debian-ins ... 8/20180619

I am going with Buster because the Motherboard I am using in our lab does not have the drivers installed in the Kernel for Debain 9
https://www.asus.com/us/Motherboards/RO ... fications/
NIC (Intel® I219V)

Here is the error we get after installing dependencies using apt ( apt install qtmultimedia5-dev libqt5webkit5-dev libqt5script5 libqt5scripttools5; ) :
/opt/pt/bin/PacketTracer7
/opt/pt/bin/PacketTracer7: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory


I just installed libcrypto.so.1.0.0
with the following:
apt install ./libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb after moving libcrypto.so.1.0.0 to /var/cache/apt/archives
which worked.

Now there are other problems which have nothing to do with Debian 9+.

"multiarch-support" is installed . This really helps : apt install ./libssl1.0.0_1.0.2l-1_bpo8+1_amd64.deb

Thanks for you posts
Last edited by 1885 on 2018-09-24 11:23, edited 1 time in total.
1885
 
Posts: 111
Joined: 2014-06-05 04:23

Re: libssl1.0.0 pre-depends on multiarch-support ?

Postby bw123 » 2018-09-24 11:20

1885 wrote:<snip>
I am going with Buster because the Motherboard I am using in our lab does not have the drivers install in the Kernel for Debain 9
https://www.asus.com/us/Motherboards/RO ... fications/
NIC (Intel® I219V)


That's why debian has a backported kernel for stretch.
https://wiki.debian.org/Backports

You're really getting off to good start at causing yourself a lot of aggravation using testing and trying to install jessie-backport pkg on it so you can install an out-of-repo application.

viewtopic.php?f=10&t=138659&p=681660&hilit=packettracer#p681574
User avatar
bw123
 
Posts: 3580
Joined: 2011-05-09 06:02
Location: TN_USA

Re: libssl1.0.0 pre-depends on multiarch-support ?

Postby 1885 » 2018-09-25 03:08

bw123 wrote:
1885 wrote:You're really getting off to good start at causing yourself a lot of aggravation using testing and trying to install jessie-backport pkg on it so you can install an out-of-repo application.

viewtopic.php?f=10&t=138659&p=681660&hilit=packettracer#p681574


Thanks for the post! You're right.

How do I get our NICS installed with buying a PCI-e for all 25 nodes? I purchased an Intel PCI-e nic that works but right now I'm saving money.
We can wait until Buster is stable.
The AUSUS B360-H uses a Intel® I219V, Nic which is not available in the 9.5 kernel.
I have yet to figure out how to add the I219V firmware on install.
1885
 
Posts: 111
Joined: 2014-06-05 04:23


Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable