USB not recognized in fdisk but recognized in Disk GUI

Kernels & Hardware, configuring network, installing services

USB not recognized in fdisk but recognized in Disk GUI

Postby Carlos777 » 2018-09-25 15:53

So I was using this USB to create a bootable ISO Windows10 and Debian. I have been made this before with time ago no problem, but last time the USB stopped working. It is recognized by the Disk GUI (imagen uploaded) but it's not mounted, besides I have been looking around and found that maybe the Kernel was not loading the USB https://ubuntuforums.org/showthread.php?t=1586206, I followed the steps but I couldn't resolve my problem, here more info.

Thanks forwards.
Screenshot:
https://imgur.com/GRDmXNE

sudo tailf /var/log/messages
Sep 25 12:06:47 carlosdebian kernel: [13144.016562] usb 2-3: new high-speed USB device number 15 using xhci_hcd
Sep 25 12:06:47 carlosdebian kernel: [13144.158088] usb 2-3: New USB device found, idVendor=058f, idProduct=1234
Sep 25 12:06:47 carlosdebian kernel: [13144.158092] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Sep 25 12:06:47 carlosdebian kernel: [13144.158094] usb 2-3: Product: Mass Storage Device
Sep 25 12:06:47 carlosdebian kernel: [13144.158095] usb 2-3: Manufacturer: Alcor Micro
Sep 25 12:06:47 carlosdebian kernel: [13144.158814] usb-storage 2-3:1.0: USB Mass Storage device detected
Sep 25 12:06:47 carlosdebian kernel: [13144.159004] scsi host6: usb-storage 2-3:1.0
Sep 25 12:06:47 carlosdebian mtp-probe: checking bus 2, device 15: "/sys/devices/pci0000:00/0000:00:14.0/usb2/2-3"
Sep 25 12:06:47 carlosdebian mtp-probe: bus: 2, device: 15 was not an MTP device
Sep 25 12:06:48 carlosdebian kernel: [13145.189369] scsi 6:0:0:0: Direct-Access Generic USB Flash Disk 7.76 PQ: 0 ANSI: 4
Sep 25 12:06:48 carlosdebian kernel: [13145.189928] sd 6:0:0:0: Attached scsi generic sg2 type 0
Sep 25 12:06:48 carlosdebian kernel: [13145.190623] sd 6:0:0:0: [sdb] Attached SCSI removable disk

sudo lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 05c8:036e Cheng Uei Precision Industry Co., Ltd (Foxlink) Webcam
Bus 002 Device 002: ID 8087:07dc Intel Corp.
Bus 002 Device 009: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 002 Device 015: ID 058f:1234 Alcor Micro Corp. Flash Drive
Bus 002 Device 005: ID 138a:0050 Validity Sensors, Inc. Swipe Fingerprint Sensor
Bus 002 Device 008: ID 0eef:a802 D-WAV Scientific Co., Ltd eGalaxTouch EXC7920
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo fdisk -l
Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xa97eee75

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 488282111 488280064 232.9G 83 Linux
/dev/sda2 878907392 888086527 9179136 4.4G 82 Linux swap / Solaris
/dev/sda3 488282112 878907391 390625280 186.3G 83 Linux
/dev/sda4 888086528 1181054975 292968448 139.7G 83 Linux

Partition table entries are not in disk order.
Carlos777
 
Posts: 1
Joined: 2018-09-25 15:35

Re: USB not recognized in fdisk but recognized in Disk GUI

Postby bw123 » 2018-09-25 21:24

I have had some similar issues with usb card reader, especially after system suspend. I usually solve it by removing and reinsert the driver.

Code: Select all
# dmesg | grep usbcore
[    1.823235] usbcore: registered new interface driver usbfs
[    1.823286] usbcore: registered new interface driver hub
[    1.827675] usbcore: registered new device driver usb
[    2.662447] usbcore: registered new interface driver usb-storage
[    2.664388] usbcore: registered new interface driver uas
[    2.678531] usbcore: registered new interface driver ums-realtek
[    9.541143] usbcore: registered new interface driver uvcvideo
# modprobe -r ums_realtek
# modprobe ums_realtek


If it works, look at /lib/systemd/system-sleep/
User avatar
bw123
 
Posts: 3572
Joined: 2011-05-09 06:02
Location: TN_USA


Return to System configuration

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable