[SOLVED] gpsd post installation failure

Kernels & Hardware, configuring network, installing services

[SOLVED] gpsd post installation failure

Postby arzgi » 2018-10-04 13:21

Debian 9.5, XFCE

After installing gpsd, I get this error message every time I install some package:
Code: Select all
Setting up gpsd (3.16-4) ...
Creating/updating gpsd user account...
A dependency job for gpsd.service failed. See 'journalctl -xe' for details.
invoke-rc.d: initscript gpsd, action "start" failed.
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; indirect; vendor preset: enabled)
   Active: inactive (dead)

loka 04 16:20:31 samsung systemd[1]: Dependency failed for GPS (Global Posi…mon.
loka 04 16:20:31 samsung systemd[1]: gpsd.service: Job gpsd.service/start f…cy'.
Hint: Some lines were ellipsized, use -l to show in full.
dpkg: error processing package gpsd (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up fprintd (0.7.0-1) ...
Setting up libpam-fprintd:i386 (0.7.0-1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for dbus (1.10.26-0+deb9u1) ...
Errors were encountered while processing:
 gpsd
E: Sub-process /usr/bin/dpkg returned an error code (1)



gpsd is working anyway. How to get rid of that error?
Last edited by arzgi on 2018-10-07 13:20, edited 1 time in total.
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: gpsd post installation failure

Postby None1975 » 2018-10-05 12:59

Did you check journalctl -xe for details?
User avatar
None1975
 
Posts: 702
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: gpsd post installation failure

Postby arzgi » 2018-10-05 14:25

Yes, I did.
Code: Select all
- The result is failed.
loka 04 18:08:08 samsung systemd[1]: Dependency failed for GPS (Global Positioni
-- Subject: Unit gpsd.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- Unit gpsd.service has failed.
--
-- The result is dependency.
)
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland

Re: gpsd post installation failure

Postby arzgi » 2018-10-07 13:19

Found it! gpsd requires loopback to be IPV6 enabled.

Wonders of systemd, dependency broken...
arzgi
 
Posts: 389
Joined: 2008-02-21 17:03
Location: Finland


Return to System configuration

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable