[SOLVED] NetworkManager issues

Kernels & Hardware, configuring network, installing services

Re: [SOLVED] NetworkManager issues

Postby Mike » 2018-10-09 23:08

bw123 wrote:Well, the deeper hole will be figuring out whether or not you can actually use network-manager's MAC randomization, which is a pretty cool feature, or you have to just totally disable it for the device. I got my b43 to work random by creating a mask that keeps the MAC beginning with 78:xx:xx:xx:xx:xx

I believe this does require that predictable names is enabled, but I haven't really tested that. I have predictable names enabled, even though this pcie device is still named wlan0 for some reason,


I do plan on checking that out, but for the time being I'm going to take a short break and use the system rather than poking around in it first. ;)
Mike
 
Posts: 57
Joined: 2005-11-16 19:12
Location: Sunshine Coast, BC

Re: [SOLVED] NetworkManager issues

Postby L_V » 2018-10-10 15:37

Mike wrote: I'm going to take a short break and use the system rather than poking around in it first.

You are right. You should first clean your fresh new Stretch system to start, and take more time to understand what you do.
You should ignore the noise around old bugs reported on Jessie/Archi/Ubuntu, talking about "totally disabling the predictable names", which hopefully you did not do.
Even more, the question was not how to totally disable the predictable names, but just change the criteria (kernel,database,onboard,slot,path / see 99-default.link file) to name the ethernet connection, and which can be simply done by adding a kernel option at boot, or by option in NetworkManager.conf if really specifically needed for Network M.

And if next time you disable something, think about what and how to enable something else as replacement !
If later on, you need to make a specific ethenet link based on MAC address, don't mix with this subject (if you don't use wireless on this PC, may be you don't need Network Manager, but should use systemd-networkd => other subject).

Then to summarize, as we have seen before, your "enp3s0" is correctly automatically created by udev: don't change this simply because you don't need it at all !
What you can do is this:
Code: Select all
# rm /etc/systemd/network/99-default.link
# echo "rt2800usb" >> /etc/modules
# update-initramfs -u

Reboot and report:
Code: Select all
$ ip a
$ grep -v \# /etc/network/interfaces
$ lsinitramfs /boot/initrd.img-$(uname -r) | egrep '99|-net|rt2800usb'

and what should have been clarified in your first post to clarify your system ethernet+WIFi (finally not sure to 100% understand your real problem / if any)
Code: Select all
lspci -knn | egrep -iA2 'ethernet|wifi'
L_V
 
Posts: 799
Joined: 2007-03-19 09:04

Previous

Return to System configuration

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable