"gave up waiting for suspend/resume device" still exists

Kernels & Hardware, configuring network, installing services

"gave up waiting for suspend/resume device" still exists

Postby travis82 » 2018-10-08 09:12

Hi
I'm using debian testing. I occasionally formatted my swap partition using Slackware installer and as expected I got boot delay and "gave up waiting for suspend/resume device" message in Debian. According many recommendation on the web, I replaced swap UUID with it's new UUID in fstab, added RESUME=none to /etc/initramfs-tools/initramfs.conf and updated initramfs but I still notice boot delay and that annoying message. Is there any further step that I should do?

Sorry for my english
travis82
 
Posts: 7
Joined: 2016-02-07 06:00

Re: "gave up waiting for suspend/resume device" still exists

Postby p.H » 2018-10-08 10:16

Did you check in /etc/initramfs-tools/conf.d/ ?
p.H
 
Posts: 602
Joined: 2017-09-17 07:12

Re: "gave up waiting for suspend/resume device" still exists

Postby travis82 » 2018-10-08 10:28

p.H wrote:Did you check in /etc/initramfs-tools/conf.d/ ?


yes, there is nothing in that folder.
travis82
 
Posts: 7
Joined: 2016-02-07 06:00

Re: "gave up waiting for suspend/resume device" still exists

Postby bw123 » 2018-10-08 14:29

travis82 wrote:Hi
I'm using debian testing. I occasionally formatted my swap partition using Slackware installer and as expected I got boot delay and "gave up waiting for suspend/resume device" message in Debian. According many recommendation on the web, I replaced swap UUID with it's new UUID in fstab, added RESUME=none to /etc/initramfs-tools/initramfs.conf and updated initramfs but I still notice boot delay and that annoying message. Is there any further step that I should do?

Sorry for my english


Your English is fine, never need to apologize. Maybe if you showed the forum instead of telling, someone can help you figure it out? What command did you use to build initramfs? Maybe one of these might have a clue?
Code: Select all
$ lsblk
$ apt policy initramfs-tools
$ cat /proc/cmdline


mkswap can also Specify the UUID to use ( man mkswap) so maybe try recreate the swap part it is looking for? Also be sure there is no typo in /etc/fstab for anything, recheck all entry in fstab.

Testing users should check bug reports for sure... https://wiki.debian.org/DebianTesting
User avatar
bw123
 
Posts: 3414
Joined: 2011-05-09 06:02
Location: TN_USA

Re: "gave up waiting for suspend/resume device" still exists

Postby travis82 » 2018-10-09 05:12

Thank you for your kind attention.
I used this instruction: https://lists.debian.org/debian-user/20 ... 00866.html
However, I noticed that UUID of swap partition is different in blkid and cmdline

here is the output of blkid
Code: Select all
/dev/sda5: UUID="67a0c2aa-e824-4934-9f08-41d5de838fe2" TYPE="swap" PARTUUID="93e993e9-05"


and here is the output of cat /proc/cmdline
Code: Select all
BOOT_IMAGE=/boot/vmlinuz-4.18.0-1-amd64 root=UUID=ef6f45fd-303a-4456-afe2-d5c76a53ac05 ro quiet resume=UUID=3167f8e8-e1dd-4262-92a2-be7bb0f02ebb


Obviously resume UUID in cmdline is not correct. is it enough to edit this file and put correct UUID in there?
travis82
 
Posts: 7
Joined: 2016-02-07 06:00

Re: "gave up waiting for suspend/resume device" still exists

Postby p.H » 2018-10-09 06:46

I did not suggest to check for a resume= parameter in the kernel command line because AFAIK Debian does not set it by default.

You cannot edit /proc/cmdline. As anything in /proc, it is not a regular file but an interface to the kernel. /proc/cmdline is read-only and contains the command line which was used to boot the kernel. If using GRUB as the boot loader, the kernel command line comes from the "linux" command of the selected menu entry in /boot/grub/grub.cfg. You should not edit this file either because it is built by update-grub which gets the kernel command line from /etc/default/grub. This is the file you should check and edit.
p.H
 
Posts: 602
Joined: 2017-09-17 07:12

Re: "gave up waiting for suspend/resume device" still exists

Postby travis82 » 2018-10-10 07:40

p.H wrote:I did not suggest to check for a resume= parameter in the kernel command line because AFAIK Debian does not set it by default.

You cannot edit /proc/cmdline. As anything in /proc, it is not a regular file but an interface to the kernel. /proc/cmdline is read-only and contains the command line which was used to boot the kernel. If using GRUB as the boot loader, the kernel command line comes from the "linux" command of the selected menu entry in /boot/grub/grub.cfg. You should not edit this file either because it is built by update-grub which gets the kernel command line from /etc/default/grub. This is the file you should check and edit.


Thank you very much. I edited /etc/default/grub and remove "resume" parameter. the problem solved.
travis82
 
Posts: 7
Joined: 2016-02-07 06:00

Re: "gave up waiting for suspend/resume device" still exists

Postby arzgi » 2018-10-10 07:52

That's great! Can you please edit your first post in the thread, and add [SOLVED] to the front of the header.
arzgi
 
Posts: 387
Joined: 2008-02-21 17:03
Location: Finland


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable