Proxmox + Optimus Computeur + Gnome or Panthon desktop = cra

Kernels & Hardware, configuring network, installing services

Proxmox + Optimus Computeur + Gnome or Panthon desktop = cra

Postby adrienf » 2018-10-09 21:04

Hello everyone,

I'm a student in a french informatic school and I've got the project to turn my laptot in a VM server using proxmox OS. But my laptop must also be in the same time server and client, I want to be able to connect on the vm from the laptop that host the vm in the same time. Here it's not the problem i can install, create vm, launch and use them from a web browser in both gnome or pantheon desktop environnement.

The problem is that as my laptop got optimus technology so is used to boot with nouveau.modeset=0 that the OS work without bugs or any problem,
(without that i can't have a working desktop environnement and the shutdown or reboot stuck with a watchog error)
With the nouveau.modeset=0 there is poor performance on graphics and the computer heats a lot, at a such point that i think the computer have something like a safety mode, beacause two time when he was incredibly hot he has automatically shut down.

So here the specs i've got a MSI GE62VR apache pro 7RF :
- i7-7700hq
- GTX 1060
- 16go ram
- ssd + hdd

I notice that proxmox is based on debian I used proxmox 5.2 which seems to be based on debian 9 stretch

So because it's a debian I tried to install bumblebee, first I tried the nouveau driver (bumblebee) but my card is not supported apparently, then I tried many time the privative one (bumblebee-nvidia) with no concluding result.
The things that i was able to get where just : fixed blackscren, a loop on login page, 'oh no something wrong happen', or the system freezing-crashing at the boot phase just when the '[OK] Start Light DM service' appears

I may have reinstall proxmox about 15 time, and I'm getting a little bit bored because I don't know whats wrong I also seen a post of a person with the same computer as me who finaly get to use bumblebee with a 'real debian' without any trouble so it's possible with mine using proxmox i guess.

After each full reinstall of proxmox I have used debian-facile wiki.debian tutorials to try to install and make work bumblebee

I've tried different methods and orders in the commands, but nothing went well. There is a few things that i've notice that can cause problems but i've manage to solve them and sometimes it work some other time it dont.

First proxmox didn't use linux-headers it use pve-headers so can its disturb the compilation process of some package, dkms ... ?
For example modprobe bbswitch return module not found in directory after is install.. and two time i installed before pve-headers and bbswitch have work is this a coincidence ??

nvidia-driver is install with apt but modinfo didn't return anything for nvidia or nvidia-current, but modinfo nvidia-current have only work two time the same time than the bbswitch was working

And I don't know why but there is only one time I've install bumblebee before the desktop environnement and all the test that was ask to run during the tutorial was working
cat /proc/acpi/bbswitch before using optirun was returning off when optirun was running cat /proc/acpi/bbswitch was returning on and then after otpirun as that ther is no X to load cat /proc/acpi/bbswitch has return to off
So here before i install a desktop bumblebee was working great i was having modinfo nvidia-current returning something, modprobe bbswitch was working too, i had correctly configure all .conf in /bumblebee. So i decide to install pantheon desktop and when i reboot the os was freezing at '[OK] Start Light DM service' .... here we go again ...

Also report that startx from tty cmd give a xauth file /root/.xauthority does not exist
and then blackscreen or came back to tty cmd

I think i may have put all the information i can get in this post maybe too much !
I really need this configuration, debian seems to work with optimus with the computer i get like a another person did i think it's just a configuration problem that i didn't see or something like that. Or i could probably be totaly wrong, if anyone could help me getting out of that it would be great, really !

PS: Sorry if i made some grammar errors it's not my native language i do my best to be understand ;)

Thanks have a niceday.
Posts: 1
Joined: 2018-10-09 21:01

Return to System configuration

Who is online

Users browsing this forum: duffy and 22 guests