Installing firmware for Atheros QCA6174

Kernels & Hardware, configuring network, installing services

Installing firmware for Atheros QCA6174

Postby nemo002 » 2018-10-28 11:13

I've searched the internet high and wide for an answer and nothing seems to work.

I recently installed Debian 9 on my Lenovo Yoga 910 and most of everything seems to work except the wifi module Atheros QCA6174. I ran both Ubuntu and Manjaro over the past year and never had a problem.

I've followed the Debian wiki here to download the firmware but still don't get anything. https://wiki.debian.org/ath9k_htc

Here are some stats

iwconfig:
wlp1s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

lo no wireless extensions.

enx00e04c534458 no wireless extensions.

dmesg:
[ 1.901614] ath10k_pci 0000:01:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:01:00.0.bin (-2)
[ 1.901620] ath10k_pci 0000:01:00.0: firmware: failed to load ath10k/cal-pci-0000:01:00.0.bin (-2)
[ 1.902524] ath10k_pci 0000:01:00.0: firmware: failed to load ath10k/QCA6174/hw3.0/firmware-6.bin (-2)
[ 1.902531] ath10k_pci 0000:01:00.0: firmware: failed to load ath10k/QCA6174/hw3.0/firmware-5.bin (-2)
[ 1.904767] ath10k_pci 0000:01:00.0: firmware: direct-loading firmware ath10k/QCA6174/hw3.0/firmware-4.bin
[ 1.904772] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[ 1.904774] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[ 1.905155] ath10k_pci 0000:01:00.0: firmware ver WLAN.RM.2.0-00180-QCARMSWPZ-1 api 4 features wowlan,ignore-otp,no-4addr-pad crc32 75dee6c5
nemo002
 
Posts: 2
Joined: 2018-10-28 10:56

Re: Installing firmware for Atheros QCA6174

Postby bw123 » 2018-10-28 16:57

found this searching for https://duckduckgo.com/html/?q=debian+a ... ware-6.bin

https://packages.debian.org/stretch-bac ... re-atheros
* Qualcomm Atheros QCA6174 rev 3.0 firmware, version
WLAN.RM.4.4.1-00079-QCARMSWPZ-1
(ath10k/QCA6174/hw3.0/firmware-6.bin)


https://backports.debian.org/Instructions/

if that doesn't get it working, check rfkill
User avatar
bw123
 
Posts: 3531
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Installing firmware for Atheros QCA6174

Postby nemo002 » 2018-10-29 01:30

bw123 wrote:found this searching for https://duckduckgo.com/html/?q=debian+a ... ware-6.bin

https://packages.debian.org/stretch-bac ... re-atheros
* Qualcomm Atheros QCA6174 rev 3.0 firmware, version
WLAN.RM.4.4.1-00079-QCARMSWPZ-1
(ath10k/QCA6174/hw3.0/firmware-6.bin)


https://backports.debian.org/Instructions/

if that doesn't get it working, check rfkill


I installed backports and tried to install the package but get these errors:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ath10k/QCA6174/hw3.0
E: Couldn't find any package by glob 'ath10k/QCA6174/hw3.0'
E: Couldn't find any package by regex 'ath10k/QCA6174/hw3.0'

rfkill list gives me these results:

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
2: ideapad_bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

I ran this command instead:
sudo apt-get -t stretch-backports install firmware-atheros

Now dmesg gives me this, so whatever ath10k/pre-cal-pic is, it's not loading or found.

[ 1.969933] ath10k_pci 0000:01:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:01:00.0.bin (-2)
[ 1.969940] ath10k_pci 0000:01:00.0: firmware: failed to load ath10k/cal-pci-0000:01:00.0.bin (-2)
[ 1.972413] ath10k_pci 0000:01:00.0: firmware: direct-loading firmware ath10k/QCA6174/hw3.0/firmware-6.bin
[ 1.972418] ath10k_pci 0000:01:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 17aa:0827
[ 1.972420] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[ 1.972815] ath10k_pci 0000:01:00.0: firmware ver WLAN.RM.4.4.1-00079-QCARMSWPZ-1 api 6 features wowlan,ignore-otp crc32 fd869beb
[ 2.038367] ath10k_pci 0000:01:00.0: firmware: direct-loading firmware ath10k/QCA6174/hw3.0/board-2.bin
[ 2.038675] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id N/A crc32 20d869c3

Also, my bluetooth works now!
nemo002
 
Posts: 2
Joined: 2018-10-28 10:56

Re: Installing firmware for Atheros QCA6174

Postby Head_on_a_Stick » 2018-10-29 06:00

nemo002 wrote:Iiwconfig:
wlp1s0 IEEE 802.11 ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

^ Your wireless card is already working.

EDIT: or was that from Ubuntu?
I suffer from depression and may lash out occasionally, try not to take it personally.
User avatar
Head_on_a_Stick
 
Posts: 8172
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Installing firmware for Atheros QCA6174

Postby stevepusser » 2018-10-29 18:38

You could run this script to provide troubleshooting info if installing firmware-atheros didn't solve the issue:

https://github.com/UbuntuForums/wireless-info
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10133
Joined: 2009-10-06 05:53


Return to System configuration

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable