Drive not showing up in file manager

Kernels & Hardware, configuring network, installing services

Drive not showing up in file manager

Postby Tinkerer » 2018-11-21 01:19

Hi,

I have a pc with an ssd and a hard drive. The ssd contains windows 10,
The hard drive contains two parts: one NTFS drive with files, (/dev/sdb2, Station_D), and one part linux.
I have mounted Station_D by editing fstab, but its not showing up in the file manager under other locations. How do i fix this?

Image

edit: Sorry, can't seem to get working screenshot.
Tinkerer
 
Posts: 2
Joined: 2018-11-21 01:08

Re: Drive not showing up in file manager

Postby jibberjabber » 2018-11-21 01:44

You could still at least tell us what version of Debian it is. And , "a file manager", ??? Is it MC, Nautilus, Thunar, gentoo, or maybe Nemo ?,
Have you tried reading the manual for mount :
Code: Select all
man mount
? Does it mount if you mount it using the CLI,.. ?

I have mounted Station_D by editing fstab,

Gee that is weird , I can not see what your fstab file looks like in my crystal ball, Would it be possible you could show us what it looks like , ? Please use code boxes to post the contents.

The ssd contains windows 10,

Maybe one of the recent windows 10 upgrades/updates remove the part Linux drive, I heard that MS windows users have been having problems with that, Folders, Files, and all kinds of data just disappears after the updates,.. you would need to ask MS, about that,..
written by HelpBot#8453
Alias jibberjabber
I am sorry, my english is not that good, and I sometimes have other problems,so my response might not be perfect.
N5RLX > "Jibber jabber ,all day and all night, jibber jabber jibber jabber"
jibberjabber
 
Posts: 122
Joined: 2016-01-10 16:58

{Solved] Re: Drive not showing up in file manager

Postby Tinkerer » 2018-11-21 08:10

My apologies for not providing enough information.

My fstab file looks like this:
Code: Select all
 /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdh4 during installation

UUID=b87f186f-fee6-4418-95d5-a5bac761a2f8 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdh5 during installation

UUID=4808a541-2ef4-4c07-a5a3-4d2595bddef3 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

/dev/sdg2   /mnt/Station_D ntfs auto,user,rw


I have made a symbolic link to the drive on my desktop, which opens without any problems, so mounting the drive works as intended.
I am using Debian 9 stretch 64 bit, with Gnome 3.22.2, and the file manager is Nautilus.

As shown below: No Station_D in the list
Image

Edit: thanks for making me look harder at what i was working with. After googling for Nautilus i found a forum post that described the problem:
The drive should be mounted to /media instead of /mnt in order for it to show up in Nautilus.

Code: Select all
/dev/sdg2   /mnt/Station_D ntfs auto,user,rw

changed into

/dev/sdg2   /media/Station_D ntfs auto,user,rw
Tinkerer
 
Posts: 2
Joined: 2018-11-21 01:08

Re: {Solved] Re: Drive not showing up in file manager

Postby debiman » 2018-11-22 06:38

Tinkerer wrote:The drive should be mounted to /media instead of /mnt in order for it to show up in Nautilus.

Code: Select all
/dev/sdg2   /mnt/Station_D ntfs auto,user,rw

changed into

/dev/sdg2   /media/Station_D ntfs auto,user,rw

so you have that in your /etc/fstab now?
i don't like it.
the software taking care of automounting stuff to /media does not like being interfered with.
maybe you're lucky and this is ok to do, or maybe you should consider this instead:
Code: Select all
/dev/sdg2    /mnt/Station_D    ntfs    auto,user,rw,comment=x-gvfs-show
User avatar
debiman
 
Posts: 3064
Joined: 2013-03-12 07:18


Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable