HPLIP on Debian 9.6

Kernels & Hardware, configuring network, installing services

HPLIP on Debian 9.6

Postby Shmotten » 2018-12-02 10:16

The last supported version is 9.5 and when I install it it says the packages pyqt4 and pyqt4-dbus are missing, eventhough they are installed with their new names (python-pyqt4 and python-pyqt4-dbus). So is there any way to install it or let it know the packages are installed?
Shmotten
 
Posts: 2
Joined: 2018-12-02 10:08

Re: HPLIP on Debian 9.6

Postby arochester » 2018-12-02 12:31

Is Hplip the one from Repository, or the one from the HP website?
arochester
 
Posts: 1349
Joined: 2010-12-07 19:55

Re: HPLIP on Debian 9.6

Postby Shmotten » 2018-12-02 13:30

arochester wrote:Is Hplip the one from Repository, or the one from the HP website?

From the website, but the one from the repository didn't function on my PC.
Shmotten
 
Posts: 2
Joined: 2018-12-02 10:08

Re: HPLIP on Debian 9.6

Postby stevepusser » 2018-12-02 15:41

What printer do you have? What minimum version of HPLIP does it require? Stretch has 3.16.11, and I have been able to backport 3.18.10 on Stretch, which requires a bit of a trick (build with the -J1 (not -j1) flag to prevent a parallel build). It's not hard to backport, and I could talk you through it.

I thought stretch-backports had 3.17.7 or something, but it seems to have been removed.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10276
Joined: 2009-10-06 05:53


Return to System configuration

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable