[Solved] Unable to configure WiFi

Kernels & Hardware, configuring network, installing services

Re: [Solved] Unable to configure WiFi

Postby dpc25 » 2018-12-24 21:10

Code: Select all
$ inxi -Fxz
System:    Host: ultranote Kernel: 4.18.0-0.bpo.1-amd64 x86_64 (64 bit gcc: 6.3.0)
           Desktop: Gnome 3.22.3 (Gtk 3.22.11-1)
           Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: laptop System: PC Specialist product: N2x0WU
           Mobo: CLEVO model: N2x0WU
           UEFI: American Megatrends v: 1.07.13 date: 06/02/2018
Battery    BAT0: charge: 20.7 Wh 72.3% condition: 28.6/30.0 Wh (96%)
           model: Notebook BAT status: Charging
CPU:       Quad core Intel Core i7-8550U (-HT-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15936
           clock speeds: max: 4000 MHz 1: 1143 MHz 2: 1952 MHz 3: 1919 MHz
           4: 1633 MHz 5: 1869 MHz 6: 1405 MHz 7: 1817 MHz 8: 1939 MHz
Graphics:  Card: Intel UHD Graphics 620 bus-ID: 00:02.0
           Display Server: X.Org 1.19.2 driver: N/A
           Resolution: 1920x1080@60.01hz
           GLX Renderer: Mesa DRI Intel Kabylake GT1.5
           GLX Version: 3.0 Mesa 13.0.6 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.18.0-0.bpo.1-amd64
Network:   Card-1: Intel Wireless-AC 9260 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 02:00.1
           IF: enp2s0f1 state: down mac: <filter>
Drives:    HDD Total Size: 628.1GB (3.9% used)
           ID-1: /dev/sda model: ST500LM034 size: 500.1GB temp: 0C
           ID-2: /dev/sdb model: ADATA_SU800NS38 size: 128.0GB temp: 27C
Partition: ID-1: / size: 109G used: 16G (15%) fs: ext4 dev: /dev/sdb2
           ID-2: swap-1 size: 8.47GB used: 0.00GB (0%) fs: swap dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 38.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 245 Uptime: 2:11 Memory: 1882.3/7856.9MB
           Init: systemd runlevel: 5 Gcc sys: N/A
           Client: Shell (bash 4.4.121) inxi: 2.3.5
Posts: 8
Joined: 2018-12-21 11:43

Re: [Solved] Unable to configure WiFi

Postby stevepusser » 2018-12-26 17:54

Inxi is reporting that your Intel graphics is working correctly with the standard Mesa libraries; hopefully that is correct. You're also using the kernel's built-in "modesetting" driver instead of the xserver-xorg-video-intel driver, which is expected and the default in Debian for recent Intel graphics. Some users, like me, prefer the "intel" driver because of its TearFree option and va-api hardware decoding and encoding options, which are not in the modesetting driver.

Start a new thread for this if you encounter video glitches with modesetting, or just want to switch to the intel driver.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Foliate 1.5.3, Minitube 3.1, wine-staging 4.12, Virtual Box 5.2.32 & 6.0.10, Pale Moon 28.6.1, Waterfox 56.2.12
User avatar
Posts: 11007
Joined: 2009-10-06 05:53


Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests