apt update with packages.sury.org

Kernels & Hardware, configuring network, installing services

apt update with packages.sury.org

Postby miasdav » 2018-12-25 10:05

Hi everyone,

"apt-get update" crash because of I added the repo https://packages.sury.org/php/
My objectif is to install PHP7.2.

RESULT OF "apt-get update" :

Code: Select all
root@staging:/etc/apt# apt-get update
Ign:1 https://packages.sury.org/php stretch InRelease
Ign:2 https://packages.sury.org/php stretch Release
Ign:3 https://packages.sury.org/php stretch/main all Packages
Ign:4 https://packages.sury.org/php stretch/main i386 Packages
Ign:5 http://deb.debian.org/debian stretch InRelease
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Hit:7 http://deb.debian.org/debian stretch-updates InRelease
Ign:8 https://packages.sury.org/php stretch/main Translation-en_US
Hit:9 http://deb.debian.org/debian stretch Release
Ign:3 https://packages.sury.org/php stretch/main all Packages
Hit:10 http://security.debian.org stretch/updates InRelease
Ign:4 https://packages.sury.org/php stretch/main i386 Packages
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:8 https://packages.sury.org/php stretch/main Translation-en_US
Ign:3 https://packages.sury.org/php stretch/main all Packages
Ign:4 https://packages.sury.org/php stretch/main i386 Packages
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:8 https://packages.sury.org/php stretch/main Translation-en_US
Ign:3 https://packages.sury.org/php stretch/main all Packages
Ign:4 https://packages.sury.org/php stretch/main i386 Packages
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:8 https://packages.sury.org/php stretch/main Translation-en_US
Ign:3 https://packages.sury.org/php stretch/main all Packages
Ign:4 https://packages.sury.org/php stretch/main i386 Packages
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:8 https://packages.sury.org/php stretch/main Translation-en_US
Ign:3 https://packages.sury.org/php stretch/main all Packages
Err:4 https://packages.sury.org/php stretch/main i386 Packages

Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:8 https://packages.sury.org/php stretch/main Translation-en_US
Reading package lists... Done
W: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch https://packages.sury.org/php/dists/stretch/main/binary-i386/Packages
E: Some index files failed to download. They have been ignored, or old ones used instead.




Some info on my system :
Debian GNU/Linux 9.6 (stretch)


Files in /etc/apt :

Code: Select all
root@staging:/etc/apt# ls -lR
.:
total 76
drwxr-xr-x 2 root root  4096 Dec 24 15:18 apt.conf.d
-rw-r--r-- 1 root root    99 Jun  8  2017 listchanges.conf
drwxr-xr-x 2 root root  4096 Dec 23 12:51 preferences.d
-rw-r--r-- 1 root root  1510 Dec 25 11:01 sources.list
drwxr-xr-x 2 root root  4096 Dec 25 12:46 sources.list.d
-rw-r--r-- 1 root root 43318 Dec 25 11:35 trusted.gpg
-rw-r--r-- 1 root root  6083 Dec 23 12:44 trusted.gpg~
drwxr-xr-x 2 root root  4096 Dec 25 12:47 trusted.gpg.d

./apt.conf.d:
total 28
-rw-r--r-- 1 root root   82 Jun  8  2017 00CDMountPoint
-rw-r--r-- 1 root root   40 Jun  8  2017 00trustcdrom
-rw-r--r-- 1 root root  769 Jun  1  2017 01autoremove
-r--r--r-- 1 root root 1824 Dec 23 12:40 01autoremove-kernels
-rw-r--r-- 1 root root  202 Apr 11  2017 20listchanges
-rw-r--r-- 1 root root   87 Jan 30  2016 30autoproxy
-rw-r--r-- 1 root root  182 Mar 19  2015 70debconf

./preferences.d:
total 0

./sources.list.d:
total 4
-rw-r--r-- 1 root root 48 Dec 25 11:07 php7.2.list

./trusted.gpg.d:
total 32
-rw-r--r-- 1 root root 7483 May 25  2017 debian-archive-stretch-automatic.gpg
-rw-r--r-- 1 root root 7492 May 25  2017 debian-archive-stretch-security-automatic.gpg
-rw-r--r-- 1 root root 2275 May 25  2017 debian-archive-stretch-stable.gpg
-rw-r--r-- 1 root root 3780 Nov 30  2014 debian-archive-wheezy-automatic.gpg
-rw-r--r-- 1 root root 2851 Nov 30  2014 debian-archive-wheezy-stable.gpg
-rw-r--r-- 1 root root 2239 Nov  2 13:40 php.gpg



vi sources.list :
Code: Select all
deb http://deb.debian.org/debian/ stretch main
deb-src http://deb.debian.org/debian/ stretch main
deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main
deb http://deb.debian.org/debian/ stretch-updates main
deb-src http://deb.debian.org/debian/ stretch-updates main


vi sources.list.d/php7.2.list :
Code: Select all
deb https://packages.sury.org/php/ stretch main



I am looking for a solution for 3 days, I need your help.
THANK YOU VERY MUCH
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby Head_on_a_Stick » 2018-12-25 11:20

"French riots get results! U lot are instagram zzzombies" — graffiti over Euston underpass
User avatar
Head_on_a_Stick
 
Posts: 8590
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: apt update with packages.sury.org

Postby miasdav » 2018-12-25 13:03

Thank you Head_on_a_Stick.
I did this 50 times.
Like you can see, I have the file php.gpg and the php.list

I did the same installation in another server debian Jessie, everything works.
I think I have a problem in my configuration but I don't know the command to reset apt. (I did apt-get clear, and delete all the list file)
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby Head_on_a_Stick » 2018-12-25 13:29

miasdav wrote:Like you can see, I have the file php.gpg and the php.list

Oh, sorry.

The Release.gpg file is definitely there:

https://packages.sury.org/php/dists/stretch/

Perhaps ask the repository maintainers?
"French riots get results! U lot are instagram zzzombies" — graffiti over Euston underpass
User avatar
Head_on_a_Stick
 
Posts: 8590
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: apt update with packages.sury.org

Postby miasdav » 2018-12-25 14:05

I download the Release.gpg into trusted.gpg.d/

The apt-get update give me more errors :

Code: Select all
root@staging:/etc/apt/trusted.gpg.d# apt-get update
Ign:1 https://packages.sury.org/php stretch InRelease
Ign:2 https://packages.sury.org/php stretch Release
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Hit:7 http://security.debian.org stretch/updates InRelease
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:8 http://deb.debian.org/debian stretch InRelease
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Get:9 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]
Err:7 http://security.debian.org stretch/updates InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Err:9 http://deb.debian.org/debian stretch-updates InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Err:3 https://packages.sury.org/php stretch/main i386 Packages

Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Hit:10 http://deb.debian.org/debian stretch Release
Err:11 http://deb.debian.org/debian stretch Release.gpg
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
Reading package lists... Done
W: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://security.debian.org stretch/updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://deb.debian.org/debian stretch-updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://deb.debian.org/debian stretch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
W: Failed to fetch http://security.debian.org/dists/stretch/updates/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: Failed to fetch http://deb.debian.org/debian/dists/stretch-updates/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
E: Failed to fetch https://packages.sury.org/php/dists/stretch/main/binary-i386/Packages
W: Failed to fetch http://deb.debian.org/debian/dists/stretch/Release.gpg  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
W: Some index files failed to download. They have been ignored, or old ones used instead.
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby Head_on_a_Stick » 2018-12-25 14:09

^ We had a thread about that yesterday:

viewtopic.php?f=17&t=139397
"French riots get results! U lot are instagram zzzombies" — graffiti over Euston underpass
User avatar
Head_on_a_Stick
 
Posts: 8590
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: apt update with packages.sury.org

Postby miasdav » 2018-12-25 21:34

It's not really the same probleme.
And when I want to add the KEY with :
Code: Select all
gpg --keyserver pgpkeys.mit.edu --recv-keys <KEY>
gpg --armor --export <KEY> | apt-key add -

I get an error.
But I think the Release.gpg don't fix my problem...
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby miasdav » 2018-12-30 07:33

Nobody can help ? :cry:
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby Head_on_a_Stick » 2018-12-30 09:57

miasdav wrote:when I want to add the KEY with :
Code: Select all
gpg --keyserver pgpkeys.mit.edu --recv-keys <KEY>
gpg --armor --export <KEY> | apt-key add -

I get an error

Post the error.

I wrote:Perhaps ask the repository maintainers?

^ This.
"French riots get results! U lot are instagram zzzombies" — graffiti over Euston underpass
User avatar
Head_on_a_Stick
 
Posts: 8590
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: apt update with packages.sury.org

Postby miasdav » 2018-12-30 21:06

Code: Select all
root@staging:/etc/apt# wget -q https://packages.sury.org/php/dists/stretch/Release.gpg -O- | apt-key add -
gpg: no valid OpenPGP data found.


If I download the file Release.gpg into trusted.gpg.d
Code: Select all
root@staging:/etc/apt/trusted.gpg.d# ll
total 16
-rw-r--r-- 1 root root  833 Dec 19 11:57 Release.gpg


Code: Select all
root@staging:/etc/apt/trusted.gpg.d# apt-key list
/etc/apt/trusted.gpg
--------------------
pub   rsa4096 2017-05-20 [SC] [expires: 2025-05-18]
      067E 3C45 6BAE 240A CEE8  8F6F EF0F 382A 1A7B 6500
uid           [ unknown] Debian Stable Release Key (9/stretch) <debian-release@lists.debian.org>

pub   rsa4096 2012-04-27 [SC] [expires: 2020-04-25]
      A1BD 8E9D 78F7 FE5C 3E65  D8AF 8B48 AD62 4692 5553
uid           [ unknown] Debian Archive Automatic Signing Key (7.0/wheezy) <ftpmaster@debian.org>

pub   rsa4096 2014-09-09 [SC]
      DF3D 585D B8F0 EB65 8690  A554 AC0E 4758 4A7A 714D
uid           [ unknown] CZ.NIC Labs Archive Automatic Signing Key <ftpmaster@labs.nic.cz>
sub   rsa4096 2014-09-09 [E]



The Release.gpg is not recogniz like a key
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby miasdav » 2018-12-30 21:07

Head_on_a_Stick wrote:
I wrote:Perhaps ask the repository maintainers?

^ This.


Sury ask to me dollars to help me..... Thank you Sury...
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52

Re: apt update with packages.sury.org

Postby reinob » 2018-12-31 10:40

miasdav wrote:I download the Release.gpg into trusted.gpg.d/

The apt-get update give me more errors :

Code: Select all
root@staging:/etc/apt/trusted.gpg.d# apt-get update
Ign:1 https://packages.sury.org/php stretch InRelease
Ign:2 https://packages.sury.org/php stretch Release
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Hit:7 http://security.debian.org stretch/updates InRelease
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:8 http://deb.debian.org/debian stretch InRelease
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Get:9 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]
Err:7 http://security.debian.org stretch/updates InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Err:9 http://deb.debian.org/debian stretch-updates InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Ign:3 https://packages.sury.org/php stretch/main i386 Packages
Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Err:3 https://packages.sury.org/php stretch/main i386 Packages

Ign:4 https://packages.sury.org/php stretch/main all Packages
Ign:5 https://packages.sury.org/php stretch/main Translation-en_US
Ign:6 https://packages.sury.org/php stretch/main Translation-en
Hit:10 http://deb.debian.org/debian stretch Release
Err:11 http://deb.debian.org/debian stretch Release.gpg
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
Reading package lists... Done
W: The repository 'https://packages.sury.org/php stretch Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://security.debian.org stretch/updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://deb.debian.org/debian stretch-updates InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://deb.debian.org/debian stretch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
W: Failed to fetch http://security.debian.org/dists/stretch/updates/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 9D6D8F6BC857C906 NO_PUBKEY 8B48AD6246925553
W: Failed to fetch http://deb.debian.org/debian/dists/stretch-updates/InRelease  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010
E: Failed to fetch https://packages.sury.org/php/dists/stretch/main/binary-i386/Packages
W: Failed to fetch http://deb.debian.org/debian/dists/stretch/Release.gpg  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010 NO_PUBKEY EF0F382A1A7B6500
W: Some index files failed to download. They have been ignored, or old ones used instead.


Did you wipe the /etc/apt/trusted.gpg.d/ directory?
It looks like you don't even have the gpg keys for the standard debian repositories.
We cannot know what you've done, but surely the above errors didn't just occur by themselves.

Good luck with the new year's reinstallation.
reinob
 
Posts: 589
Joined: 2014-06-30 11:42

Re: apt update with packages.sury.org

Postby miasdav » 2019-01-01 14:10

The problem is not relativ to trusted or not, I had the repo [trusted=yes] I have the same problem : failed to fetch... without error after the name of file :

E: Failed to fetch https://packages.sury.org/php/dists/str ... 6/Packages [no error here]
E: Some index files failed to download. They have been ignored, or old ones used instead.
miasdav
 
Posts: 8
Joined: 2018-12-25 09:52


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable