amavis no longer works

Kernels & Hardware, configuring network, installing services

amavis no longer works

Postby mda » 2018-12-25 21:21

can not speak with it with telnet:
Code: Select all
root@smtp:/var/log# telnet localhost 10025
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 smtp.amsystems.co.uk  ESMTP
ehlo a
250-server.amsystems.co.uk
250-STARTTLS
250 8BITMIME
quit
221 2.0.0 Bye
Connection closed by foreign host.
root@smtp:/var/log# telnet localhost 10024
Trying ::1...
Connected to localhost.
Escape character is '^]'.
ehlo a
quit


the amavis.log is showing this, but this are the last lines, it never shows more:
Code: Select all
root@smtp:/var/log# tail -f amavis.log
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21278]: extra modules loaded after daemonizing/chrooting: /etc/perl/Net/libnet.cfg, /etc/spamassassin/Fromnamespoof.pm, /etc/spamassassin/HashBL.pm, /etc/spamassassin/plugins/FromAndReplyToIsNotSameDomain.pm, /etc/spamassassin/plugins/FromIsNotReplyTo.pm, /etc/spamassassin/plugins/FromIsNotReplyToWhitelist.pm, /etc/spamassassin/plugins/FromIsReplyTo.pm, /etc/spamassassin/plugins/FromIsTo.pm, Mail/SpamAssassin/CompiledRegexps/body_0.pm, Mail/SpamAssassin/Plugin/FreeMail.pm, Mail/SpamAssassin/Plugin/Phishing.pm, Mail/SpamAssassin/Plugin/SpamCop.pm, Net/Cmd.pm, Net/Config.pm, Net/SMTP.pm
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21278]: Net::Server: Beginning prefork (2 processes)
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21278]: Net::Server: Starting "2" children
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21300]: Net::Server: Child Preforked (21300)
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21278]: Net::Server: Parent ready for children.
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21300]: entered child_init_hook
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21300]: SpamControl: init_child on SpamAssassin done
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21301]: Net::Server: Child Preforked (21301)
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21301]: entered child_init_hook
Dec 25 21:53:16 amsystems.co.uk /usr/sbin/amavisd-new[21301]: SpamControl: init_child on SpamAssassin done


nothing in postfix log, mailq is showing:
Code: Select all
connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)


did not do any change in the system as far as I remember, the only thing was update in debian jessie but it was quite few days back and everything worked:
Code: Select all
Start-Date: 2018-12-17  13:43:38
Commandline: apt-get upgrade
Upgrade: libapache2-mod-php5:i386 (5.6.38+dfsg-0+deb8u1, 5.6.39+dfsg-0+deb8u1), gcc-4.9-base:i386 (4.9.2-10+deb8u1, 4.9.2-10+deb8u2), libquadmath0:i386 (4.9.2-10+deb8u1, 4.9.2-10+deb8u2), php5-readline:i386 (5.6.38+dfsg-0+deb8u1, 5.6.39+d
End-Date: 2018-12-17  13:44:28


any clue?
mda
 
Posts: 8
Joined: 2016-08-09 09:31

Re: amavis no longer works

Postby mda » 2018-12-25 21:27

sory the telnet for the amavis code was uploaded wronly (it's postfix) so adding proper amavis telnet response here:
Code: Select all
root@smtp:/var/log# telnet localhost 10024
Trying ::1...
Connected to localhost.
Escape character is '^]'.
ehlo localhost
root@smtp:/var/log# telnet localhost 10024
Trying ::1...
Connected to localhost.
Escape character is '^]'.
ehlo localhost
^]


no response no matter what I type
mda
 
Posts: 8
Joined: 2016-08-09 09:31

Re: amavis no longer works

Postby mda » 2018-12-25 21:28

from mail.log
Code: Select all
Dec 25 22:16:31 smtp postfix/smtp[21913]: 29B3F3C1661: to=<clamav@amsystems.co.uk>, orig_to=<clamav>, relay=127.0.0.1[127.0.0.1]:10024, delay=16592, delays=16292/0.07/300/0, dsn=4.4.2, status=deferred (conversation with 127.0.0.1[127.0.0.1] timed out while receiving the initial server greeting)
mda
 
Posts: 8
Joined: 2016-08-09 09:31

Re: amavis no longer works

Postby mda » 2018-12-25 21:32

Code: Select all
root@smtp:/var/log# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:10025         *:*                     LISTEN      21710/master
tcp        0      0 localhost:spamd         *:*                     LISTEN      21744/perl
tcp        0      0 *:smtp                  *:*                     LISTEN      21710/master
tcp        0      0 localhost:33307         localhost:10024         FIN_WAIT2   -
tcp        1      0 localhost:10024         localhost:33305         CLOSE_WAIT  -
tcp        0     92 10.0.0.8:smtp           server.nakupnigal:58888 FIN_WAIT1   -
tcp        0      0 localhost:33309         localhost:10024         ESTABLISHED 21913/smtp
tcp        0    262 10.0.0.8:smtp           30.subnet-103.23.:35237 ESTABLISHED 21917/smtpd
tcp        1      0 localhost:10024         localhost:33306         CLOSE_WAIT  -
tcp        1      0 localhost:10024         localhost:33307         CLOSE_WAIT  -
tcp        0      0 localhost:10024         localhost:33309         ESTABLISHED -
tcp6       0      0 localhost:spamd         [::]:*                  LISTEN      21744/perl
tcp6       0      0 localhost:10024         [::]:*                  LISTEN      21797/amavisd-new (
tcp6     424      0 localhost:10024         localhost:38157         ESTABLISHED -
tcp6       0      0 localhost:38157         localhost:10024         ESTABLISHED 21934/telnet
mda
 
Posts: 8
Joined: 2016-08-09 09:31

Re: amavis no longer works

Postby mda » 2018-12-25 21:40

OF course restarted amavis, postfix, spamassassin many times...
mda
 
Posts: 8
Joined: 2016-08-09 09:31

Re: amavis no longer works

Postby mda » 2018-12-25 22:13

I will get some sleep and most likely reinstall hence no other option here :(
mda
 
Posts: 8
Joined: 2016-08-09 09:31


Return to System configuration

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable