[Debian 9 (stretch)] E: Unable to locate package docker-ce

Kernels & Hardware, configuring network, installing services

[Debian 9 (stretch)] E: Unable to locate package docker-ce

Postby Bitspark » 2018-12-27 09:58

Hello,

Linux/Debian newbie here. I’ve been trying to install docker on a debian machine following these instructions: https://docs.docker.com/install/linux/docker-ce/debian/

Everything works, up untill the point where docker is actually installed using:

Code: Select all
$ sudo apt-get install docker-ce


i’m getting the following in response:

Code: Select all
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package docker-ce


Anyone a clue on what this might be?

I’m running Debian GNU/Linux 9 (stretch)on a 64-bit i5 machine.
Kernel: Linux 4.9.0-8-686-pae

Steps undertaken:

checked repositories, original installation, only docker line added. they seem to match:

Code: Select all
deb http://ftp.nl.debian.org/debian/ stretch main
deb-src http://ftp.nl.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.nl.debian.org/debian/ stretch-updates main

# deb-src [arch=amd64] https://download.docker.com/linux/debian stretch stable
deb-src http://ftp.nl.debian.org/debian/ stretch-updates main

# docker repo
deb [arch=amd64] https://download.docker.com/linux/debian stretch stable


checked the fingerprint, seems to match:
Code: Select all
apt-key fingerprint 0EBFCD88
pub   rsa4096 2017-02-22 [SCEA]
      9DC8 5822 9FC7 DD38 854A  E2D8 8D81 803C 0EBF CD88
uid           [ unknown] Docker Release (CE deb) <docker@docker.com>
sub   rsa4096 2017-02-22 [S]


Can someone point me in the right direction perhaps? Thanks for your advice.
Bitspark
 
Posts: 5
Joined: 2018-12-27 09:55

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Head_on_a_Stick » 2018-12-27 10:30

Bitspark wrote:Anyone a clue on what this might be?

Did you remember to update the package database after adding the new repository?
Code: Select all
# apt update

I like to use `apt edit-sources` to add new repositories, that reminds you to update afterwards.
User avatar
Head_on_a_Stick
 
Posts: 10321
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Bitspark » 2018-12-27 12:21

yes, i did
Code: Select all
apt-get update

a couple of times.

Just now:
Code: Select all
root@Optimus:~# apt update
Get:1 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Ign:2 http://ftp.nl.debian.org/debian stretch InRelease
Hit:3 http://ftp.nl.debian.org/debian stretch-updates InRelease
Hit:4 http://ftp.nl.debian.org/debian stretch Release
Hit:5 https://download.docker.com/linux/debian stretch InRelease
Get:6 http://security.debian.org/debian-security stretch/updates/main Sources [188 kB]
Get:8 http://security.debian.org/debian-security stretch/updates/main armhf Packages [448 kB]
Get:9 http://security.debian.org/debian-security stretch/updates/main i386 Packages [464 kB]
Get:10 http://security.debian.org/debian-security stretch/updates/main Translation-en [202 kB]
Fetched 1,397 kB in 4s (298 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.


After this, the install still says the same (unable to locate package).

I've noticed something that maybe you can explain. I've seen different notations of the repository line for docker:
Code: Select all
# docker repo
deb [arch=amd64] https://download.docker.com/linux/debian stretch stable
# deb-src [arch=amd64] https://download.docker.com/linux/debian stretch stable


the upper one is what i'm using from the docker site itsself. the lower one (stating deb-src) is from a linux install site on howto install docker (https://linuxconfig.org/how-to-install- ... etch-linux).

which repository should be used?
Bitspark
 
Posts: 5
Joined: 2018-12-27 09:55

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Head_on_a_Stick » 2018-12-27 12:26

Bitspark wrote:which repository should be used?

The plain deb line, "deb-src" will contain the source code.

The man page examples have spaces around the square brackets that declare the architecture but I don't think that would make any difference.

How about
Code: Select all
aptitude search docker
User avatar
Head_on_a_Stick
 
Posts: 10321
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Bitspark » 2018-12-27 12:57

thanks for helping me further down this rabbit hole.

provides a whole lot of packages.
Code: Select all
root@Optimus:~# apt search docker
Sorting... Done
Full Text Search... Done
auto-apt-proxy/stable,stable 2+deb9u1 all
  automatic detector of common APT proxy settings

ctop/stable,stable 1.0.0-2 all
  Command line / text based Linux Containers monitoring tool

debocker/stable,stable 0.2.1 all
  docker-powered package builder for Debian

debootstick/stable 1.2 i386
  Turn a chroot environment into a bootable image

docker/stable 1.5-1+b1 i386
  System tray for KDE3/GNOME2 docklet applications

[b]docker-ce/stretch 5:18.09.0~3-0~debian-stretch amd64
  Docker: the open-source application container engine[/b]

docker-ce-cli/stretch 5:18.09.0~3-0~debian-stretch amd64
  Docker CLI: the open-source application container engine

docker-compose/stable,stable 1.8.0-2 all
  Punctual, lightweight development environments using Docker

dumb-init/stable 1.2.0-1 i386
  wrapper script which proxies signals to a child

fence-agents/stable 4.0.25-1 i386
  Fence Agents for Red Hat Cluster

golang-docker-credential-helpers/stable 0.3.0+git20160601.0.5128fa1-1+b2 i386
  Use native stores to safeguard Docker credentials

golang-github-docker-docker-credential-helpers-dev/stable,stable 0.3.0+git20160601.0.5128fa1-1 all
  Use native stores to safeguard Docker credentials

golang-github-docker-go-connections-dev/stable,stable 0.2.1-1 all
  Golang utility package to work with network connections

golang-github-docker-go-dev/stable,stable 0.0~git20160303.0.d30aec9-3 all
  Go packages with small patches autogenerated (used for canonical/json)

golang-github-docker-go-events-dev/stable,stable 0.0~git20160331.0.882f161-1 all
  Composable event distribution for Go

golang-github-docker-go-units-dev/stable,stable 0.3.1-1 all
  parse and print size and time units in human-readable format

golang-github-docker-libtrust-dev/stable,stable 0.0~git20150526.0.9cbd2a1-1 all
  Primitives for identity and authorization

golang-github-docker-spdystream-dev/stable,stable 0.0~git20151103.0.4d80814-1 all
  multiplexed stream library using spdy

golang-github-endophage-gotuf-dev/stable,stable 0.0~git20151020.0.2df1c8e-1 all
  Go implementation of the TUF specification

golang-github-hashicorp-go-reap-dev/stable,stable 0.0~git20160113.0.2d85522-2 all
  child process reaping utilities for Go

golang-github-jfrazelle-go-dev/stable,stable 0.0~git20160303.0.d30aec9-3 all
  Transitional package for golang-github-docker-go-dev

golang-github-opencontainers-runc-dev/stable,stable 0.1.1+dfsg1-2 all
  Open Container Project - develpoment files

golang-github-vishvananda-netlink-dev/stable,stable 0.0~git20160629.0.e73bad4-1 all
  netlink library for go

gosu/stable 1.10-1+b2 i386
  Simple Go-based setuid+setgid+setgroups+exec

itamae/stable,stable 1.9.10-1 all
  Simple Configuration Management Tool

karbon/stable 1:2.9.11+dfsg-4+b1 i386
  vector graphics application for the Calligra Suite

kdocker/stable 5.0-1+b1 i386
  lets you dock any application into the system tray

libcib-dev/stable 1.1.16-1 i386
  cluster resource manager CIB library development

libcib4/stable 1.1.16-1 i386
  cluster resource manager CIB library

libcrmcluster-dev/stable 1.1.16-1 i386
  cluster resource manager cluster library development

libcrmcluster4/stable 1.1.16-1 i386
  cluster resource manager cluster library

libcrmcommon-dev/stable 1.1.16-1 i386
  cluster resource manager common library development

libcrmcommon3/stable 1.1.16-1 i386
  cluster resource manager common library

libcrmservice-dev/stable 1.1.16-1 i386
  cluster resource manager service library development

libcrmservice3/stable 1.1.16-1 i386
  cluster resource manager service library

liblrmd-dev/stable 1.1.16-1 i386
  cluster resource manager LRMD library development

liblrmd1/stable 1.1.16-1 i386
  cluster resource manager LRMD library

libnss-docker/stable 0.02-1 i386
  nss module for finding Docker containers

libpe-rules2/stable 1.1.16-1 i386
  cluster resource manager Policy Engine rules library

libpe-status10/stable 1.1.16-1 i386
  cluster resource manager Policy Engine status library

libpengine-dev/stable 1.1.16-1 i386
  cluster resource manager Policy Engine library development

libpengine10/stable 1.1.16-1 i386
  cluster resource manager Policy Engine library

libstonithd-dev/stable 1.1.16-1 i386
  cluster resource manager STONITH daemon library development

libstonithd2/stable 1.1.16-1 i386
  cluster resource manager STONITH daemon library

libtransitioner2/stable 1.1.16-1 i386
  cluster resource manager transitioner library

magnum-api/stable,stable 3.1.1-5 all
  OpenStack containers as a service

magnum-common/stable,stable 3.1.1-5 all
  OpenStack containers as a service - API server

magnum-conductor/stable,stable 3.1.1-5 all
  OpenStack containers as a service - conductor

needrestart/stable,stable 2.11-3+deb9u1 all
  check which daemons need to be restarted after library upgrades

ovn-docker/stable 2.6.2~pre+git20161223-3 i386
  OVN Docker drivers

pacemaker/stable 1.1.16-1 i386
  cluster resource manager

pacemaker-cli-utils/stable 1.1.16-1 i386
  cluster resource manager command line utilities

pacemaker-common/stable,stable 1.1.16-1 all
  cluster resource manager common files

pacemaker-doc/stable,stable 1.1.16-1 all
  cluster resource manager HTML documentation

pacemaker-remote/stable 1.1.16-1 i386
  cluster resource manager proxy daemon for remote nodes

pacemaker-resource-agents/stable,stable 1.1.16-1 all
  cluster resource manager general resource agents

packer/stable 0.10.2+dfsg-6 i386
  tool for creating machine images for multiple platforms

python-ck/stable,stable 1.7.2-1 all
  Python2 light-weight knowledge manager

python-docker/stable,stable 1.9.0-1 all
  Python wrapper to access docker.io's control socket

python-dockerpty/stable,stable 0.4.1-1 all
  Pseudo-tty handler for docker Python client (Python 2.x)

python-dockerpycreds/stable,stable 0.2.1-1 all
  Python bindings for the docker credentials store API

python-magnum/stable,stable 3.1.1-5 all
  OpenStack containers as a service - Python library

python-magnumclient/stable,stable 2.3.1-1 all
  client library for Magnum API - Python 2.x

python-magnumclient-doc/stable,stable 2.3.1-1 all
  client library for Magnum API - doc

python3-ck/stable,stable 1.7.2-1 all
  Python3 light-weight knowledge manager

python3-docker/stable,stable 1.9.0-1 all
  Python 3 wrapper to access docker.io's control socket

python3-dockerpty/stable,stable 0.4.1-1 all
  Pseudo-tty handler for docker Python client (Python 3.x)

python3-dockerpycreds/stable,stable 0.2.1-1 all
  Python3 bindings for the docker credentials store API

python3-magnumclient/stable,stable 2.3.1-1 all
  client library for Magnum API - Python 3.x

rawdns/stable 1.6~ds1-1+b2 i386
  raw DNS interface to the Docker API

resource-agents/stable 1:4.0.0~rc1-4 i386
  Cluster Resource Agents

ruby-docker-api/stable,stable 1.22.2-1 all
  Ruby gem to interact with docker.io remote API

sen/stable,stable 0.5.0-1 all
  Terminal user interface for docker engine

test-kitchen/stable,stable 1.11.1-1 all
  integration tool for Chef

wait-for-it/stable,stable 0.0~git20160501-1 all
  script that will wait on the availability of a host and TCP port



when looking for specific docker packages i get this:
Code: Select all
root@Optimus:~# apt-cache pkgnames dock
docker-compose
docker
docky
docker-ce
docker-ce-cli

So it seems, the packages are on the system? What am I missing then, are there other packages on which docker depends? I've installed Debian from the netinstall (usb stick).
Bitspark
 
Posts: 5
Joined: 2018-12-27 09:55

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Head_on_a_Stick » 2018-12-27 17:56

I have no idea why APT has the package in the database but can't install it, that is most perplexing :?

You could try installing the .deb directly instead:

https://download.docker.com/linux/debia ... ble/amd64/
User avatar
Head_on_a_Stick
 
Posts: 10321
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby stevepusser » 2018-12-27 20:03

You say you are running the "pae" kernel, which is only for 32-bit systems. Did you maybe install a 32-bit system in error, which is possible on a 64-bit machine?

Run "dpkg --print-architecture" to see what you've got.

If you do have a 32-bit install, do you need some facepalm gifs?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Foliate 1.5.3, Minitube 3.1, wine-staging 4.12, Virtual Box 5.2.32 & 6.0.10, Pale Moon 28.6.1, Waterfox 56.2.12
User avatar
stevepusser
 
Posts: 11007
Joined: 2009-10-06 05:53

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Bitspark » 2018-12-29 10:09

ehm :? let's see, I should have the 64bit installed...

Code: Select all
root@Optimus:~# dpkg --print-architecture
i386


please tell me this is 64Bit?

checking google on howto check;

Code: Select all
root@Optimus:~# uname -a
Linux Optimus 4.9.0-8-686-pae #1 SMP Debian 4.9.130-2 (2018-10-27) i686 GNU/Linux


Now, i'm going to grab a chair and do some self reflection, in my face :). If I read your comment correctly, I've installed a 32Bit version, reading the PAE part in the version string.

...

@self: welcome to the debian newbie group.

next up; howto get 64 bit installed?
Bitspark
 
Posts: 5
Joined: 2018-12-27 09:55

Re: [Debian 9 (stretch)] E: Unable to locate package docker-

Postby Bitspark » 2018-12-29 12:36

ok, duh! so stupid... grabbed the wrong install packages from debian.org.

installed amd64 now;
Code: Select all
root@Optimus:~# uname -a
Linux Optimus 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux


let's see if we can get docker to run this time
Bitspark
 
Posts: 5
Joined: 2018-12-27 09:55


Return to System configuration

Who is online

Users browsing this forum: fender0107401 and 8 guests

fashionable