systemd: how to disable autofs4 module

Kernels & Hardware, configuring network, installing services

systemd: how to disable autofs4 module

Postby manmath » 2019-01-19 10:39

My system is working perfectly fine except an error message while booting:
Code: Select all
systemd: Failed to load module autofs4

I don't have autofs module and I know I don't need that. Mine is custom kernel stripped off of all the unnecessary modules. And my system doesn't have initrd and kmod. I did try to blacklist this module, but nothing to my avail.
Would anybody please suggest how to suppress this message, in other words, what should I do so that systemd doesn't check autofs4 module?
manmath
 
Posts: 118
Joined: 2009-11-26 07:16

Re: systemd: how to disable autofs4 module

Postby Head_on_a_Stick » 2019-01-19 11:11

https://github.com/systemd/systemd/issues/9501 & https://bugs.debian.org/cgi-bin/bugrepo ... bug=902946 — please search before posting here.

@Wheelerof4te, looks like those kernel devs are breaking stuff again... :D
User avatar
Head_on_a_Stick
 
Posts: 10346
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: systemd: how to disable autofs4 module

Postby p.H » 2019-01-19 11:49

manmath wrote:how to suppress this message

If kmod was installed, you could have used the "install" command in an /etc/modprobe.d/*.conf file to run some command which returns success. Without kmod, I guess you can create a {/usr/local}/sbin/modprobe symlink pointing to /bin/true.
p.H
 
Posts: 1036
Joined: 2017-09-17 07:12

Re: systemd: how to disable autofs4 module

Postby Segfault » 2019-01-19 12:23

Head_on_a_Stick wrote:https://github.com/systemd/systemd/issues/9501 & https://bugs.debian.org/cgi-bin/bugrepo ... bug=902946 — please search before posting here.

@Wheelerof4te, looks like those kernel devs are breaking stuff again... :D

What this issue has to do with kernel devs? :?
Segfault
 
Posts: 903
Joined: 2005-09-24 12:24

Re: systemd: how to disable autofs4 module

Postby llivv » 2019-01-19 13:19

How I learned to love the dep~bloat
see also: auto5 []6 []7 end []8

p.H is that what is called a dirty hack?

:idea:
In memory of Ian Ashley Murdock (1973 - 2015) founder of the Debian project.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Re: systemd: how to disable autofs4 module

Postby Head_on_a_Stick » 2019-01-19 13:37

Segfault wrote:What this issue has to do with kernel devs? :?

Read Lennart's comments in the linked bug report.

And sorry for the off-topic wind-up.
User avatar
Head_on_a_Stick
 
Posts: 10346
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: systemd: how to disable autofs4 module

Postby p.H » 2019-01-19 17:32

llivv wrote:p.H is that what is called a dirty hack?

I guess so. It is intended to suppress the message, not the cause. But after reading HoaS' link I am not even sure it works.
p.H
 
Posts: 1036
Joined: 2017-09-17 07:12

Re: systemd: how to disable autofs4 module

Postby bw123 » 2019-01-19 22:47

...
I don't have autofs module and I know I don't need that. Mine is custom kernel stripped off of all the unnecessary modules.
...


How did you determine which modules were unnecessary? Have you considered that maybe autofs is necessary for systemd to function correctly with your current settings?

In any case, version of systemd would be bare minimum, (and kernel source ver?) to link the issue to the bug report/controversy mentioned?

These threads pointing out contoversies/conflicts among devs seem much more common lately, but do not affect debian stable users so far FWICT. Some people just like to stir the pot, but if you take away the controversy, usually you just need to post more facts to help the forum solve a problem together.
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: systemd: how to disable autofs4 module

Postby manmath » 2019-01-20 00:06

Thank you all. I tried the suggestions but still that error message is there. And yes, my problem is the same as mentioned in bugzilla.
manmath
 
Posts: 118
Joined: 2009-11-26 07:16


Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable