ping reports "system error"

Kernels & Hardware, configuring network, installing services

Re: ping reports "system error"

Postby p.H » 2019-01-27 17:40

Is it the ping utility from iputils or inetutils ?
Code: Select all
dpkg -S $(which ping)
p.H
 
Posts: 1046
Joined: 2017-09-17 07:12

Re: ping reports "system error"

Postby hbauer » 2019-01-27 17:44

bw123 wrote:Breaking a system tool and then asking what broke it isn't really a good way to go about solving it. Post a lot of info, after you check it first, of course.


This is right after the install. No additional stuff was installed. I can uninstall sudo or traceroute but I really believe this is not the root cause for this.
hbauer
 
Posts: 29
Joined: 2015-10-26 15:38

Re: ping reports "system error"

Postby hbauer » 2019-01-27 17:44

p.H wrote:Is it the ping utility from iputils or inetutils ?
Code: Select all
dpkg -S $(which ping)


Code: Select all
dpkg -S $(which ping)
iputils-ping: /bin/ping
hbauer
 
Posts: 29
Joined: 2015-10-26 15:38

Re: ping reports "system error"

Postby bw123 » 2019-01-27 18:00

hbauer wrote:
bw123 wrote:Breaking a system tool and then asking what broke it isn't really a good way to go about solving it. Post a lot of info, after you check it first, of course.


This is right after the install. No additional stuff was installed. I can uninstall sudo or traceroute but I really believe this is not the root cause for this.


So what installed mdns and added the [NOTFOUND=RETURN] stuff? was that in the guide somewhere? dnsutils pkg is needed for nslookup? All this was a fresh install?

sudo or traceroute not in guide either? How they got installed?

I don't do the debootstrap thing, but I was thinking it should be a pretty tiny little base system, none of that would be installed?
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: ping reports "system error"

Postby p.H » 2019-01-27 18:37

Maybe try to install inetutils-ping instead ?
p.H
 
Posts: 1046
Joined: 2017-09-17 07:12

Re: ping reports "system error"

Postby hbauer » 2019-01-28 06:02

bw123 wrote:So what installed mdns and added the [NOTFOUND=RETURN] stuff? was that in the guide somewhere? dnsutils pkg is needed for nslookup? All this was a fresh install?

sudo or traceroute not in guide either? How they got installed?


this was part of my attempts to fix it. The error appeared right after installation.
hbauer
 
Posts: 29
Joined: 2015-10-26 15:38

Re: ping reports "system error"

Postby hbauer » 2019-01-28 06:04

p.H wrote:Maybe try to install inetutils-ping instead ?



great that fixed it.

Code: Select all
ping www.debian.org
PING www.debian.org (5.153.231.4): 56 data bytes
64 bytes from 5.153.231.4: icmp_seq=0 ttl=47 time=40,961 ms


I was not aware of the fact that for a tool like ping there are multiple alternatives
hbauer
 
Posts: 29
Joined: 2015-10-26 15:38

Previous

Return to System configuration

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable