(Solv)permission issues in /etc/apt/sources.list.d directory

Kernels & Hardware, configuring network, installing services

(Solv)permission issues in /etc/apt/sources.list.d directory

Postby Moltke » 2019-02-02 21:26

Hi everyone! Hope you're all having a nice life! :D About a week ago I was having some issues trying to add some repo into my system, I googled and found some solutions I tried, just in case I backed up sources.list.d but something went wrong and now if I run
Code: Select all
apt search package_name
I got a permissions error message. It works with sudo but It did without before as it's meant to be. I've been googling about this trying to find a solution, I guess I have to change the permissions with chmod?? Any help/advice is really appreciated. Thanks!

EDIT: My first option was
Code: Select all
sudo chmod 755 /etc/apt/sources.list.d
and after some reading in google and man chmod I realized that was indeed the solution. It was a very easy issue to solve but I was confused. :lol:
Posts: 8
Joined: 2017-03-16 18:10

Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests