"A start job is running for Raise network interfaces" SOLVED

Kernels & Hardware, configuring network, installing services

Re: "A start job is running for Raise network interfaces" SO

Postby jaimet » 2019-10-01 07:11

It turns out that my "boot delay" / "slow boot" / "boot pause" problem was just another instance of the "Boottime Entropy Starvation" issue. (I'm guessing that wpa-supplicant couldn't connect as it was blocking on requesting random data from the kernel, which in turn was blocking on the entropy generator).

I installed the havege daemon ("sudo apt install haveged") and the problem has disappeared! :D :D :D

More info:
https://www.debian.org/releases/stable/ ... starvation
https://daniel-lange.com/archives/152-hello-buster.html
jaimet
 
Posts: 10
Joined: 2019-07-19 08:38

Re: "A start job is running for Raise network interfaces" SO

Postby ab1jx » 2020-11-07 18:58

In Raspbian this is an option in raspi-config, which is just a Bash script calling Whiptail.
Code: Select all
do_boot_wait() {
  DEFAULT=--defaultno
  if [ $(get_boot_wait) -eq 0 ]; then
    DEFAULT=
  fi
  if [ "$INTERACTIVE" = True ]; then
    whiptail --yesno "Would you like boot to wait until a network connection is established?" $DEFAULT 20 60 2
    RET=$?
  else
    RET=$1
  fi
  if [ $RET -eq 0 ]; then
    mkdir -p /etc/systemd/system/dhcpcd.service.d/
    cat > /etc/systemd/system/dhcpcd.service.d/wait.conf << EOF
[Service]
ExecStart=
ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -w
EOF
    STATUS=enabled
  elif [ $RET -eq 1 ]; then
    rm -f /etc/systemd/system/dhcpcd.service.d/wait.conf
    STATUS=disabled
  else
    return $RET
  fi
  if [ "$INTERACTIVE" = True ]; then
    whiptail --msgbox "Waiting for network on boot is $STATUS" 20 60 1
  fi
}
ab1jx
 
Posts: 38
Joined: 2016-01-23 21:28
Location: Heath, MA, USA

Previous

Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable