After VPN installation: I need to login twice

Kernels & Hardware, configuring network, installing services

After VPN installation: I need to login twice

Postby Onsemeliot » 2019-07-19 12:25

Hi together,

after I installed a VPN connection on my Debian 10 (with LUKS whole disc encryption) on my Fujitsu Siemens Lifebook E781 I need to login twice at each boot. First before the graphical user interface is up and secondly (like usual) at the normal graphical login screen.

The first prompt comes right after the network is successfully established:

Code: Select all
...
[  OK  ] Reached target Network is online.
         Starting OpenVPN connection to *...*
Enter Auth Username::

Do you have any idea what might cause this ... or how I could get rid of this annoyance? Should I somehow alter in what order the services during the boot procedure start?
User avatar
Onsemeliot
 
Posts: 225
Joined: 2010-12-15 14:43

Re: After VPN installation: I need to login twice

Postby nulix » 2019-07-19 13:12

you could define the vpn to not start automatically, but i guess you could try to sort it out at openvpn level to see if you can insert that password on a config file... or remove the passkey from a certificate, though that may have security implications.
nulix
 
Posts: 9
Joined: 2019-07-18 10:38

Re: After VPN installation: I need to login twice

Postby Onsemeliot » 2019-07-19 13:29

Thank you for your reply. I will talk to my colleague what would be best in his view.
User avatar
Onsemeliot
 
Posts: 225
Joined: 2010-12-15 14:43

Re: After VPN installation: I need to login twice

Postby Head_on_a_Stick » 2019-07-20 09:52

Which desktop environment (or window manager) are you using?
User avatar
Head_on_a_Stick
 
Posts: 11587
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: After VPN installation: I need to login twice

Postby Onsemeliot » 2019-07-20 12:30

I went with the standard GNOME 3.
User avatar
Onsemeliot
 
Posts: 225
Joined: 2010-12-15 14:43

Re: After VPN installation: I need to login twice

Postby Head_on_a_Stick » 2019-07-20 19:21

Hmm, the GNOME keyring should be handling the password (I think) so try fiddling with Seahorse.
User avatar
Head_on_a_Stick
 
Posts: 11587
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: After VPN installation: I need to login twice

Postby Onsemeliot » 2019-07-21 08:52

Seahorse seems to work just fine. The key and the passphrase are there. It just doesn't seem to be running at that time in the boot process. (After the GUI is up and running I can easily enable the VPN connection without issues.)
User avatar
Onsemeliot
 
Posts: 225
Joined: 2010-12-15 14:43

Re: After VPN installation: I need to login twice

Postby Head_on_a_Stick » 2019-07-21 10:24

Does this help?

I don't use a VPN myself so I can't really help directly, sorry.
User avatar
Head_on_a_Stick
 
Posts: 11587
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: After VPN installation: I need to login twice

Postby Onsemeliot » 2019-09-22 08:44

In the end I just disabled the auto-run at system start.
User avatar
Onsemeliot
 
Posts: 225
Joined: 2010-12-15 14:43


Return to System configuration

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable