Slow boot

Kernels & Hardware, configuring network, installing services

Re: Slow boot

Postby L_V » 2019-07-28 14:50

Code: Select all
# dmesg | grep 258a

+ if you have another keyboard to try....
+
Code: Select all
lsmod | grep usb
L_V
 
Posts: 1032
Joined: 2007-03-19 09:04

Re: Slow boot

Postby dragonball » 2019-07-28 15:03

Code: Select all
 sudo dmesg | grep 258a
[sudo] password for george:
[  124.172180] usb 1-3: New USB device found, idVendor=258a, idProduct=001f, bcdDevice= 6.27


Code: Select all
george@Debian:~$ lsmod | grep usb
usbhid                 57344  0
hid                   135168  2 usbhid,hid_generic
usbcore               290816  3 xhci_hcd,usbhid,xhci_pci
usb_common             16384  1 usbcore
dragonball
 
Posts: 33
Joined: 2014-03-27 12:37

Re: Slow boot

Postby L_V » 2019-07-28 15:09

something around xhci_hcd
I have this
Code: Select all
usbcore               290816  8 ohci_hcd,ehci_pci,usbnet,usbhid,rndis_host,ehci_hcd,ohci_pci,cdc_ether
usb_common             16384  1 usbcore
+
Code: Select all
find /etc/modprobe.d/ -type f -exec grep -v "#" {} \;
L_V
 
Posts: 1032
Joined: 2007-03-19 09:04

Re: Slow boot

Postby dragonball » 2019-07-28 15:11

Code: Select all
find /etc/modprobe.d/ -type f -exec grep -v "#" {} \;
alias char-major-195* nvidia
blacklist microcode
dragonball
 
Posts: 33
Joined: 2014-03-27 12:37

Re: Slow boot

Postby L_V » 2019-07-28 15:20

Something around USB 3.0.
For testing/investigation, I would blacklist xhci_hcd , and load ohci_hcd ehci_hcd in /etc/initramfs-tools/modules.

Can you try
Code: Select all
sudo modprobe ohci_hcd
sudo modprobe ehci_hcd
sudo modprobe -r xhci_hcd
lsmod | grep usb

risk of necessary hard reboot , but cannot test for you !

+ maybe some BIOS investigation about USB
L_V
 
Posts: 1032
Joined: 2007-03-19 09:04

Re: Slow boot

Postby dragonball » 2019-07-28 16:01

Small progress

Code: Select all
lsmod | grep usb
usbhid                 57344  0
hid                   135168  2 usbhid,hid_generic
usbcore               290816  5 xhci_hcd,ohci_hcd,usbhid,ehci_hcd,xhci_pci
usb_common             16384  1 usbcore


But still cannot disable xhci_hcd.

Code: Select all
george@Debian:~$ more /etc/modprobe.d/blacklist.conf
blacklist xhci_hcd


Also this are my bios settings but disabling XHCI Hand-off didn't change anything

Image

Image
dragonball
 
Posts: 33
Joined: 2014-03-27 12:37

Re: Slow boot

Postby L_V » 2019-07-28 16:05

Then.....
For testing/investigation, I would blacklist xhci_hcd , and load ohci_hcd ehci_hcd in /etc/initramfs-tools/modules.

Do you know how to do this ?
/!\ this is at risk if you don't know how to recover.
Then, don't do it if not familiar with.
L_V
 
Posts: 1032
Joined: 2007-03-19 09:04

Re: Slow boot

Postby dragonball » 2019-07-28 16:12

The first step I found it. I add this lines in /etc/initramfs-tools/modules

ohci_hcd
ehci_hcd

After that i updated initramfs with

Code: Select all
update-initramfs -u


But I cannot blacklist xhci_hcd
dragonball
 
Posts: 33
Joined: 2014-03-27 12:37

Re: Slow boot

Postby L_V » 2019-07-28 16:25

Code: Select all
lsinitramfs /initrd.img | grep "etc/modprobe.d/"
cat /etc/modprobe.d/blacklist.conf
L_V
 
Posts: 1032
Joined: 2007-03-19 09:04

Re: Slow boot

Postby dragonball » 2019-07-28 16:28

Code: Select all
lsinitramfs /initrd.img | grep "etc/modprobe.d/"
etc/modprobe.d/blacklist.conf
etc/modprobe.d/dkms.conf
etc/modprobe.d/intel-microcode-blacklist.conf
etc/modprobe.d/nvidia-blacklists-nouveau.conf
etc/modprobe.d/nvidia-kernel-common.conf
etc/modprobe.d/nvidia.conf


Code: Select all
george@Debian:~$ cat /etc/modprobe.d/blacklist.conf
blacklist xhci_hcd
dragonball
 
Posts: 33
Joined: 2014-03-27 12:37

Re: Slow boot

Postby L_V » 2019-07-28 16:45

Strange ... I'm a bit short in idea.....
To make a dirty blacklist, there is a straight one.....
Code: Select all
### !!! dirty test - don't do it, or only if you decide to do it !!! ###
mv /lib/modules/$(uname -r)/kernel/drivers/usb/host/xhci-hcd.ko /lib/modules/$(uname -r)/kernel/drivers/usb/host/xhci-hcd.ko.bak

... even not sure this is enough in your case, because probably in the kernel and the target is to prevent xhci-hcd at boot.
+ to see
Code: Select all
lsusb -t

+ you can try to add this as kernel option
Code: Select all
modprobe.blacklist=xhci_hcd
or this one....
Code: Select all
intel_iommu=off
or this one....
Code: Select all
iommu=soft
L_V
 
Posts: 1032
Joined: 2007-03-19 09:04

Previous

Return to System configuration

Who is online

Users browsing this forum: ruwolf and 10 guests

fashionable