Aptitude tries to resolve dependecies forever...

Kernels & Hardware, configuring network, installing services

Re: Aptitude tries to resolve dependecies forever...

Postby Head_on_a_Stick » 2019-08-02 14:10

jeffry7 wrote:
Code: Select all
root@blackhole:/home/csg2/VueScan/VueScan# apt-show-versions | grep '/sid'
bash: apt-show-versions: command not found

Did you not think to install the package then? I did provide a link to the package page...
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10680
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-02 15:18

Head_on_a_Stick wrote:
jeffry7 wrote:
Code: Select all
root@blackhole:/home/csg2/VueScan/VueScan# apt-show-versions | grep '/sid'
bash: apt-show-versions: command not found

Did you not think to install the package then? I did provide a link to the package page...


When I looked at it last night, I thought this was getting the version of the package management system which I think was revealed by a different command.

Now that I have actually looked it up I see it does something else.

I will try this tonight.
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-03 00:29

Head_on_a_Stick wrote:
jeffry7 wrote:
Code: Select all
root@blackhole:/home/csg2/VueScan/VueScan# apt-show-versions | grep '/sid'
bash: apt-show-versions: command not found

Did you not think to install the package then? I did provide a link to the package page...


sid comes up empty

Code: Select all
root@blackhole:/home/csg2/Downloads# apt-show-versions | grep '/sid'
root@blackhole:/home/csg2/Downloads#


But unstable has a lot of hits

Code: Select all
ant-contrib:all/unstable 1.0~b3+svn177-10 uptodate
apparmor:amd64/unstable *manually* upgradeable from 2.13.2-10 to 2.13.3-4
apt:amd64/unstable 1.8.2 uptodate
apt-show-versions:all/unstable 0.22.11 uptodate
apt-utils:amd64/unstable 1.8.2 uptodate
aptitude:amd64/unstable 0.8.11-7 uptodate
aptitude-common:all/unstable 0.8.11-7 uptodate
at-spi2-core:amd64/unstable *manually* upgradeable from 2.30.0-7 to 2.32.1-1
base-files:amd64/unstable *manually* upgradeable from 10.3 to 11
bzip2:amd64/unstable *manually* upgradeable from 1.0.6-9.1 to 1.0.6-9.2
ca-certificates-java:all/unstable 20190405 uptodate
coinor-libcbc3:amd64/unstable 2.9.9+repack1-1 uptodate
coinor-libcgl1:amd64/unstable 0.59.10+repack1-1 uptodate
coinor-libclp1:amd64/unstable 1.16.11+repack1-1 uptodate
coinor-libcoinmp1v5:amd64/unstable 1.8.3-2+b11 uptodate
coinor-libcoinutils3v5:amd64/unstable 2.10.14+repack1-1 uptodate
coinor-libosi1v5:amd64/unstable 0.107.9+repack1-1 uptodate
dconf-gsettings-backend:amd64/unstable 0.30.1-2 uptodate
dconf-service:amd64/unstable 0.30.1-2 uptodate
dirmngr:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
firebird3.0-common:all/unstable *manually* upgradeable from 3.0.5.33100.ds4-2 to 3.0.5.33100.ds4-3
firebird3.0-common-doc:all/unstable *manually* upgradeable from 3.0.5.33100.ds4-2 to 3.0.5.33100.ds4-3
firebird3.0-server-core:amd64/unstable *manually* upgradeable from 3.0.5.33100.ds4-2 to 3.0.5.33100.ds4-3
firebird3.0-utils:amd64/unstable *manually* upgradeable from 3.0.5.33100.ds4-2 to 3.0.5.33100.ds4-3
flac:amd64/unstable 1.3.2-3 uptodate
fontconfig-config:all/unstable 2.13.1-2 uptodate
fonts-liberation2:all/unstable 2.00.5-2 uptodate
fonts-noto-core:all/unstable 20181227-1 uptodate
fonts-noto-ui-core:all/unstable 20181227-1 uptodate
fonts-opensymbol:all/unstable *manually* upgradeable from 2:102.11+LibO6.3.0~rc1-1 to 2:102.11+LibO6.3.0~rc2-1
fonts-sil-gentium:all/unstable 20081126:1.03-2 uptodate
fonts-sil-gentium-basic:all/unstable 1.102-1 uptodate
freetype2-doc:all/unstable *manually* upgradeable from 2.9.1-3 to 2.9.1-4
gcc-8-base:amd64/unstable *manually* upgradeable from 8.3.0-7 to 8.3.0-19
gcc-8-base:i386/unstable *manually* upgradeable from 8.3.0-7 to 8.3.0-19
gir1.2-atk-1.0:amd64/unstable *manually* upgradeable from 2.30.0-2 to 2.32.0-2
gir1.2-gdkpixbuf-2.0:amd64/unstable 2.38.1+dfsg-1 uptodate
gir1.2-gtk-2.0:amd64/unstable 2.24.32-3 uptodate
gir1.2-harfbuzz-0.0:amd64/unstable *manually* upgradeable from 2.4.0-2 to 2.5.3-1
gir1.2-pango-1.0:amd64/unstable 1.42.4-6 uptodate
glib-networking:amd64/unstable 2.58.0-2 uptodate
glib-networking-common:all/unstable 2.58.0-2 uptodate
glib-networking-services:amd64/unstable 2.58.0-2 uptodate
gnupg:all/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gnupg-l10n:all/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gnupg-utils:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpg:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpg-agent:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpg-wks-client:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpg-wks-server:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpgconf:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpgsm:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gpgv:amd64/unstable *manually* upgradeable from 2.2.13-2 to 2.2.17-3
gstreamer1.0-gl:amd64/unstable *manually* upgradeable from 1.14.4-2 to 1.16.0-2
gstreamer1.0-plugins-bad:amd64/unstable *manually* upgradeable from 1.14.4-1+b1 to 1.16.0-2
gstreamer1.0-plugins-base:amd64/unstable *manually* upgradeable from 1.14.4-2 to 1.16.0-2
gtk2-engines-pixbuf:amd64/unstable 2.24.32-3 uptodate
gvfs:amd64/unstable 1.38.1-5 uptodate
gvfs-common:all/unstable 1.38.1-5 uptodate
gvfs-daemons:amd64/unstable 1.38.1-5 uptodate
gvfs-libs:amd64/unstable 1.38.1-5 uptodate
hunspell-en-us:all/unstable 1:2018.04.16-1 uptodate
libabw-0.1-1:amd64/unstable 0.1.2-1 uptodate
libactivation-java:all/unstable 1.2.0-2 uptodate
libalgorithm-diff-xs-perl:amd64/unstable 0.04-5+b1 uptodate
libaom0:amd64/unstable 1.0.0-3 uptodate
libaopalliance-java:all/unstable 20070526-6 uptodate
libapache-poi-java:all/unstable 4.0.1-1 uptodate
libapt-inst2.0:amd64/unstable 1.8.2 uptodate
libapt-pkg-perl:amd64/unstable *manually* upgradeable from 0.1.34+b1 to 0.1.36+b1
libapt-pkg5.0:amd64/unstable 1.8.2 uptodate
libargon2-1:amd64/unstable 0~20171227-0.2 uptodate
libasm-java:all/unstable *manually* upgradeable from 7.0-1 to 7.1-2
libass9:amd64/unstable 1:0.14.0-2 uptodate
libassuan0:amd64/unstable *manually* upgradeable from 2.5.2-1 to 2.5.3-7
libatinject-jsr330-api-java:all/unstable 1.0+ds1-5 uptodate
libatk-bridge2.0-0:amd64/unstable *manually* upgradeable from 2.30.0-5 to 2.32.0-2
libatk-wrapper-java:all/unstable 0.33.3-22 uptodate
libatk-wrapper-java-jni:amd64/unstable 0.33.3-22 uptodate
libatk1.0-0:amd64/unstable *manually* upgradeable from 2.30.0-2 to 2.32.0-2
libatk1.0-data:all/unstable *manually* upgradeable from 2.30.0-2 to 2.32.0-2
libatk1.0-dev:amd64/unstable *manually* upgradeable from 2.30.0-2 to 2.32.0-2
libatomic1:amd64/unstable *manually* upgradeable from 8.3.0-7 to 9.1.0-10
libatomic1:i386/unstable *manually* upgradeable from 8.3.0-7 to 9.1.0-10
libatspi2.0-0:amd64/unstable *manually* upgradeable from 2.30.0-7 to 2.32.1-1
libaudiofile1:amd64/unstable 0.3.6-5 uptodate
libavcodec58:amd64/unstable *manually* upgradeable from 7:4.1.3-1 to 7:4.1.4-1
libavformat58:amd64/unstable *manually* upgradeable from 7:4.1.3-1 to 7:4.1.4-1
libavutil56:amd64/unstable *manually* upgradeable from 7:4.1.3-1 to 7:4.1.4-1
libbcmail-java:all/unstable *manually* upgradeable from 1.60-1 to 1.61-1
libbcpkix-java:all/unstable *manually* upgradeable from 1.60-1 to 1.61-1
libbcprov-java:all/unstable *manually* upgradeable from 1.60-1 to 1.61-1
libblas3:amd64/unstable 3.8.0-2 uptodate
libblkid-dev:amd64/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libblkid1:amd64/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libblkid1:i386/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libbluray2:amd64/unstable 1:1.1.2-2 uptodate
libboost-atomic1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-chrono1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-date-time1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-filesystem1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-iostreams1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-locale1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-python1.62.0:amd64/unstable 1.62.0+dfsg-10+b1 uptodate
libboost-system1.67.0:amd64/unstable 1.67.0-13 uptodate
libboost-thread1.67.0:amd64/unstable 1.67.0-13 uptodate
libbrotli1:amd64/unstable 1.0.7-2 uptodate
libbsh-java:all/unstable 2.0b4-19 uptodate
libbz2-1.0:amd64/unstable *manually* upgradeable from 1.0.6-9.1 to 1.0.6-9.2
libbz2-1.0:i386/unstable *manually* upgradeable from 1.0.6-9.1 to 1.0.6-9.2
libc-bin:amd64/unstable 2.28-10 uptodate
libc-dev-bin:amd64/unstable 2.28-10 uptodate
libc-l10n:all/unstable 2.28-10 uptodate
libc6:amd64/unstable 2.28-10 uptodate
libc6:i386/unstable 2.28-10 uptodate
libc6-dev:amd64/unstable 2.28-10 uptodate
libc6-dev-i386:amd64/unstable 2.28-10 uptodate
libc6-dev-x32:amd64/unstable 2.28-10 uptodate
libc6-i386:amd64/unstable 2.28-10 uptodate
libc6-x32:amd64/unstable 2.28-10 uptodate
libcairo-gobject2:amd64/unstable 1.16.0-4 uptodate
libcairo-perl:amd64/unstable 1.106-3+b1 uptodate
libcairo-script-interpreter2:amd64/unstable 1.16.0-4 uptodate
libcairo2:amd64/unstable 1.16.0-4 uptodate
libcairo2:i386/unstable 1.16.0-4 uptodate
libcairo2-dev:amd64/unstable 1.16.0-4 uptodate
libcdi-api-java:all/unstable 1.2-2 uptodate
libcdparanoia0:amd64/unstable 3.10.2+debian-13 uptodate
libcdr-0.1-1:amd64/unstable 0.1.5-1 uptodate
libcglib-java:all/unstable *manually* upgradeable from 3.2.10-1 to 3.2.12-1
libchromaprint-tools:amd64/unstable 1.4.3-3 uptodate
libchromaprint1:amd64/unstable 1.4.3-3 uptodate
libcmis-0.5-5v5:amd64/unstable 0.5.2-1 uptodate
libcodec2-0.8.1:amd64/unstable 0.8.1-2 uptodate
libcodemodel-java:all/unstable 2.6+jaxb2.3.0.1-8 uptodate
libcolamd2:amd64/unstable 1:5.4.0+dfsg-1 uptodate
libcolord2:amd64/unstable 1.4.3-4 uptodate
libcom-err2:amd64/unstable *manually* upgradeable from 1.45.2-1 to 1.45.3-3
libcom-err2:i386/unstable *manually* upgradeable from 1.45.2-1 to 1.45.3-3
libcomerr2:amd64/unstable *manually* upgradeable from 1.45.2-1 to 1.45.3-3
libcommons-cli-java:all/unstable 1.4-1 uptodate
libcommons-collections4-java:all/unstable 4.2-1 uptodate
libcommons-compress-java:all/unstable 1.18-2 uptodate
libcommons-io-java:all/unstable 2.6-2 uptodate
libcommons-lang3-java:all/unstable 3.8-2 uptodate
libcommons-math3-java:all/unstable 3.6.1-3 uptodate
libcommons-parent-java:all/unstable 43-1 uptodate
libconfig-inifiles-perl:all/unstable 3.000001-1 uptodate
libcroco3:amd64/unstable 0.6.12-3 uptodate
libcryptsetup12:amd64/unstable *manually* upgradeable from 2:2.1.0-5 to 2:2.1.0-7
libcurl3-gnutls:amd64/unstable *manually* upgradeable from 7.64.0-4 to 7.65.1-1
libcwidget3v5:amd64/unstable 0.5.17-11 uptodate
libdatrie1:amd64/unstable 0.2.12-2 uptodate
libdbus-glib-1-2:amd64/unstable 0.110-4 uptodate
libdc1394-22:amd64/unstable 2.2.5-2 uptodate
libdc1394-22-dev:amd64/unstable 2.2.5-2 uptodate
libdca0:amd64/unstable 0.0.6-1 uptodate
libdconf1:amd64/unstable 0.30.1-2 uptodate
libde265-0:amd64/unstable 1.0.3-1+b1 uptodate
libdom4j-java:all/unstable 2.1.1-2 uptodate
libdrm-amdgpu1:amd64/unstable 2.4.97-1 uptodate
libdrm-amdgpu1:i386/unstable 2.4.97-1 uptodate
libdrm-common:all/unstable 2.4.97-1 uptodate
libdrm2:amd64/unstable 2.4.97-1 uptodate
libdrm2:i386/unstable 2.4.97-1 uptodate
libdvdnav4:amd64/unstable 6.0.0-1 uptodate
libdvdread4:amd64/unstable 6.0.1-1 uptodate
libe-book-0.1-1:amd64/unstable 0.1.3-1+b2 uptodate
libegl-mesa0:amd64/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
libegl1:amd64/unstable 1.1.0-1 uptodate
libegl1-mesa:amd64/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
libeot0:amd64/unstable 0.01-5 uptodate
libepoxy0:amd64/unstable 1.5.3-0.1 uptodate
libepubgen-0.1-1:amd64/unstable 0.1.1-1 uptodate
libetonyek-0.1-1:amd64/unstable 0.1.9-1 uptodate
libexttextcat-2.0-0:amd64/unstable 3.4.5-1 uptodate
libexttextcat-data:all/unstable 3.4.5-1 uptodate
libfaad2:amd64/unstable 2.8.8-3 uptodate
libfastinfoset-java:all/unstable 1.2.12-3 uptodate
libfbclient2:amd64/unstable *manually* upgradeable from 3.0.5.33100.ds4-2 to 3.0.5.33100.ds4-3
libfcgi-perl:amd64/unstable 0.78-2+b3 uptodate
libffi-dev:amd64/unstable 3.2.1-9 uptodate
libffi6:amd64/unstable 3.2.1-9 uptodate
libffi6:i386/unstable 3.2.1-9 uptodate
libfftw3-double3:amd64/unstable 3.3.8-2 uptodate
libfile-fcntllock-perl:amd64/unstable 0.22-3+b5 uptodate
libflite1:amd64/unstable 2.1-release-3 uptodate
libfluidsynth1:amd64/unstable *manually* upgradeable from 1.1.11-1 to 1.1.11-1+b1
libflute-java:all/unstable 1:1.1.6-4 uptodate
libfontconfig1:amd64/unstable 2.13.1-2 uptodate
libfontconfig1:i386/unstable 2.13.1-2 uptodate
libfontconfig1-dev:amd64/unstable 2.13.1-2 uptodate
libfreehand-0.1-1:amd64/unstable 0.1.2-2 uptodate
libfreetype6:amd64/unstable *manually* upgradeable from 2.9.1-3 to 2.9.1-4
libfreetype6:i386/unstable *manually* upgradeable from 2.9.1-3 to 2.9.1-4
libfreetype6-dev:amd64/unstable *manually* upgradeable from 2.9.1-3 to 2.9.1-4
libfribidi-dev:amd64/unstable 1.0.5-3.1 uptodate
libfribidi0:amd64/unstable 1.0.5-3.1 uptodate
libgail-common:amd64/unstable 2.24.32-3 uptodate
libgail18:amd64/unstable 2.24.32-3 uptodate
libgbm1:amd64/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
libgcc1:amd64/unstable *manually* upgradeable from 1:8.3.0-7 to 1:9.1.0-10
libgcc1:i386/unstable *manually* upgradeable from 1:8.3.0-7 to 1:9.1.0-10
libgcrypt20:amd64/unstable 1.8.4-5 uptodate
libgcrypt20:i386/unstable 1.8.4-5 uptodate
libgdbm-compat4:amd64/unstable *manually* upgradeable from 1.18.1-4 to 1.18.1-4+b1
libgdbm6:amd64/unstable *manually* upgradeable from 1.18.1-4 to 1.18.1-4+b1
libgdk-pixbuf2.0-0:amd64/unstable 2.38.1+dfsg-1 uptodate
libgdk-pixbuf2.0-bin:amd64/unstable 2.38.1+dfsg-1 uptodate
libgdk-pixbuf2.0-common:all/unstable 2.38.1+dfsg-1 uptodate
libgdk-pixbuf2.0-dev:amd64/unstable 2.38.1+dfsg-1 uptodate
libgeronimo-annotation-1.3-spec-java:all/unstable 1.0-1 uptodate
libgeronimo-interceptor-3.0-spec-java:all/unstable 1.0.1-4 uptodate
libgfortran5:amd64/unstable *manually* upgradeable from 8.3.0-7 to 9.1.0-10
libgif7:amd64/unstable 5.1.4-3 uptodate
libglib-perl:amd64/unstable *manually* upgradeable from 3:1.329-1 to 3:1.329-4
libglib2.0-0:amd64/unstable *manually* upgradeable from 2.58.3-2 to 2.60.6-1
libglib2.0-0:i386/unstable *manually* upgradeable from 2.58.3-2 to 2.60.6-1
libglib2.0-bin:amd64/unstable *manually* upgradeable from 2.58.3-2 to 2.60.6-1
libglib2.0-dev:amd64/unstable *manually* upgradeable from 2.58.3-2 to 2.60.6-1
libglib2.0-dev-bin:i386/unstable *manually* upgradeable from 2.58.3-2 to 2.60.6-1
libglvnd0:amd64/unstable 1.1.0-1 uptodate
libgme0:amd64/unstable 0.6.2-1 uptodate
libgnutls-openssl27:amd64/unstable 3.6.8-2 uptodate
libgnutls30:amd64/unstable 3.6.8-2 uptodate
libgnutls30:i386/unstable 3.6.8-2 uptodate
libgpgme11:amd64/unstable 1.12.0-6 uptodate
libgpgmepp6:amd64/unstable 1.12.0-6 uptodate
libgraphene-1.0-0:amd64/unstable 1.8.4-1 uptodate
libgraphite2-3:amd64/unstable 1.3.13-7 uptodate
libgraphite2-dev:amd64/unstable 1.3.13-7 uptodate
libgsm1:amd64/unstable 1.0.18-2 uptodate
libgsm1:i386/unstable 1.0.18-2 uptodate
libgssapi-krb5-2:amd64/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libgssapi-krb5-2:i386/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libgssdp-1.0-3:amd64/unstable 1.0.2-4 uptodate
libgstreamer-gl1.0-0:amd64/unstable *manually* upgradeable from 1.14.4-2 to 1.16.0-2
libgstreamer-plugins-bad1.0-0:amd64/unstable *manually* upgradeable from 1.14.4-1+b1 to 1.16.0-2
libgstreamer-plugins-base1.0-0:amd64/unstable *manually* upgradeable from 1.14.4-2 to 1.16.0-2
libgstreamer1.0-0:amd64/unstable *manually* upgradeable from 1.14.4-1 to 1.16.0-2
libgtk-3-0:amd64/unstable *manually* upgradeable from 3.24.5-1 to 3.24.10-1
libgtk-3-common:all/unstable *manually* upgradeable from 3.24.5-1 to 3.24.10-1
libgtk2-perl:amd64/unstable 2:1.24992-1+b2 uptodate
libgtk2.0-0:amd64/unstable 2.24.32-3 uptodate
libgtk2.0-bin:amd64/unstable 2.24.32-3 uptodate
libgtk2.0-dev:amd64/unstable 2.24.32-3 uptodate
libgudev-1.0-0:amd64/unstable 232-2 uptodate
libguice-java:all/unstable 4.2.1-1 uptodate
libgupnp-1.0-4:amd64/unstable 1.0.3-3 uptodate
libgupnp-igd-1.0-4:amd64/unstable 0.2.5-3 uptodate
libharfbuzz-dev:amd64/unstable *manually* upgradeable from 2.4.0-2 to 2.5.3-1
libharfbuzz-gobject0:amd64/unstable *manually* upgradeable from 2.4.0-2 to 2.5.3-1
libharfbuzz-icu0:amd64/unstable *manually* upgradeable from 2.4.0-2 to 2.5.3-1
libharfbuzz0b:amd64/unstable *manually* upgradeable from 2.4.0-2 to 2.5.3-1
libhawtjni-runtime-java:all/unstable *manually* upgradeable from 1.16-1 to 1.17-1
libhogweed4:amd64/unstable 3.4.1-1 uptodate
libhogweed4:i386/unstable 3.4.1-1 uptodate
libhtml-parser-perl:amd64/unstable 3.72-3+b3 uptodate
libhttpclient-java:all/unstable 4.5.9-1 uptodate
libhttpcore-java:all/unstable 4.4.11-1 uptodate
libhunspell-1.7-0:amd64/unstable *manually* upgradeable from 1.7.0-2 to 1.7.0-2+b1
libhyphen0:amd64/unstable 2.8.8-7 uptodate
libib-util:amd64/unstable *manually* upgradeable from 3.0.5.33100.ds4-2 to 3.0.5.33100.ds4-3
libicu4j-java:all/unstable 62.1-2 uptodate
libicu63:amd64/unstable 63.2-2 uptodate
libidn2-0:amd64/unstable *manually* upgradeable from 2.0.5-1 to 2.2.0-1
libidn2-0:i386/unstable *manually* upgradeable from 2.0.5-1 to 2.2.0-1
libilmbase23:amd64/unstable 2.2.1-2 uptodate
libintellij-annotations-java:all/unstable 17.0.0-1 uptodate
libio-socket-ip-perl:all/unstable 0.39-1 uptodate
libistack-commons-java:all/unstable 3.0.6-4 uptodate
libitext-java:all/unstable 2.1.7-12 uptodate
libjansi-java:all/unstable 1.18-1 uptodate
libjansi-native-java:all/unstable 1.8-1 uptodate
libjavascriptcoregtk-4.0-18:amd64/unstable 2.24.3-1 uptodate
libjaxb-api-java:all/unstable 2.3.1-1 uptodate
libjaxb-java:all/unstable 2.3.0.1-8 uptodate
libjaxen-java:all/unstable 1.1.6-4 uptodate
libjdom1-java:all/unstable 1.1.3-2 uptodate
libjetbrains-annotations-java:all/unstable 17.0.0-1 uptodate
libjson-c3:amd64/unstable 0.12.1+ds-2 uptodate
libjson-glib-1.0-0:amd64/unstable 1.4.4-2 uptodate
libjson-glib-1.0-common:all/unstable 1.4.4-2 uptodate
libjsoup-java:all/unstable 1.10.2-2 uptodate
libjsr305-java:all/unstable 0.1~+svn49-11 uptodate
libk5crypto3:amd64/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libk5crypto3:i386/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libkate1:amd64/unstable 0.4.1-9 uptodate
libkrb5-3:amd64/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libkrb5-3:i386/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libkrb5support0:amd64/unstable *manually* upgradeable from 1.17-3 to 1.17-5
libkrb5support0:i386/unstable *manually* upgradeable from 1.17-3 to 1.17-5
liblapack3:amd64/unstable 3.8.0-2 uptodate
liblayout-java:all/unstable 0.2.10-3 uptodate
liblilv-0-0:amd64/unstable 0.24.2~dfsg0-2 uptodate
libllvm7:amd64/unstable 1:7.0.1-8 uptodate
libllvm7:i386/unstable 1:7.0.1-8 uptodate
liblocale-gettext-perl:amd64/unstable 1.07-3+b4 uptodate
libmariadb3:amd64/unstable 1:10.3.16-1 uptodate
libmaven-file-management-java:all/unstable 3.0.0-1 uptodate
libmaven-parent-java:all/unstable 31-2 uptodate
libmaven-resolver-java:all/unstable 1.4.0-2 uptodate
libmaven-shared-io-java:all/unstable 3.0.0-3 uptodate
libmaven-shared-utils-java:all/unstable 3.3.0-1 uptodate
libmaven3-core-java:all/unstable *manually* upgradeable from 3.6.0-1 to 3.6.1-1
libmhash2:amd64/unstable 0.9.9.9-7+b1 uptodate
libmms0:amd64/unstable 0.6.4-3 uptodate
libmodplug1:amd64/unstable 1:0.8.9.0-2 uptodate
libmount-dev:amd64/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libmount1:amd64/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libmount1:i386/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libmp3lame0:amd64/unstable 3.100-2+b1 uptodate
libmp3lame0:i386/unstable 3.100-2+b1 uptodate
libmp3splt:amd64/unstable 0.9.2-3 uptodate
libmpcdec6:amd64/unstable 2:0.1~r495-1+b2 uptodate
libmpdec2:amd64/unstable 2.4.2-2 uptodate
libmspub-0.1-1:amd64/unstable 0.1.4-1+b2 uptodate
libmusicbrainz-discid-perl:amd64/unstable 0.04-1+b1 uptodate
libmwaw-0.3-3:amd64/unstable 0.3.15-2 uptodate
libncurses6:amd64/unstable *manually* upgradeable from 6.1+20181013-2 to 6.1+20190713-1
libncursesw6:amd64/unstable *manually* upgradeable from 6.1+20181013-2 to 6.1+20190713-1
libneon27-gnutls:amd64/unstable 0.30.2-3 uptodate
libnet-dbus-perl:amd64/unstable 1.1.0-6 uptodate
libnet-ssleay-perl:amd64/unstable *manually* upgradeable from 1.85-3 to 1.88-1
libnettle6:amd64/unstable 3.4.1-1 uptodate
libnettle6:i386/unstable 3.4.1-1 uptodate
libnghttp2-14:amd64/unstable 1.37.0-1 uptodate
libnice10:amd64/unstable 0.1.14-1 uptodate
libnspr4:amd64/unstable 2:4.21-1 uptodate
libnss3:amd64/unstable *manually* upgradeable from 2:3.44+really3.42.1-2 to 2:3.45-1
libnumbertext-1.0-0:amd64/unstable 1.0.5-1 uptodate
libnumbertext-data:all/unstable 1.0.5-1 uptodate
libodfgen-0.1-1:amd64/unstable 0.1.7-1 uptodate
libofa0:amd64/unstable 0.9.3-19 uptodate
libopenexr23:amd64/unstable 2.2.1-4.1 uptodate
libopenjp2-7:amd64/unstable 2.3.0-2 uptodate
libopenjp2-7:i386/unstable 2.3.0-2 uptodate
libopenmpt0:amd64/unstable *manually* upgradeable from 0.4.3-1 to 0.4.5-1
liborc-0.4-0:amd64/unstable 1:0.4.28-3.1 uptodate
liborcus-0.14-0:amd64/unstable 0.14.1-6 uptodate
libp11-kit0:amd64/unstable 0.23.15-2 uptodate
libp11-kit0:i386/unstable 0.23.15-2 uptodate
libpagemaker-0.0-0:amd64/unstable 0.0.4-1 uptodate
libpam-systemd:amd64/unstable *manually* upgradeable from 241-5 to 241-7
libpango-1.0-0:amd64/unstable 1.42.4-6 uptodate
libpango-perl:amd64/unstable 1.227-3+b1 uptodate
libpango1.0-dev:amd64/unstable 1.42.4-6 uptodate
libpangocairo-1.0-0:amd64/unstable 1.42.4-6 uptodate
libpangoft2-1.0-0:amd64/unstable 1.42.4-6 uptodate
libpangoxft-1.0-0:amd64/unstable 1.42.4-6 uptodate
libpcre2-16-0:amd64/unstable 10.32-5 uptodate
libpcre2-32-0:amd64/unstable 10.32-5 uptodate
libpcre2-8-0:amd64/unstable 10.32-5 uptodate
libpcre2-8-0:i386/unstable 10.32-5 uptodate
libpcre2-dev:amd64/unstable 10.32-5 uptodate
libpcre2-posix0:amd64/unstable 10.32-5 uptodate
libpcsclite1:amd64/unstable 1.8.25-1 uptodate
libpentaho-reporting-flow-engine-java:all/unstable 0.9.4-5 uptodate
libperl-dev:amd64/unstable 5.28.1-6 uptodate
libperl5.28:amd64/unstable 5.28.1-6 uptodate
libplexus-archiver-java:all/unstable 3.6.0-2 uptodate
libplexus-cipher-java:all/unstable 1.7-3 uptodate
libplexus-classworlds-java:all/unstable 2.6.0-1 uptodate
libplexus-component-annotations-java:all/unstable *manually* upgradeable from 1.7.1-7 to 2.0.0-1
libplexus-interpolation-java:all/unstable 1.26-1 uptodate
libplexus-io-java:all/unstable 3.1.1-1 uptodate
libplexus-sec-dispatcher-java:all/unstable 1.4-4 uptodate
libplexus-utils2-java:all/unstable *manually* upgradeable from 3.1.1-1 to 3.2.1-1
libpolkit-agent-1-0:amd64/unstable 0.105-25 uptodate
libpolkit-backend-1-0:amd64/unstable 0.105-25 uptodate
libpolkit-gobject-1-0:amd64/unstable 0.105-25 uptodate
libpoppler82:amd64/unstable 0.71.0-5 uptodate
libposix-strptime-perl:amd64/unstable 0.13-1+b5 uptodate
libpq5:amd64/unstable 11.4-1 uptodate
libproxy1v5:amd64/unstable 0.4.15-5 uptodate
libpsl5:amd64/unstable 0.20.2-2 uptodate
libpython3-stdlib:amd64/unstable 3.7.3-1 uptodate
libpython3.7:amd64/unstable 3.7.4-2 uptodate
libpython3.7-minimal:amd64/unstable 3.7.4-2 uptodate
libpython3.7-stdlib:amd64/unstable 3.7.4-2 uptodate
libqt4-dbus:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-declarative:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-designer:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-help:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-network:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-script:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-scripttools:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-sql:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-sql-mysql:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-svg:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-test:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-xml:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqt4-xmlpatterns:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqtcore4:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqtdbus4:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libqtgui4:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
libquadmath0:amd64/unstable *manually* upgradeable from 8.3.0-7 to 9.1.0-10
libqxp-0.0-0:amd64/unstable 0.0.2-1 uptodate
librdf0:amd64/unstable 1.0.17-1.1+b1 uptodate
libreadline7:amd64/unstable 7.0-5 uptodate
libreadline8:amd64/unstable 8.0-2 uptodate
libreoffice:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-base:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-base-core:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-base-drivers:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-calc:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-common:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-core:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-draw:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-impress:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-java-common:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-librelogo:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-math:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-nlpsolver:all/unstable *manually* upgradeable from 0.9+LibO6.3.0~rc1-1 to 0.9+LibO6.3.0~rc2-1
libreoffice-report-builder:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-report-builder-bin:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-script-provider-bsh:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-script-provider-js:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-script-provider-python:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-sdbc-firebird:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-sdbc-mysql:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-sdbc-postgresql:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-style-colibre:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-style-tango:all/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
libreoffice-wiki-publisher:all/unstable *manually* upgradeable from 1.2.0+LibO6.3.0~rc1-1 to 1.2.0+LibO6.3.0~rc2-1
libreoffice-writer:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
librest-0.7-0:amd64/unstable 0.8.1-1 uptodate
librngom-java:all/unstable 2.3.0.1-8 uptodate
librsvg2-2:amd64/unstable 2.44.10-2.1 uptodate
librsvg2-common:amd64/unstable 2.44.10-2.1 uptodate
librtmp1:amd64/unstable 2.4+20151223.gitfa8646d.1-2 uptodate
libsac-java:all/unstable 1.3+dfsg-5 uptodate
libsaxonhe-java:all/unstable *manually* upgradeable from 9.9.0.2+dfsg-1 to 9.9.1.1+dfsg-1
libsbc1:amd64/unstable 1.4-1 uptodate
libselinux1:amd64/unstable 2.9-2 uptodate
libselinux1:i386/unstable 2.9-2 uptodate
libselinux1-dev:amd64/unstable 2.9-2 uptodate
libsepol1:amd64/unstable 2.9-2 uptodate
libsepol1-dev:amd64/unstable 2.9-2 uptodate
libserd-0-0:amd64/unstable 0.28.0~dfsg0-1 uptodate
libserializer-java:all/unstable 1.1.6-5 uptodate
libsisu-guice-java:all/unstable 4.2.0-1 uptodate
libsisu-inject-java:all/unstable 0.3.3-1 uptodate
libsisu-ioc-java:all/unstable 2.3.0-11 uptodate
libsisu-plexus-java:all/unstable 0.3.3-3 uptodate
libslf4j-java:all/unstable 1.7.25-3 uptodate
libsnappy-java:all/unstable 1.1.7.2-1 uptodate
libsnappy-jni:amd64/unstable 1.1.7.2-1 uptodate
libsoundtouch1:amd64/unstable 2.1.2+ds1-1 uptodate
libsoup-gnome2.4-1:amd64/unstable 2.64.2-2 uptodate
libsoup2.4-1:amd64/unstable 2.64.2-2 uptodate
libspandsp2:amd64/unstable 0.0.6+dfsg-2 uptodate
libsqlite3-0:amd64/unstable *manually* upgradeable from 3.27.2-3 to 3.29.0-1
libsrtp2-1:amd64/unstable 2.2.0-1 uptodate
libssh-gcrypt-4:amd64/unstable *manually* upgradeable from 0.8.7-1 to 0.9.0-1
libssh2-1:amd64/unstable 1.8.0-2.1 uptodate
libssl-dev:amd64/unstable 1.1.1c-1 uptodate
libssl1.1:amd64/unstable 1.1.1c-1 uptodate
libssl1.1:i386/unstable 1.1.1c-1 uptodate
libstaroffice-0.0-0:amd64/unstable 0.0.6-1 uptodate
libstax-ex-java:all/unstable 1.7.8-3 uptodate
libstdc++6:amd64/unstable *manually* upgradeable from 8.3.0-7 to 9.1.0-10
libstdc++6:i386/unstable *manually* upgradeable from 8.3.0-7 to 9.1.0-10
libsub-name-perl:amd64/unstable 0.21-1+b3 uptodate
libsuitesparseconfig5:amd64/unstable 1:5.4.0+dfsg-1 uptodate
libswresample3:amd64/unstable *manually* upgradeable from 7:4.1.3-1 to 7:4.1.4-1
libsystemd0:amd64/unstable *manually* upgradeable from 241-5 to 241-7
libsystemd0:i386/unstable *manually* upgradeable from 241-5 to 241-7
libtasn1-6:amd64/unstable *manually* upgradeable from 4.13-3 to 4.14-2
libtasn1-6:i386/unstable *manually* upgradeable from 4.13-3 to 4.14-2
libtext-charwidth-perl:amd64/unstable *manually* upgradeable from 0.04-7.1+b1 to 0.04-8
libtext-iconv-perl:amd64/unstable *manually* upgradeable from 1.7-5+b7 to 1.7-6
libthai0:amd64/unstable 0.1.28-2 uptodate
libtinfo6:amd64/unstable *manually* upgradeable from 6.1+20181013-2 to 6.1+20190713-1
libtinfo6:i386/unstable *manually* upgradeable from 6.1+20181013-2 to 6.1+20190713-1
libtommath1:amd64/unstable 1.1.0-3 uptodate
libtxw2-java:all/unstable 2.3.0.1-8 uptodate
libudev-dev:amd64/unstable *manually* upgradeable from 241-5 to 241-7
libudev1:amd64/unstable *manually* upgradeable from 241-5 to 241-7
libudisks2-0:amd64/unstable *manually* upgradeable from 2.8.3-3 to 2.8.4-1
libunicode-linebreak-perl:amd64/unstable 0.0.20190101-1 uptodate
libunicode-string-perl:amd64/unstable 2.10-1+b4 uptodate
libunistring2:amd64/unstable *manually* upgradeable from 0.9.10-1 to 0.9.10-2
libunistring2:i386/unstable *manually* upgradeable from 0.9.10-1 to 0.9.10-2
libusb-1.0-0:amd64/unstable 2:1.0.22-2 uptodate
libuuid1:amd64/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libuuid1:i386/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
libv4l-0:amd64/unstable *manually* upgradeable from 1.16.6-1 to 1.16.6-2
libv4lconvert0:amd64/unstable *manually* upgradeable from 1.16.6-1 to 1.16.6-2
libva-drm2:amd64/unstable 2.5.0-1 uptodate
libva-x11-2:amd64/unstable 2.5.0-1 uptodate
libva2:amd64/unstable 2.5.0-1 uptodate
libva2:i386/unstable 2.5.0-1 uptodate
libvisio-0.1-1:amd64/unstable 0.1.6-1+b2 uptodate
libvisual-0.4-0:amd64/unstable 0.4.0-15 uptodate
libvo-aacenc0:amd64/unstable 0.1.3-1+b1 uptodate
libvo-amrwbenc0:amd64/unstable 0.1.3-1+b1 uptodate
libvorbis0a:amd64/unstable 1.3.6-2 uptodate
libvorbis0a:i386/unstable 1.3.6-2 uptodate
libvorbisenc2:amd64/unstable 1.3.6-2 uptodate
libvorbisenc2:i386/unstable 1.3.6-2 uptodate
libvorbisfile3:amd64/unstable 1.3.6-2 uptodate
libvpx5:amd64/unstable 1.7.0-3 uptodate
libvulkan1:amd64/unstable 1.1.101.0-2 uptodate
libwagon-http-java:all/unstable 3.3.3-1 uptodate
libwagon-provider-api-java:all/unstable 3.3.3-1 uptodate
libwayland-client0:amd64/unstable *manually* upgradeable from 1.16.0-1 to 1.17.0-1
libwayland-cursor0:amd64/unstable *manually* upgradeable from 1.16.0-1 to 1.17.0-1
libwayland-egl1:amd64/unstable *manually* upgradeable from 1.16.0-1 to 1.17.0-1
libwayland-egl1-mesa:amd64/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
libwayland-server0:amd64/unstable *manually* upgradeable from 1.16.0-1 to 1.17.0-1
libwebkit2gtk-4.0-37:amd64/unstable 2.24.3-1 uptodate
libwebpmux3:amd64/unstable 0.6.1-2 uptodate
libwildmidi2:amd64/unstable 0.4.3-1 uptodate
libwoff1:amd64/unstable 1.0.2-1 uptodate
libwpd-0.10-10:amd64/unstable 0.10.3-1 uptodate
libwpg-0.3-3:amd64/unstable 0.3.3-1 uptodate
libwps-0.4-4:amd64/unstable 0.4.10-1 uptodate
libx264-155:amd64/unstable 2:0.155.2917+git0a84d98-2 uptodate
libx265-165:amd64/unstable 2.9-4 uptodate
libxapian30:amd64/unstable 1.4.11-1 uptodate
libxatracker2:amd64/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
libxcb-dri3-0:amd64/unstable 1.13.1-2 uptodate
libxcb-dri3-0:i386/unstable 1.13.1-2 uptodate
libxcb-xfixes0:amd64/unstable 1.13.1-2 uptodate
libxcb-xfixes0:i386/unstable 1.13.1-2 uptodate
libxerces2-java:all/unstable 2.12.0-1 uptodate
libxkbcommon0:amd64/unstable 0.8.2-1 uptodate
libxml-commons-external-java:all/unstable 1.4.01-3 uptodate
libxml-libxml-perl:amd64/unstable 2.0134+dfsg-1 uptodate
libxml-parser-perl:amd64/unstable 2.44-4 uptodate
libxmlbeans-java:all/unstable 3.0.2-1 uptodate
libxmlsec1:amd64/unstable 1.2.28-2 uptodate
libxmlsec1-nss:amd64/unstable 1.2.28-2 uptodate
libxsom-java:all/unstable 2.3.0.1-8 uptodate
libxz-java:all/unstable 1.8-2 uptodate
libyajl2:amd64/unstable 2.1.0-3 uptodate
libzbar0:amd64/unstable *manually* upgradeable from 0.22-1 to 0.23-1.1
libzmf-0.0-0:amd64/unstable 0.0.2-1+b2 uptodate
libzstd1:amd64/unstable 1.3.8+dfsg-3 uptodate
locales:all/unstable 2.28-10 uptodate
mariadb-common:all/unstable 1:10.3.16-1 uptodate
mesa-va-drivers:i386/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
mesa-vdpau-drivers:amd64/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
mesa-vdpau-drivers:i386/unstable *manually* upgradeable from 18.3.6-2 to 19.1.2-1
mp3splt:amd64/unstable 2.6.2+20170630-3 uptodate
mp3val:amd64/unstable 0.1.8-4 uptodate
mpg321:amd64/unstable 0.3.2-3 uptodate
mysql-common:all/unstable 5.8+1.0.5 uptodate
normalize-audio:amd64/unstable 0.7.7-15 uptodate
p11-kit-modules:amd64/unstable 0.23.15-2 uptodate
pango1.0-tools:amd64/unstable 1.42.4-6 uptodate
pcscd:amd64/unstable 1.8.25-1 uptodate
perl:amd64/unstable 5.28.1-6 uptodate
perl-base:amd64/unstable 5.28.1-6 uptodate
perl-modules-5.28:all/unstable 5.28.1-6 uptodate
policykit-1:amd64/unstable 0.105-25 uptodate
policykit-1-gnome:amd64/unstable 0.105-7 uptodate
printer-driver-postscript-hp:amd64/unstable 3.18.12+dfsg0-2 uptodate
publicsuffix:all/unstable *manually* upgradeable from 20190529.1825-1 to 20190723.1836-1
puddletag:all/unstable 1.2.0-2 uptodate
python-acoustid:all/unstable 1.1.5-1 uptodate
python-asn1crypto:all/unstable 0.24.0-1 uptodate
python-audioread:all/unstable 2.1.5-1 uptodate
python-certifi:all/unstable 2018.8.24-1 uptodate
python-cffi-backend:amd64/unstable *manually* upgradeable from 1.12.2-1 to 1.12.3-1
python-chardet:all/unstable 3.0.4-3 uptodate
python-configobj:all/unstable 5.0.6-3 uptodate
python-cryptography:amd64/unstable 2.6.1-3 uptodate
python-enum34:all/unstable 1.1.6-2 uptodate
python-idna:all/unstable *manually* upgradeable from 2.6-1 to 2.6-2
python-levenshtein:amd64/unstable 0.12.0-3 uptodate
python-mysqldb:amd64/unstable 1.3.10-2 uptodate
python-openssl:all/unstable 19.0.0-1 uptodate
python-pymad:amd64/unstable 0.10-2+b1 uptodate
python-pyparsing:all/unstable 2.2.0+dfsg1-2 uptodate
python-qt4:amd64/unstable 4.12.1+dfsg-2+b1 uptodate
python-requests:all/unstable 2.21.0-1 uptodate
python-sip:amd64/unstable *manually* upgradeable from 4.19.14+dfsg-2 to 4.19.18+dfsg-1
python-urllib3:all/unstable 1.24.1-1 uptodate
python3:amd64/unstable 3.7.3-1 uptodate
python3-apt:amd64/unstable 1.8.4 uptodate
python3-distutils:all/unstable *manually* upgradeable from 3.7.3-1 to 3.7.4-3
python3-gi:amd64/unstable 3.30.4-1 uptodate
python3-lib2to3:all/unstable *manually* upgradeable from 3.7.3-1 to 3.7.4-3
python3-minimal:amd64/unstable 3.7.3-1 uptodate
python3-pycurl:amd64/unstable 7.43.0.2-0.1 uptodate
python3-uno:amd64/unstable *manually* upgradeable from 1:6.3.0~rc1-1 to 1:6.3.0~rc2-1
python3.7:amd64/unstable 3.7.4-2 uptodate
python3.7-minimal:amd64/unstable 3.7.4-2 uptodate
qdbus:amd64/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
qt-at-spi:amd64/unstable 0.4.0-9 uptodate
qtchooser:amd64/unstable 66-2 uptodate
qtcore4-l10n:all/unstable *manually* upgradeable from 4:4.8.7+dfsg-18 to 4:4.8.7+dfsg-19
systemd:amd64/unstable *manually* upgradeable from 241-5 to 241-7
task-english:all/unstable *manually* upgradeable from 3.53 to 3.54
task-print-server:all/unstable 3.53 uptodate
task-ssh-server:all/unstable *manually* upgradeable from 3.53 to 3.54
tasksel:all/unstable *manually* upgradeable from 3.53 to 3.54
tasksel-data:all/unstable *manually* upgradeable from 3.53 to 3.54
texinfo:amd64/unstable 6.6.0.dfsg.1-2 uptodate
udev:amd64/unstable *manually* upgradeable from 241-5 to 241-7
uno-libs3:amd64/unstable *manually* upgradeable from 6.3.0~rc1-1 to 6.3.0~rc2-1
unzip:i386/unstable *manually* upgradeable from 6.0-23 to 6.0-25
ure:amd64/unstable *manually* upgradeable from 6.3.0~rc1-1 to 6.3.0~rc2-1
uuid-dev:amd64/unstable *manually* upgradeable from 2.33.1-0.1 to 2.34-0.1
winetricks:all/unstable 0.0+20181203-3 uptodate
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-03 00:33

sunrat wrote:
You can also use aptitude why-not, in this case
Code: Select all
aptitude why-not motion



Code: Select all
root@blackhole:/home/csg2/VueScan/VueScan# aptitude why-not motion
Not currently installed
The candidate version 4.0-1 has priority optional
No dependencies require to remove motion
root@blackhole:/home/csg2/VueScan/VueScan#
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby stevepusser » 2019-08-03 02:20

Is it true that you have jessie and stretch repositories both enabled now, as well as possibly some packages from Sid?
I hate to say it, but if so, then this tangled web may be too knotted to unweave.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.8, Telegram-desktop 1.8.15, Pale Moon 28.7.2, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11298
Joined: 2009-10-06 05:53

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-03 12:53

stevepusser wrote:Is it true that you have jessie and stretch repositories both enabled now, as well as possibly some packages from Sid?
I hate to say it, but if so, then this tangled web may be too knotted to unweave.


I don't think I have any Jessie.

My current sources:
Code: Select all
#

# deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ stretch main

#deb cdrom:[Debian GNU/Linux 8.7.1 _Jessie_ - Official amd64 NETINST Binary-1 20170116-10:57]/ stretch main

deb http://ftp.us.debian.org/debian/ stretch main
deb-src http://ftp.us.debian.org/debian/ stretch main

deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main
deb-src http://ftp.us.debian.org/debian/ stretch-updates main
/etc/apt/sources.list (END)


When I look at the output of apt-show-versions, I don't see Jessie, or old stable. I see stretch and unstable.

In general, I accept that the only sure way to make a stable system is to do a clean install. Unfortunately, there is some custom config that was difficult to work out, and which I will have to recreate. The system has working hibernate. That was a pain. There is a working OpenVPN with some atypical settings. That was a pain. If the power goes out, the system hibernates instead of doing a shutdown. There was a mysterious lock up problem this forum helped me sort out. All that stuff, plus stuff I have forgotten will have to be set up again. If this was a plain vanilla install, I would have done it already.

At this point I figure I have nothing to lose. If some experimental attempts at unweaving screw the system up more then I already had to do a clean install anyway.
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby Head_on_a_Stick » 2019-08-03 14:01

jeffry7 wrote:unstable has a lot of hits

You could try https://www.debian.org/doc/manuals/debi ... owngrading but reinstalling is probably a better option.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10680
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-03 14:44

Head_on_a_Stick wrote:
jeffry7 wrote:unstable has a lot of hits

You could try https://www.debian.org/doc/manuals/debi ... owngrading but reinstalling is probably a better option.


Clonezilla is cranking out a backup now. After that I will try more ambitious experiments.

There is more discussion here about downgrading.
http://linuxmafia.com/faq/Debian/downgrade.html
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby Dai_trying » 2019-08-03 14:59

You could dual boot and then you would have an easy comparison of partitions side-by-side to make it easier to find the changes you have had to make.
Dai_trying
 
Posts: 832
Joined: 2016-01-07 12:25

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-03 15:16

Dai_trying wrote:You could dual boot and then you would have an easy comparison of partitions side-by-side to make it easier to find the changes you have had to make.


I do have a bigger HD sitting idle I could use for this. This will be plan B if the unweaving fails.
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby emariz » 2019-08-05 00:45

Could you post the output of the following commands?

Code: Select all
dpkg --audit
aptitude --simulate --f install
aptitude --simulate full-upgrade
emariz
 
Posts: 2916
Joined: 2008-10-17 07:59

Re: Aptitude tries to resolve dependecies forever...

Postby jeffry7 » 2019-08-05 01:17

emariz wrote:Could you post the output of the following commands?

Code: Select all
dpkg --audit
aptitude --simulate --f install
aptitude --simulate full-upgrade


dpkg --audit
returns nothing.

aptitude --simulate --f install
produces so much output I cannot post it here. I also cannot post it in pastebin. (It exceeds 150k)

full upgrade gives this:
Code: Select all
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Building tag database...
The following packages will be REMOVED:
  mariadb-common{u}
0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 75.8 kB will be freed.

Note: Using 'Simulate' mode.
Do you want to continue? [Y/n/?] Would download/install/remove packages.
jeffry7
 
Posts: 20
Joined: 2017-12-03 16:41

Re: Aptitude tries to resolve dependecies forever...

Postby emariz » 2019-08-05 13:47

Then check the dependency chain of mariadb-common and see how you can solve it, probably manually. On my system, Gnome Control Centre pulls this package through colord, which means that removing it would remove hundreds of packages. However, a previous version (from Debian Snapshot) of mariadb-common might solve the situation.
Note that, as a last resort, one can "trick" APT (the system, not the program) by modifying the dependencies of installed packages, but one must be 110 % sure that the system will hold together with the changes (a very complex exercise when the dependency chain has numerous levels.)
emariz
 
Posts: 2916
Joined: 2008-10-17 07:59

Previous

Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable