[solved] Howto enable tap click in Buster on XFCE

Kernels & Hardware, configuring network, installing services

[solved] Howto enable tap click in Buster on XFCE

Postby Onsemeliot » 2019-08-04 14:31

The solution I used on my Technoethical T400s for Stretch (on GNOME 3) unfortunately doesn't seem to work on my Acer Extensa 5220 with Buster (using XFCE).

Code: Select all
$ egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices
N: Name="SynPS/2 Synaptics TouchPad"

I have re-installed the operating system now twice after failed attempts to add the tapping option in the xorg configuration. The system wouldn't properly start after I have added the line to my configuration file in "/etc/X11/". I might have tried the wrong file but so far I was unable to find a specific Buster guide for this.

The Debian Synaptics guide doesn't even mention Buster. Is it supposed to work on Buster out of the box and it doesn't because my hardware is really outdated now?
Last edited by Onsemeliot on 2019-08-04 15:37, edited 1 time in total.
User avatar
Onsemeliot
 
Posts: 221
Joined: 2010-12-15 14:43


Re: Howto enable tap click in Buster on XFCE

Postby Head_on_a_Stick » 2019-08-04 15:10


That guide's a bit crap, the configuration file will be over-written if the xserver-xorg-input-libinput package is updated. Also the configuration file says to just use snippets rather than the entire file:
40-libinput.conf wrote:# If you want to configure your devices, do not copy this file.
# Instead, use a config snippet that contains something like this:
#
# Section "InputClass"
# Identifier "something or other"
# MatchDriver "libinput"
#
# MatchIsTouchpad "on"
# ... other Match directives ...
# Option "someoption" "value"
# EndSection
#
# This applies the option any libinput device also matched by the other
# directives. See the xorg.conf(5) man page for more info on
# matching devices.

@OP: copy the touchpad section in /usr/share/X11/xorg.conf.d/40-libinput.conf to it's own file at /etc/X11/xorg.conf.d/40-libinput.conf and edit that instead.

Alternatively, install xserver-xorg-input-synaptics to use the old synaptics driver.
Don't break DebianHow to report bugs

SharpBang GNU/Linux® — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10695
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Howto enable tap click in Buster on XFCE

Postby Onsemeliot » 2019-08-04 15:36

Thank you for your fast help.

Tap click worked after I copied the configuration file and added the option. (I had to create the "xorg.conf.d" folder first.) But I lost my Xfce panels. I could only use right-click on the desktop in order to get any menus. Therefore I navigated to the panels configuration. After that my panels came back. It said I need to save the panels after logging out or I would not have them when logging in again.

I found an option to save the panels on logout but each time I logged in I got the error that the panels aren't available. When I then selected to enable the panels I got an error telling me that they can not be changed as a normal user because they run in kiosk mode.

I could overcome this problem by logging out and deleting all files in "/home/username/.cache/sessions" but afterwards I couldn't adapt the panel settings any more.

On top of that the system needed an unusual long time to boot and log-out or log-in. (I had to wait for at least 30 seconds before anything happened when I select either option.) So I suspect there was something failing again but I had no clue how to narrow it down. After all I made a totally fresh installation just about an hour earlier.

Therefore I did the third or even fourth installation this day and this time selected GNOME 3 instead of Xfce. There everything worked out of the box but it is slow – even if version 3.20 does actually need fewer resources than older GNOME 3 versions. So I am again uncertain how to best proceed. Since the Acer Extensa 5220 can't take more than 2 GB RAM it might be better to use Xfce but if I can't get it working properly and keep having ridiculous login- and logout-delays the performance gain might be more than leveled by other issues that slow me down and annoy me. And I didn't even mention the odd behavior that during typing in the LUKS pass phrase I get messages that produce several lines with unfinished pass phrases in the middle. Fortunately, this is more an optical problem since I can keep typing and the functionality is not hindered by the additional output. It just feels very odd that the output is creating copies of what I am typing mixed with error messages I still need to document. (The pass phrase isn't shown. It's just the stars that indicate the length of what I am typing.)

I guess I will give Xfce an other try when I have more time to tinker with it.

[update]:
The ridiculous login times and messages during boot did come up on GNOME 3 also after the first boot. I found a tip how to resolve this but both options failed to resolve my issue. If anything the boot is even slower now.
User avatar
Onsemeliot
 
Posts: 221
Joined: 2010-12-15 14:43


Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable