multipath-tools problems in Debian 10 vs 9

Kernels & Hardware, configuring network, installing services

multipath-tools problems in Debian 10 vs 9

Postby darkpixel » 2019-09-11 01:30

I have two identical servers. They are both packed with the same number of HGST SAS drives.
One I immediately configured with Debian 9 and put into service. It works perfectly.

The other wasn't needed immediately, so it sat for a month or so. Today I loaded Debian 10 on to it.

Both servers have multipath-tools installed, but Debian 9 magically detects the multiple paths and drives while Debian 10 does not.

Code: Select all
root@ussnisdnas01:~# lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 9.9 (stretch)
Release:   9.9
Codename:   stretch
root@ussnisdnas01:~# multipathd show paths
hcil     dev  dev_t  pri dm_st  chk_st dev_st  next_check     
0:0:0:0  sdd  8:48   1   active ready  running XXXXXXXXXX 20/20
0:0:1:0  sde  8:64   1   active ready  running XXXXXX.... 13/20
0:0:10:0 sdn  8:208  1   active ready  running XXXXXXXXX. 18/20
0:0:11:0 sdo  8:224  1   active ready  running XXXXXXXXX. 18/20
0:0:2:0  sdf  8:80   1   active ready  running XXXX...... 8/20
0:0:3:0  sdg  8:96   1   active ready  running XXXXXXXXX. 18/20
0:0:4:0  sdh  8:112  1   active ready  running XXXXXXX... 14/20
0:0:5:0  sdi  8:128  1   active ready  running XX........ 5/20
0:0:6:0  sdj  8:144  1   active ready  running XXXXXXXXXX 20/20
0:0:7:0  sdk  8:160  1   active ready  running XXXXXX.... 13/20
0:0:8:0  sdl  8:176  1   active ready  running XXXXXXXXX. 18/20
0:0:9:0  sdm  8:192  1   active ready  running .......... 1/20
0:0:13:0 sdp  8:240  1   active ready  running .......... 1/20
0:0:14:0 sdq  65:0   1   active ready  running XXXX...... 9/20
0:0:23:0 sdz  65:144 1   active ready  running XXXXXXXXX. 18/20
0:0:24:0 sdaa 65:160 1   active ready  running XXXXXXXXXX 20/20
0:0:15:0 sdr  65:16  1   active ready  running XXXXXXXXX. 18/20
0:0:16:0 sds  65:32  1   active ready  running XXXXXXXXX. 18/20
0:0:17:0 sdt  65:48  1   active ready  running XXXXXXX... 14/20
0:0:18:0 sdu  65:64  1   active ready  running XXXXXX.... 13/20
0:0:19:0 sdv  65:80  1   active ready  running .......... 1/20
0:0:20:0 sdw  65:96  1   active ready  running XX........ 4/20
0:0:21:0 sdx  65:112 1   active ready  running .......... 1/20
0:0:22:0 sdy  65:128 1   active ready  running .......... 1/20
10:0:0:0 sdc  8:32   1   undef  ready  running orphan         
5:0:0:0  sda  8:0    1   active ready  running XXXXX..... 11/20
9:0:0:0  sdb  8:16   1   undef  ready  running orphan         
root@ussnisdnas01:~#


Code: Select all
root@usbvesdnas01:~# lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux 10 (buster)
Release:   10
Codename:   buster
root@usbvesdnas01:~# multipathd show paths
hcil     dev  dev_t  pri dm_st chk_st dev_st  next_check
0:0:0:0  sdd  8:48   1   undef undef  unknown orphan   
0:0:1:0  sde  8:64   1   undef undef  unknown orphan   
0:0:10:0 sdn  8:208  1   undef undef  unknown orphan   
0:0:11:0 sdo  8:224  1   undef undef  unknown orphan   
0:0:2:0  sdf  8:80   1   undef undef  unknown orphan   
0:0:3:0  sdg  8:96   1   undef undef  unknown orphan   
0:0:4:0  sdh  8:112  1   undef undef  unknown orphan   
0:0:5:0  sdi  8:128  1   undef undef  unknown orphan   
0:0:6:0  sdj  8:144  1   undef undef  unknown orphan   
0:0:7:0  sdk  8:160  1   undef undef  unknown orphan   
0:0:8:0  sdl  8:176  1   undef undef  unknown orphan   
0:0:9:0  sdm  8:192  1   undef undef  unknown orphan   
0:0:13:0 sdp  8:240  1   undef undef  unknown orphan   
0:0:14:0 sdq  65:0   1   undef undef  unknown orphan   
0:0:23:0 sdz  65:144 1   undef undef  unknown orphan   
0:0:24:0 sdaa 65:160 1   undef undef  unknown orphan   
0:0:15:0 sdr  65:16  1   undef undef  unknown orphan   
0:0:16:0 sds  65:32  1   undef undef  unknown orphan   
0:0:17:0 sdt  65:48  1   undef undef  unknown orphan   
0:0:18:0 sdu  65:64  1   undef undef  unknown orphan   
0:0:19:0 sdv  65:80  1   undef undef  unknown orphan   
0:0:20:0 sdw  65:96  1   undef undef  unknown orphan   
0:0:21:0 sdx  65:112 1   undef undef  unknown orphan   
0:0:22:0 sdy  65:128 1   undef undef  unknown orphan   
10:0:0:0 sdc  8:32   1   undef undef  unknown orphan   
5:0:0:0  sda  8:0    1   undef undef  unknown orphan   
9:0:0:0  sdb  8:16   1   undef undef  unknown orphan   
root@usbvesdnas01:~#


I've been all through the man pages for multipathd, double and triple-checked the config files. Everything looks like it should be working.
Since I'm a bit of a noob when it comes to SAS and multipath, does anyone have any insight into what I may be missing?
darkpixel
 
Posts: 2
Joined: 2019-09-11 01:19

Re: multipath-tools problems in Debian 10 vs 9

Postby darkpixel » 2019-09-11 16:30

Finally found it.
It looks like the multipath-tools defaults changed between 9 and 10. Specifically the find_multipaths setting.

I added:
Code: Select all
defaults {
   find_multipaths yes
}


to /etc/multipath.conf and restart the tools.

It now detects the drives properly.
darkpixel
 
Posts: 2
Joined: 2019-09-11 01:19


Return to System configuration

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable