[Solved] -Virtual Machine Manager 2.0.0 in Buster

Kernels & Hardware, configuring network, installing services

[Solved] -Virtual Machine Manager 2.0.0 in Buster

Postby CwF » 2019-09-12 14:57

I came up with a strange issue.
Using VMM 2.0.0 from Buster the "Add a Storage Volume" dialog no longer includes a 'backing store' option. It is usually below the "Format' drop down , and above the 'Storage Volume Quota' statement.

Helpful would simply be someones's confirmation a default VMM install in Buster does have this option?

Unhelpful would be trying to digest the status or health of this system.
1. Rolling update from Jessie to Stretch to Buster. Synaptic makes no complaints, nothing broken, etc.
2. Has been many things, broken and fixed many times. Issue goes back before Busters move to stable.
3. Disposable copy.

Note on #2, most recently I did try to get nftables working and removed iptables. Broke, and put it back. Continued working on the new machine versions, etc, everything working, past vm's, layers storage vm's (so it does understand backing stores) and then went to create a new test layer, and the option is missing. First time I noticed, I checked an older image from before the above testing, same thing.

Is it remotely possible they removed it? Yes I can try an earlier image, start over, just thought someone else has noticed. It's odd it's simply not there, I'd expect it to be grayed out if I had a dependency issue. In comparable package list, I see nothing missing.
Last edited by CwF on 2019-09-13 14:37, edited 1 time in total.
CwF
 
Posts: 485
Joined: 2018-06-20 15:16

Re: Solved -Virtual Machine Manager 2.0.0 in Buster

Postby CwF » 2019-09-13 14:33

Well, without any confirmation I'll just start guessing...

The function really is gone. I found a screenshot, also with the option missing. My heart sank.

I created these system a few years ago for the express purpose of preserving obsolete stuff that has no replacement. It never occurred to me that the hypervisor itself could become frozen in time. So my Stretch has been given an indefinite lease on life, it won't be upgraded. There is a reason the stretch version has no browser, no mail, no nothing. I wonder if a skip to bullseye will be possible in few years.

The buster version is not an improvement so far. I continued with other stuff, have some more testing to do, but what's the use, I want a divorce.

So I consulted the counselor, his name is root, at least my ROOT environment still works. Ya know, where I can do things without typing su sudo sudio password ever 10 seconds...I did some digging and found the issue. Buster has proven to have a few things in flux, like every release does - things that old ways are leaving, new ways are not solidified, so things don't work without actually being broken. Root stuff (pkexec/gksu/Phil Collins), iptables is still required, and more.

Add another. Qemu-img, a favorite of mine, has changed. It appears to be improved. Syntax changed slightly. I was close to using dynamite since old syntax was not working but I did manage to create a new layer qcow on a 'backing store'. So technically, buster still works and I simply need the cli to do it. BACKWARDS we go. Then my guess solidified. VMM 2.0.0 maybe does not have the new way baked in. So no more easy GUI'ing. Other qcow capabilities did make it into the new VMM 2.0 gui, looks like sparseness improved - something that needed cli help in the past, so maybe we're even.

I still love debian, I'll stay.

I do wish gui cpu pinning was still there, that was absent from stretch - the last time I blew a fuse.
CwF
 
Posts: 485
Joined: 2018-06-20 15:16


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable