Keyboard and mouse not working

Kernels & Hardware, configuring network, installing services

Keyboard and mouse not working

Postby maraska » 2019-11-16 09:25

After yesterday bullseye update mouse and keyboard stopped working.
I can see logitech receiver with lsusb and mouse and keyboard in Xfce xfce4-power-manager.
Everything works in grub but not on lightdm and desktop.

edit:
there is no device connected in xfce4-mouse-settings
maraska
 
Posts: 21
Joined: 2012-01-09 17:55

Re: Keyboard and mouse not working

Postby maraska » 2019-11-16 10:54

My device is not listed . How to reconfigure this?
Code: Select all
 xinput list
⎡ Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]

Code: Select all
cat /var/log/Xorg.0.log
The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
config/udev: Adding input device Logitech Performance MX (/dev/input/mouse0)
[     6.742] (II) No input driver specified, ignoring this device.
[     6.742] (II) This device may have been added with another device file.


Code: Select all
setxkbmap -print -verbose 10
Setting verbose level to 10
locale is C
Trying to load rules file ./rules/evdev...
Trying to load rules file /usr/share/X11/xkb/rules/evdev...
Success.
Applied rules from evdev:
rules:      evdev
model:      pc105
layout:     us
Trying to build keymap using the following components:
keycodes:   evdev+aliases(qwerty)
types:      complete
compat:     complete
symbols:    pc+us+inet(evdev)
geometry:   pc(pc105)
xkb_keymap {
   xkb_keycodes  { include "evdev+aliases(qwerty)"   };
   xkb_types     { include "complete"   };
   xkb_compat    { include "complete"   };
   xkb_symbols   { include "pc+us+inet(evdev)"   };
   xkb_geometry  { include "pc(pc105)"   };
};

This is part of my xorg.conf.
Code: Select all
Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   Screen      1  "Screen1" RightOf "Screen0"
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "auto"
   Option       "Device" "/dev/input/mice"
   Option       "ZAxisMapping" "4 5"
       Option      "XAxisMapping" "6 7"  #uncomment if you want horizontal scrolling with mouse wheel
        Option      "Buttons"    "17"
EndSection
maraska
 
Posts: 21
Joined: 2012-01-09 17:55

Re: Keyboard and mouse not working

Postby maraska » 2019-11-16 21:22

udev-243-5 update is problem.
I downgradeded udev and libudev1 and that solved problem.
maraska
 
Posts: 21
Joined: 2012-01-09 17:55

Re: Keyboard and mouse not working

Postby None1975 » 2019-11-17 06:39

maraska wrote:udev-243-5 update is problem.
I downgradeded udev and libudev1 and that solved problem.

Please, write a bug report to Debian bug tracking system.
OS: Debian 10.1 Buster / WM: fvwm
Debian Wiki | DontBreakDebian, My config files in github
User avatar
None1975
 
Posts: 956
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius


Return to System configuration

Who is online

Users browsing this forum: Heliosstyx and 15 guests

fashionable