Multipathing not working as desired.

Kernels & Hardware, configuring network, installing services

Multipathing not working as desired.

Postby kumar.ranjan » 2020-01-07 07:54

Hi Team :
We @ western digital configured DMMP for NVMeOF. We are using Debian 9.11.
But the proablem is, when "multipath -ll" command is exected, it reports :

Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed
Jan 06 16:37:30 | io_setup failed



To overcome the above error, I increased the asynchronous I/O contexts [by setting fs.aio-max-nr = 1048576 ].
This time, when I run "multipath -ll" , the output hangs for 30 seconds to come back to the prompt.


strace shows these prints :

.
.
fcntl(30, F_GETFL) = 0xc000 (flags O_RDONLY|O_DIRECT|O_LARGEFILE)
fcntl(30, F_SETFL, O_RDONLY|O_LARGEFILE) = 0
io_destroy(0x7fd8a6512000) = 0
close(30) = 0
fcntl(31, F_GETFL) = 0xc000 (flags O_RDONLY|O_DIRECT|O_LARGEFILE)
fcntl(31, F_SETFL, O_RDONLY|O_LARGEFILE) = 0
io_destroy(0x7fd8a6501000) = 0
close(31) = 0
fcntl(32, F_GETFL) = 0xc000 (flags O_RDONLY|O_DIRECT|O_LARGEFILE)
fcntl(32, F_SETFL, O_RDONLY|O_LARGEFILE) = 0
io_destroy(0x7fd8a64f0000^Cstrace: Process 17748 detached





How do I overcome this problem, now ?
kumar.ranjan
 
Posts: 4
Joined: 2020-01-06 18:11

Re: Multipathing not working as desired.

Postby kumar.ranjan » 2020-01-08 06:48

Please let me know if you need information. Any response would be greatly helpful.
kumar.ranjan
 
Posts: 4
Joined: 2020-01-06 18:11

Re: Multipathing not working as desired.

Postby Pakos » 2020-01-08 19:58

can you show cat /proc/sys/fs/aio-nr?
User avatar
Pakos
 
Posts: 100
Joined: 2008-03-08 17:36

Re: Multipathing not working as desired.

Postby kumar.ranjan » 2020-01-21 05:07

Thank you for commenting.
Issue got resolved with buster packages.

# ls -l
total 936
-rw-r--r-- 1 hgst hgst 330728 Jan 16 04:41 libsystemd0_241-7_deb10u2_amd64.deb
-rw-r--r-- 1 hgst hgst 325328 Jan 16 04:41 libtinfo6_6.1+20181013-2+deb10u2_amd64.deb
-rw-r--r-- 1 hgst hgst 295836 Jan 16 04:41 multipath-tools_0.7.9-3_amd64.deb
kumar.ranjan
 
Posts: 4
Joined: 2020-01-06 18:11

Re: Multipathing not working as desired.

Postby kumar.ranjan » 2020-01-21 05:11

We can close this thread now.
kumar.ranjan
 
Posts: 4
Joined: 2020-01-06 18:11


Return to System configuration

Who is online

Users browsing this forum: Jethro_UK, paratrap and 11 guests

fashionable