More problems with open-infrastructure-system-build

Kernels & Hardware, configuring network, installing services

More problems with open-infrastructure-system-build

Postby tjcw » 2020-01-19 16:43

I am having problems again with building a debian live image. I get
Code: Select all
P: Configuring file /etc/apt/sources.list
Hit:1 http://ftp.us.debian.org/debian buster InRelease
Ign:2 http://ftp.us.debian.org/debian-security buster/updates InRelease
Get:3 http://ftp.us.debian.org/debian buster-updates InRelease [49.3 kB]
Err:4 http://ftp.us.debian.org/debian-security buster/updates Release
  404  Not Found [IP: 64.50.236.52 80]
Get:5 http://ftp.us.debian.org/debian buster/main Sources [7832 kB]
Get:6 http://ftp.us.debian.org/debian buster-updates/main Sources [2544 B]
Get:7 http://ftp.us.debian.org/debian buster-updates/main amd64 Packages [5792 B]
Get:8 http://ftp.us.debian.org/debian buster-updates/main Translation-en [3655 B]
Reading package lists...
E: The repository 'http://ftp.us.debian.org/debian-security buster/updates Release' does not have a Release file.
P: Begin unmounting filesystems...

The full build log and a tarball of the 'config' directory are here http://tjcw.freeshell.org/oisb-1/ .

Can anyone tell me what I am doing wrong ?
tjcw
 
Posts: 22
Joined: 2019-12-08 21:14

Re: More problems with open-infrastructure-system-build

Postby arochester » 2020-01-19 17:37

I would suspect
Code: Select all
Err:4 http://ftp.us.debian.org/debian-security buster/updates Release
  404  Not Found [IP: 64.50.236.52 80]
and
Code: Select all
E: The repository 'http://ftp.us.debian.org/debian-security buster/updates Release' does not have a Release file.


Security isn't ftp it is http.

Perhaps the line should be
Code: Select all
deb http://security.debian.org/ stable/updates main


A wider question might be what does your sources list say and what are the contents of sources.list.d?
arochester
 
Posts: 1694
Joined: 2010-12-07 19:55

Re: More problems with open-infrastructure-system-build

Postby tjcw » 2020-01-19 18:24

Changing the security-related servers to 'deb.debian.org' has fixed the issue.
I'm using the open-infrastructure-system-build tools, specifically 'lb config' and 'lb build', so I don't set up the sources for apt explicitly. If the problem reoccurs I will report what I can find.
tjcw
 
Posts: 22
Joined: 2019-12-08 21:14

Re: More problems with open-infrastructure-system-build

Postby tjcw » 2020-01-19 21:52

I got futher, but I still don't get an iso. Now the attempted build fails with
Code: Select all
Get:1 http://security.debian.org buster/updates InRelease [65.4 kB]
Get:2 http://security.debian.org buster/updates/main Sources [98.4 kB]
Ign:3 https://ftp.us.debian.org/debian buster InRelease
Get:4 http://security.debian.org buster/updates/main amd64 Packages [171 kB]
Get:5 http://security.debian.org buster/updates/main Translation-en [89.3 kB]
Ign:6 https://ftp.us.debian.org/debian buster-updates InRelease
Err:7 https://ftp.us.debian.org/debian buster Release
  Certificate verification failed: The certificate is NOT trusted. The name in the certificate does not match the expected.  Could not handshake: Error in the certificate verification. [IP: 64.50.236.52 443]
Err:8 https://ftp.us.debian.org/debian buster-updates Release
  Certificate verification failed: The certificate is NOT trusted. The name in the certificate does not match the expected.  Could not handshake: Error in the certificate verification. [IP: 64.50.236.52 443]
Reading package lists...
E: The repository 'https://ftp.us.debian.org/debian buster Release' does not have a Release file.
E: The repository 'https://ftp.us.debian.org/debian buster-updates Release' does not have a Release file.

Can anyone tell me what is likely to be causing this error ? I have refreshed the files under http://tjcw.freeshell.org/oisb-1/ with the tarball of the failing config and the output of the 'lb' commands.
tjcw
 
Posts: 22
Joined: 2019-12-08 21:14

Re: More problems with open-infrastructure-system-build

Postby Head_on_a_Stick » 2020-01-20 12:02

What if you use the redirector for all of the sources? It works for me™ with live-build.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12271
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: More problems with open-infrastructure-system-build

Postby pcalvert » 2020-01-20 19:07

Please post the output of this command:
Code: Select all
apt policy open-infrastructure-system-build


Phil
“Property is the fruit of labor; property is desirable; it is a positive good
in the world. That some should be rich shows that others may become
rich, and hence is just encouragement to industry and enterprise.”
— Abraham Lincoln
pcalvert
 
Posts: 1895
Joined: 2006-04-21 11:19
Location: Sol Sector

Re: More problems with open-infrastructure-system-build

Postby tjcw » 2020-01-21 06:44

How do I use the redirector, and where should I issue the apt policy command ? (There are several 'chroot's in an open infrastructure system builld)
I think the problem has to do with the particular debs in my build, maybe ca-certificates or something related to it. When I try a build with a restricted set of debs, it proceeds to a normal conclusion.
I am currently trying to get a clean listing of failing build and a successful build so I can post them here. Meanwhile if you try to build with the config directory from http://tjcw.freeshell.org/oisb-1/ I think you will see the failure.
tjcw
 
Posts: 22
Joined: 2019-12-08 21:14

Re: More problems with open-infrastructure-system-build

Postby tjcw » 2020-01-21 08:22

An attempt to do an open infrastructure system build with an empty desktop.list.chroot file fails with the same problem. This used to work, so I think there must be a bug in one of the recent revisions to one of the debs.
'config' tarball and output from the failing build are here http://tjcw.freeshell.org/oisb-fail/ . Please can someone who knows what they are doing take a look at this, and help me raise the bug report against the right component.
My 'lb' command were
Code: Select all
lb clean
lb config --distribution=buster
lb build
tjcw
 
Posts: 22
Joined: 2019-12-08 21:14


Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable