Upgrade Apache2 from 2.4.10 to 2.4.41

Kernels & Hardware, configuring network, installing services

Upgrade Apache2 from 2.4.10 to 2.4.41

Postby coppolino97 » 2020-01-23 21:43

Hi all,
I need to upgrade an Apache2 server to security reason.
I have searched online, but I did not find a way to update Apache2 web server on a Debian server.
Can anyone suggest the right way?

Thanks so much :D
HP Elitebook 840 G3 | 8Gbyte of RAM | Intel core i5 | SSD 250GB | Debian 10
coppolino97
 
Posts: 61
Joined: 2018-06-05 15:23

Re: Upgrade Apache2 from 2.4.10 to 2.4.41

Postby kedaha » 2020-01-23 23:15

How about backports?
Code: Select all
$ rmadison apache2 |grep buster-backports
apache2    | 2.4.41-1~bpo10+1  | buster-backports
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3036
Joined: 2008-05-24 12:26

Re: Upgrade Apache2 from 2.4.10 to 2.4.41

Postby dilberts_left_nut » 2020-01-24 05:17

Also worth nothing that the stable version receives support from the Debian Security team, so will be much more "secure" than the one from backports (which you'll need to manage yourself).
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5029
Joined: 2009-10-05 07:54
Location: enzed

Re: Upgrade Apache2 from 2.4.10 to 2.4.41

Postby coppolino97 » 2020-01-25 17:59

Hi all,
thanks for all information.
I don't know about backports, I am a new Debian user.
Thanks so much!
:D
HP Elitebook 840 G3 | 8Gbyte of RAM | Intel core i5 | SSD 250GB | Debian 10
coppolino97
 
Posts: 61
Joined: 2018-06-05 15:23

Re: Upgrade Apache2 from 2.4.10 to 2.4.41

Postby coppolino97 » 2020-01-30 15:16

I am trying to use backports on my debian machine but I have problem.

This is my configuration file of source.list

Code: Select all
cat /etc/apt/sources.list

# deb cdrom:[Debian GNU/Linux 9.0.0 _Stretch_ - Official amd64 NETINST 20170617-13:06]/ stretch main
#deb cdrom:[Debian GNU/Linux 9.0.0 _Stretch_ - Official amd64 NETINST 20170617-13:06]/ stretch main

deb http://ftp.it.debian.org/debian/ stretch main
deb-src http://ftp.it.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main
deb-src http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile' (attivi)
deb http://ftp.it.debian.org/debian/ stretch-updates main
deb-src http://ftp.it.debian.org/debian/ stretch-updates main

#backports
deb http://deb.debian.org/debian stretch-backports main


What is wrong?
Thanks
HP Elitebook 840 G3 | 8Gbyte of RAM | Intel core i5 | SSD 250GB | Debian 10
coppolino97
 
Posts: 61
Joined: 2018-06-05 15:23


Return to System configuration

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable