problems with updating my debian stretch

Kernels & Hardware, configuring network, installing services

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 20:46

L_V wrote:
Code: Select all
cd /etc/apt/sources.list.d/

rm  canonical_partner.list additional-repositories.list mono-xamarin.list alexlarsson-flatpak-jessie.list saiarcot895-flightgear-jessie.list
rm atareao-updf-jessie.list webupd8team-atom-jessie.list strukturag-libde265-jessie.list hanipouspilot-rtlwifi-jessie.list
rm oibaf-graphics-drivers-jessie.list nilarimogard-webupd8-jessie.list colingille-freshlight-jessie.list

apt update


after apt update I get these warnings too I didn't run the install command yet . I wanted to let you know the output :
Code: Select all
1220 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release 

W: Some index files failed to download. They have been ignored, or old ones used instead.
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)

rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 20:46

rezapanda wrote:I also made a mistake I have debian jessie not stretch I realized this when I talked to my brother who said at the time you installed debian there were no stretch and probably I have jessie , I also checked the handbook that I downloaded years ago at the time i installed debian and its jessie . but when I run the command to see my debian version it says 9.11 and the code name is : n/a . which is weird . I installed debian jessie in the first place 3 or 4 years ago . I am a little confused . I had debian jessie but now it says its 9.11 which is stretch . what has happened ?

To summarize: what do you want / what do you need ? What is your problem ?
If you don't know, ask your brother or sister or father. No difference to me.

Ask your brother if he is OK with a fresh Buster installation....
Last edited by L_V on 2020-01-27 20:50, edited 1 time in total.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 20:48

L_V wrote:
Code: Select all
cd /etc/apt/sources.list.d/

rm  canonical_partner.list additional-repositories.list mono-xamarin.list alexlarsson-flatpak-jessie.list saiarcot895-flightgear-jessie.list
rm atareao-updf-jessie.list webupd8team-atom-jessie.list strukturag-libde265-jessie.list hanipouspilot-rtlwifi-jessie.list
rm oibaf-graphics-drivers-jessie.list nilarimogard-webupd8-jessie.list colingille-freshlight-jessie.list

apt update


I get this result after this part before install -f command . here is the output there are some warnings :
Code: Select all
1220 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Ignoring file '50unattended-upgrades.ucf-dist' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://dl.google.com stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release 

W: Some index files failed to download. They have been ignored, or old ones used instead.
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)

rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 20:52

No need to copy again your previous message.
The question is: what do you want (read my previous message again + question to your brother).
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 20:54

I am sorry if i made you frustrated , didn't mean to . let me give you a summary of what happened . 2 days ago I wanted to upgrade a package so I ran apt-get upgrade the-package-name . but it started to upgrade the whole system all packages . after that I started to see some problems in my debian . some programs are not running . apt-get install gives me an error which i mentioned in my first post . and some other stuff too . I thought instead of fixing each problem individually maybe its better to do an upgrade again but with correct repositories . that's what i am trying to do . actually my brother suggested to install buster too . since I don't have a back up drive now , I prefer to fix the existing debian .
rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 21:07

rezapanda wrote:let me give you a summary of what happened . 2 days ago I wanted to upgrade a package so I ran apt-get upgrade the-package-name

This is a mistake. You don't need to upgrade a system, to update a package.
You just need to ... update the database.

Now, if your brother is OK for Buster: no hesitation => go for Buster.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 21:10

do you think its possible to fix the existing debian ?
rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 21:16

Yes it should be feasible. Nothing alarming to me.
But if you want jessie and stretch at the same time, it is difficult for me.
You are going to loose time with old installation mixtures.
You need something fresh.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 21:23

Code: Select all
cd /etc/apt/sources.list.d/
rm  canonical_partner.list additional-repositories.list mono-xamarin.list alexlarsson-flatpak-jessie.list saiarcot895-flightgear-jessie.list
rm atareao-updf-jessie.list webupd8team-atom-jessie.list strukturag-libde265-jessie.list hanipouspilot-rtlwifi-jessie.list
rm oibaf-graphics-drivers-jessie.list nilarimogard-webupd8-jessie.list colingille-freshlight-jessie.list

apt update
apt install -f




can you please explain to me what this fix which you suggested earlier would do ?
rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 21:31

You already have "upgraded" to Stretch.
Then no need of any jessie packages which should be cleaned/removed if no Stretch update.

You cannot upgrade your old mixtures to Buster: don't try it.
You need something clean and fresh.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 21:36

ok I see what you mean . I guess its better to go with buster . at the time of the upgrade this line was in sources.list :
Code: Select all
#deb http://debian.drdteam.org/ stable multivers


it has used this source I guess as a source for upgrade , is this where it got the stretch packages ?
rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 21:40

What what ???
I am lost with what you did. A line starting with # is just... a comment.
Again:
Code: Select all
find /etc/apt -name '*.list' -print -exec grep '^deb ' {} \;
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 21:48

no this is commented after the upgrade which i did 2 days ago . I commented it later to add new repositories .

here is the output of your command :
Code: Select all
/etc/apt/sources.list.d/estmob-sendanywhere.list
deb http://update.send-anywhere.com/linux/debian/ stable main
/etc/apt/sources.list.d/google-chrome.list
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/skype-stable.list
deb [arch=amd64] https://repo.skype.com/deb stable main
/etc/apt/sources.list.d/google.list
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list
rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

Re: problems with updating my debian stretch

Postby L_V » 2020-01-27 21:50

Is it your brother who recommend to empty the sources.list ? Bad idea.
Code: Select all
cat /etc/apt/sources.list
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: problems with updating my debian stretch

Postby rezapanda » 2020-01-27 21:59

no my brother is not involved in what i am doing with this debian :) he just reminded me that I have debian jessie not stretch . that's all he said or did about my debian . he is not responsible at all .

Code: Select all
#deb http://ftp.debian.org/debian/ stretch main contrib non-free
#deb http://debian.drdteam.org/ stable multivers
# deb-src http://debian.drdteam.org/ stable multivers
# deb-src http://debian.drdteam.org/ stable multivers


this is how it looks now which i have commented the entries . at the time of upgrade which ruined up my debian only line 2 had no comment , that was the only thing active .
rezapanda
 
Posts: 19
Joined: 2020-01-26 23:45

PreviousNext

Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable