install bluetooth adapter 0a12:0001 Cambridge Silicon Radio

Kernels & Hardware, configuring network, installing services

install bluetooth adapter 0a12:0001 Cambridge Silicon Radio

Postby SImon2020 » 2020-01-27 16:16

Hi there, I tried to get the adapter to run, but I failed so far.

What I did:
Plug the adapter, install some packages:
apt install pulseaudio-module-bluetooth bluez-firmware btscanner blueman bluez bluez-tools libpam-blue python-bluez
sudo apt-get install bluetooth bluez libbluetooth-dev libudev-dev libcap2-bin

Some outputs that might be helpful:
Code: Select all
simon@debian-simon:~$ lsusb
Bus 002 Device 002: ID 1058:25a1 Western Digital Technologies, Inc. Elements / My Passport (WD20NMVW)
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0451:16a8 Texas Instruments, Inc.
Bus 001 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 002:[b] ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)[/b]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Journal when I plug in the adapter:
Code: Select all
simon@debian-simon:~$ sudo journalctl -f
-- Logs begin at Mon 2020-01-27 13:13:33 CET. --
Jan 27 16:56:29 debian-simon kernel: usb 1-2: new full-speed USB device number 6 using xhci_hcd
Jan 27 16:56:29 debian-simon kernel: usb 1-2: New USB device found, idVendor=0a12, idProduct=0001, bcdDevice=88.91
Jan 27 16:56:29 debian-simon kernel: usb 1-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
Jan 27 16:56:29 debian-simon kernel: usb 1-2: Product: USB1.1-A
Jan 27 16:56:29 debian-simon systemd[1]: Starting Load/Save RF Kill Switch Status...
Jan 27 16:56:29 debian-simon systemd[1]: Started Load/Save RF Kill Switch Status.
Jan 27 16:56:29 debian-simon systemd[1]: Reached target Bluetooth.


Code: Select all
simon@debian-simon:~$ bluetoothctl
[bluetooth]# list
[bluetooth]# devices
No default controller available
[bluetooth]#


Unfortunately, google lead me to this page and I followed the steps:
https://www.raspberrypi.org/forums/view ... 4#p1384009

I think this destroyed some dependencies. Before I running the stuff in the post, I had:
Code: Select all
simon@debian-simon:~$ dpkg -l blue*
Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten
| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/
         Halb installiert/Trigger erWartet/Trigger anhängig
|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)
||/ Name           Version      Architektur  Beschreibung
+++-==============-============-============-=================================
ii  bluetooth      5.50-1       all          Bluetooth support (metapackage)
ii  bluez          5.50-1       amd64        Bluetooth tools and daemons
un  bluez-alsa     <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-audio    <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-cups     <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-gnome    <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-input    <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-network  <keine>      <keine>      (keine Beschreibung vorhanden)
ii  bluez-obexd    5.50-1       amd64        bluez obex daemon
un  bluez-pan      <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-serial   <keine>      <keine>      (keine Beschreibung vorhanden)
un  bluez-utils    <keine>      <keine>      (keine Beschreibung vorhanden)
simon@debian-simon:~$


No I have:
Code: Select all
simon@debian-simon:~$ sudo dpkg -l blue*
[sudo] Passwort für simon:
dpkg-query: Kein Paket gefunden, das auf bluez-5.50 passt
dpkg-query: Kein Paket gefunden, das auf bluez-5.50.tar.xz passt
dpkg-query: Kein Paket gefunden, das auf bluez-firmware.deb passt


Sorry its partly in German, hope thats enough info. Can someone give me a hint here? Or recommend some other bluetooth adapter, that might work better?
SImon2020
 
Posts: 2
Joined: 2020-01-27 16:06

Re: install bluetooth adapter 0a12:0001 Cambridge Silicon Ra

Postby pylkko » 2020-02-01 13:14

how do you know it didn't work? you should have tried it first!
User avatar
pylkko
 
Posts: 1621
Joined: 2014-11-06 19:02


Return to System configuration

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable