No internet on Debian 10 after upgrading Windows 10 DualBoot

Kernels & Hardware, configuring network, installing services

No internet on Debian 10 after upgrading Windows 10 DualBoot

Postby Cupain7 » 2020-02-03 15:11

Hello,
After reinstalling Windows 10 in dual boot aside Debian Buster, i can connect the internet throw ethernet on Windows but no more on Debian. More precisely, Debian recognize the network card, and the connection seems active, but "locked" (the icon tray is like a locker)
I found on a forum than the Windows Wake On Lan (WOL) function could be responsible : https://superuser.com/questions/546441/ ... om-windows
I tried to desactivate all WOL's functionnalities in Windows, i also tried to activate them all, but no effect : i can't unlock the connexion on Debian.

Here is my network controller :
Code: Select all
$ lspci -nnd ::0200
22:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)


Here is what returns the "ip a" command :
Code: Select all
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp34s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:d8:61:4e:71:de brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.54/24 brd 192.168.1.255 scope global dynamic noprefixroute enp34s0
       valid_lft 85373sec preferred_lft 85373sec
    inet6 fe80::5b6d:6ef:4922:cbbd/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
    link/ether 02:42:8d:52:7d:25 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
       valid_lft forever preferred_lft forever


I hope someone can help me!
Cupain7
 
Posts: 7
Joined: 2018-06-15 08:12

Re: No internet on Debian 10 after upgrading Windows 10 Dual

Postby fred44nl » 2020-02-03 15:25

inet 192.168.1.54/24 brd 192.168.1.255 scope global dynamic noprefixroute enp34s0


for some reason, you have "noprefixroute"
this might be a problem.
Debian 10 - Buster on Compulab Fitlet2
User avatar
fred44nl
 
Posts: 179
Joined: 2018-07-14 08:54

Re: No internet on Debian 10 after upgrading Windows 10 Dual

Postby Cupain7 » 2020-02-03 16:09

Problem solved !
Windows is not in accusation... but I am. It seems that i didn't correctly close my VPN connection the last time i shut down Debian.
Disable manually my VPN resolved the internet connection problem.
I still have "noprefixroute", but it works, so...
Thank you for your help.
Cupain7
 
Posts: 7
Joined: 2018-06-15 08:12


Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable