[solved] apt-mirror not mirroring some files

Kernels & Hardware, configuring network, installing services

[solved] apt-mirror not mirroring some files

Postby Dai_trying » 2020-02-09 15:26

I have set up an apt-mirror to ease the burden on Debian servers (as well as making d/l speed quicker for me) as I experiment with using live-build to create my own installers but have come up against a small issue, the apt-mirror is working great and all machines on my local network are now set to use it and it works with no issues.
The problem is that I need to have available on my server the files available from /debian/dists/buster/main/installer-amd64/ but I do not have them in my mirror. My /etc/apt/mirror.list is as follows
Code: Select all
dai@MyServer:~$ cat /etc/apt/mirror.list
############# config ##################
set base_path    /var/spool/apt-mirror
set mirror_path  $base_path/mirror
set skel_path    $base_path/skel
set var_path     $base_path/var
set cleanscript $var_path/clean.sh
set nthreads     20
set _tilde 0

deb http://deb.debian.org/debian buster main contrib non-free
deb-src http://deb.debian.org/debian buster main contrib non-free

deb http://deb.debian.org/debian buster-updates main contrib non-free
deb-src http://deb.debian.org/debian buster-updates main contrib non-free

deb http://deb.debian.org/debian buster-backports main contrib non-free
deb-src http://deb.debian.org/debian buster-backports main contrib non-free

deb http://deb.debian.org/debian-security buster/updates main contrib non-free
deb-src http://deb.debian.org/debian-security buster/updates main contrib non-free

deb http://deb.debian.org/debian buster main/debian-installer


The error I am getting is
Code: Select all
E: Could not download file: http://192.168.1.1/debian//dists/buster/main/installer-amd64/current/images//cdrom/vmlinuz

I have checked the Debian site and it is available (http://ftp.debian.org/debian/dists/bust ... om/vmlinuz) and I would guess that I will also need the initrd.gz too but would think that when I solve this initial issue that will be available.
Is there a setting I am missing? or anything obvious to anyone?
Dai_trying
 
Posts: 905
Joined: 2016-01-07 12:25

Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable