Debian 10 "Buster" (64bits) stuck in initramfs while booting

Kernels & Hardware, configuring network, installing services

Debian 10 "Buster" (64bits) stuck in initramfs while booting

Postby hamada » 2020-02-20 06:17

My server suddenly crashed in the early morning and it's stuck in initramfs?
I received this e-mail.
Code: Select all
The intervention on <SERVER_IP> has been completed.

This operation was closed at 2020-02-20 05:35:23 CET (UTC +01:00)

Here are the details of this operation:
Diagnosis interface boot (rescue)
Date 2020-02-20 05:28:46 CET (UTC +01:00), damien D made Diagnosis interface boot (rescue):
 Here are the details of the operation performed:
The server gets stuck during the boot phase, with the message:
(initramfs)
A restart on the standard OVH kernel ('netboot') does not correct the
situation.

Actions:
Rebooting the server to "rescue" mode (Linux)
Checking cooling and hard disk : OK

result:
Boot OK. Rescue mode accessible.

recommendations:
Configuration / error to be corrected by the customer


Does anyone know how to fix this issue? Currently it's in rescue mode.
Server have soft RAID and it's /dev/md2.

Code: Select all
root@rescue:/# fsck /dev/md2
fsck from util-linux 2.25.2
e2fsck 1.42.12 (29-Aug-2014)
/: clean, 306850/29278208 files, 6774736/117080816 blocks


When mount /dev/md2 /mnt/ then I can access my files in /mnt/

I tried grub-install /dev/md2 but I am getting this output:
Code: Select all
grub-install: error: failed to get canonical path of `aufs'.

https://www.debian.org/releases/jessie/ ... 07.html.en

I tried this guide from: https://zeldor.biz/2010/12/install-grub-from-chroot/
Code: Select all
root@rescue:~# mount /dev/md2 /mnt/
root@rescue:~# mount -t proc none /mnt/proc
root@rescue:~# mount -o bind /dev /mnt/dev
root@rescue:~# mount -t sysfs sys /mnt/sys
root@rescue:~# chroot /mnt/ /bin/bash
root@rescue:/# update-grub
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.19.0-8-cloud-amd64
Found initrd image: /boot/initrd.img-4.19.0-8-cloud-amd64
Found linux image: /boot/vmlinuz-4.19.0-5-amd64
Found initrd image: /boot/initrd.img-4.19.0-5-amd64
done
root@rescue:/# /usr/sbin/grub-install --recheck --no-floppy /dev/md2
Installing for i386-pc platform.
/usr/sbin/grub-install: warning: File system `ext2' doesn't support embedding.
/usr/sbin/grub-install: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
/usr/sbin/grub-install: error: will not proceed with blocklists.


// edit: I selected OVH kernel 4.19 (netboot) in OVH server control panel and server booted up.

How I can see what kernel version was that caused server to crash? And how to change to previous kernel version? I don't want to use OVH kernel, I prefer Debian default kernel.
I think Debian updated kernel version to newer that caused server to crash.

Code: Select all
root@sysb:~# uname -a
Linux ***** 4.19.62-mod-std-ipv6-64-rescue #828825 SMP Tue Jul 30 13:54:49 UTC 2019 x86_64 GNU/Linux
hamada
 
Posts: 1
Joined: 2020-02-20 06:12

Return to System configuration

Who is online

Users browsing this forum: No registered users and 19 guests

fashionable