Network interface renamed without root action...

Kernels & Hardware, configuring network, installing services

Network interface renamed without root action...

Postby SkilleR666 » 2020-03-30 18:54


Debian version : current stable

Recently i installed 2 packages on my server :
Code: Select all
Start-Date: 2020-03-30  15:37:54
Commandline: apt-get install libsqlite3-dev
Requested-By: (1000)
Install: libsqlite3-dev:amd64 (3.27.2-3)
End-Date: 2020-03-30  15:37:56

Start-Date: 2020-03-30  15:38:30
Commandline: apt-get install libssl-dev
Requested-By:  (1000)
Install: libssl-dev:amd64 (1.1.1d-0+deb10u2)
End-Date: 2020-03-30  15:38:31

1 hours later i've do my weekly reboot. What a surprise to see that i have no more access to ssh / web service / no ping response. I tried to wait, rebooted multiple times, no success. So i've rebooted in rescue mode provided by my hosting provider, and strangely i regained ssh access (so i exclude a hardware fault). After quick investigation, i see this in the log : "ifup[782]: Cannot find device "rename2"".

I tried multiple thing to bring my network detected back, the only solution that worked is to create a udev rules with fixed named on the mac of my network card, set this name into /etc/interface, and edit the default grub settings to move to unpredictable name.

But i really don't like this solution, i want to understand why my network card just become unavailable without any sudo/root modification. If someone have some thing i can look to find from where come the problem.
Posts: 10
Joined: 2020-02-06 12:55

Re: Network interface renamed without root action...

Postby Head_on_a_Stick » 2020-03-30 19:26

SkilleR666 wrote:If someone have some thing i can look to find from where come the problem.

The answers you seek can probably be found in the systemd journal.

I highly doubt the problems are caused by those -dev packages, have you polluted your sources?
Code: Select all
apt policy
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Network interface renamed without root action...

Postby SkilleR666 » 2020-03-30 19:48

My source list is almost the default one, i've just added contrib/nonfree at the end of each line without touching anything else (no other repo, no pinning) :

Code: Select all
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 buster-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=i386
 500 buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
 500 buster/updates/non-free i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=i386
 500 buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
 500 buster/updates/main i386 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=i386
 500 buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
 500 buster/contrib i386 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=i386
 500 buster/contrib amd64 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
 500 buster/non-free i386 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=i386
 500 buster/non-free amd64 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
 500 buster/main i386 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=main,b=i386
 500 buster/main amd64 Packages
     release v=10.3,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
Pinned packages:

Ive looked into systemd journal, but don't find anything related to the problem. Tomorrow i will restore in "problematic state" and try to view the journal again.
Posts: 10
Joined: 2020-02-06 12:55

Return to System configuration

Who is online

Users browsing this forum: No registered users and 21 guests