amdgpu - Debian Testing [SOLVED]

Kernels & Hardware, configuring network, installing services

amdgpu - Debian Testing [SOLVED]

Postby questlinq » 2020-04-01 20:10

Hello,

I'm trying to install amdgpu drivers for amd a10-7800 CPU on Debian Testing ..

I've installed "xserver-xorg-video-ati xserver-xorg-video-amdgpu" and graphics/X still fails due to missing drivers.

On last stable Debian I only had to do "apt install firmware-linux" for the same CPU/graphics.

But, now when I try with "apt install firmware-linux" it fails.

I'm asking for your suggestions, thank you.
Last edited by questlinq on 2020-04-01 20:48, edited 1 time in total.
questlinq
 
Posts: 59
Joined: 2017-09-19 08:51

Re: amdgpu - Debian Testing

Postby Head_on_a_Stick » 2020-04-01 20:23

questlinq wrote:I'm trying to install amdgpu drivers

The amdgpu drivers are already included in the kernel, no need to install anything.

Confirm this with
Code: Select all
lspci -k | grep -iA3 'vga\|display\|3d'

questlinq wrote:I've installed "xserver-xorg-video-ati xserver-xorg-video-amdgpu"

You don't need xserver-xorg-video-ati but xserver-xorg-video-amdgpu will provide the amdgpu DDX drivers. They're not actually needed though, your card should also be able to use the modesetting DDX drivers built into the X server itself.

questlinq wrote:graphics/X still fails due to missing drivers

You should post (a link to) the X.Org logs for the failed session.

questlinq wrote:On last stable Debian I only had to do "apt install firmware-linux" for the same CPU/graphics.

That should work, did it pull in firmware-amd-graphics?

If you have a very new card then you may need newer firmware than Debian are currently providing, you can try MX Linux's firmware package instead (ported from Ubuntu):

http://mxrepo.com/mx/repo/pool/ahs/l/li ... +1_all.deb
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: amdgpu - Debian Testing [SOLVED]

Postby questlinq » 2020-04-01 20:52

@ Head_on_a_Stick

Thanks for your fast reply.

Found a mistake in my /etc/apt/sources-list.

I had to add "contrib non-free" - after that I was able to install drivers by runing "apt install firmware-linux".
questlinq
 
Posts: 59
Joined: 2017-09-19 08:51

Re: amdgpu - Debian Testing [SOLVED]

Postby stevepusser » 2020-04-02 03:27

And another kitten died when you called firmware "drivers". :(
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12124
Joined: 2009-10-06 05:53


Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable