Why wpa_cli save_config FAIL ?

Kernels & Hardware, configuring network, installing services

Why wpa_cli save_config FAIL ?

Postby eoffer » 2020-04-12 15:41

sudo wpa_cli

After add_network set_network try to "save_config" but always fail

Code: Select all
 sudo wpa_cli -i wlp3s0 save_config
always FAIL

Should I create a /etc/wpa_supplicant.conf file first ?
eoffer
 
Posts: 6
Joined: 2020-04-09 12:12

Re: Why wpa_cli save_config FAIL ?

Postby Head_on_a_Stick » 2020-04-13 10:39

eoffer wrote:always FAIL

Please always post the exact, full error message.

eoffer wrote:Should I create a /etc/wpa_supplicant.conf file first ?

Yes, you need these lines for wpa_cli to work:
Code: Select all
ctrl_interface=/run/wpa_supplicant
update_config=1

https://wiki.debian.org/WiFi/HowToUse#W ... d_WPA2-PSK
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Why wpa_cli save_config FAIL ?

Postby eoffer » 2020-04-14 10:58

It there a way like "strace" to find out which configuration file is used by systemd
under path usr/lib/systemd/system there are four wpa_supplicant related service
wpa_supplicant-nl80211@.service
wpa_supplicant.service
wpa_supplicant@.service
wpa_supplicant-wired@.service
eoffer
 
Posts: 6
Joined: 2020-04-09 12:12

Re: Why wpa_cli save_config FAIL ?

Postby Head_on_a_Stick » 2020-04-14 11:31

Are you actually trying to wind me up?

Here's a deal: if you respond to my last post then I will respond to your last question, even though it is clearly off-topic for this thread.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable