Getting Fan speed and voltages on Buster from B365M

Kernels & Hardware, configuring network, installing services

Getting Fan speed and voltages on Buster from B365M

Postby k829king » 2020-04-25 11:58

I've installed lm-sensors and run sensors-detect on a system using Debian Buster 10 and an Asrock B365M Phantom Gaming 4 motherboard.
All I see is
Code: Select all
$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +51.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +51.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +35.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +37.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +35.0°C  (high = +86.0°C, crit = +100.0°C)
Core 4:        +44.0°C  (high = +86.0°C, crit = +100.0°C)
Core 5:        +36.0°C  (high = +86.0°C, crit = +100.0°C)
Core 6:        +35.0°C  (high = +86.0°C, crit = +100.0°C)
Core 7:        +35.0°C  (high = +86.0°C, crit = +100.0°C)

Do I need to install anything else to get fan speeds and voltages?
k829king
 
Posts: 69
Joined: 2018-08-26 09:47

Re: Getting Fan speed and voltages on Buster from B365M

Postby Head_on_a_Stick » 2020-04-25 16:06

Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Getting Fan speed and voltages on Buster from B365M

Postby stevepusser » 2020-04-26 03:34

If it's a bleeding-edge moboard, chances are that it needs the latest kernel in buster-backports.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12124
Joined: 2009-10-06 05:53

Re: Getting Fan speed and voltages on Buster from B365M

Postby k829king » 2020-04-26 09:25

thankyou both, installed fan control I now see below and in Xsensors it shows two tabs, the one I could see before for "coretemps" and now the second for "nct6791".
Do I need to do any further config changes or is just installing fancontrol enough?
From the terminal I see a number of "ALARM" should I be concerned?
The AUXTIN1 of 107.0 degrees looks worrying, but as the unit has little turned on from cold and shows that I'm a bit sceptical.
f.y.i. I'm running kernel 5.4.0-0.bpo.4-amd64

Code: Select all
$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +27.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +24.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +25.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +23.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +25.0°C  (high = +86.0°C, crit = +100.0°C)
Core 4:        +26.0°C  (high = +86.0°C, crit = +100.0°C)
Core 5:        +25.0°C  (high = +86.0°C, crit = +100.0°C)
Core 6:        +26.0°C  (high = +86.0°C, crit = +100.0°C)
Core 7:        +24.0°C  (high = +86.0°C, crit = +100.0°C)

nct6791-isa-0290
Adapter: ISA adapter
Vcore:                  +0.38 V  (min =  +0.00 V, max =  +1.74 V)
in1:                    +1.68 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:                   +3.38 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:                  +3.36 V  (min =  +2.98 V, max =  +3.63 V)
in4:                    +1.02 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                    +1.06 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                    +1.01 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:                   +3.46 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:                   +3.07 V  (min =  +2.70 V, max =  +3.63 V)
in9:                    +1.06 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in10:                   +0.21 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in11:                   +1.05 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                   +1.26 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                   +1.29 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                   +1.05 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                   783 RPM  (min =    0 RPM)
fan2:                   481 RPM  (min =    0 RPM)
fan3:                     0 RPM  (min =    0 RPM)
fan4:                   657 RPM  (min =    0 RPM)
fan5:                     0 RPM  (min =    0 RPM)
SYSTIN:                 +23.0°C  (high = +36.0°C, hyst = +35.0°C)  sensor = thermistor
CPUTIN:                 +23.0°C  (high = +36.0°C, hyst = +35.0°C)  sensor = thermistor
AUXTIN0:                +25.0°C    sensor = thermistor
AUXTIN1:               +107.0°C    sensor = thermistor
AUXTIN2:                +23.0°C    sensor = thermistor
AUXTIN3:                +23.0°C    sensor = thermistor
PECI Agent 0:           +26.5°C  (high = +36.0°C, hyst = +35.0°C)
                                 (crit = +100.0°C)
PCH_CHIP_CPU_MAX_TEMP:   +0.0°C 
PCH_CHIP_TEMP:           +0.0°C 
PCH_CPU_TEMP:            +0.0°C 
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled
k829king
 
Posts: 69
Joined: 2018-08-26 09:47


Return to System configuration

Who is online

Users browsing this forum: No registered users and 21 guests

fashionable