Buster with sysvinit as PID1

Kernels & Hardware, configuring network, installing services

Buster with sysvinit as PID1

Postby Bulkley » 2020-04-30 23:29

On another thread I started going astray so I am starting fresh. [Moderator feel free to move my posts if necessary.]

Head_on_a_Stick posted his alternate inits and I asked how he did the first one, sysvinit as PID1. To experiment I have loaded a fresh install of SharpBang which is Head_on_a_Stick's basic configuration of Debian Buster. It is small enough to be a quick install for test purposes. I installed it as a VM using Gnome Boxes which I prefer to all the other methods I've tried. Anyway, the install went perfectly. This is what happens:

Code: Select all
# aptitude install sysvinit-core
The following NEW packages will be installed:
  initscripts{a} insserv{a} startpar{a} sysv-rc{a} sysvinit-core{b}
0 packages upgraded, 5 newly installed, 0 to remove and 22 not upgraded.
Need to get 398 kB of archives. After unpacking 823 kB will be used.
The following packages have unmet dependencies:
 systemd-sysv : Conflicts: sysvinit-core but 2.93-8 is to be installed
 sysvinit-core : Conflicts: systemd-sysv but 241-7~deb10u3 is installed
The following actions will resolve these dependencies:

      Remove the following packages:                             
1)      brltty [5.6-10 (now, stable)]                           
2)      dbus-user-session [1.12.16-1 (now, stable)]             
3)      gdebi [ (now, stable)]                       
4)      gvfs [1.38.1-5 (now, stable)]     
5)      gvfs-backends [1.38.1-5 (now, stable)]                   
6)      gvfs-daemons [1.38.1-5 (now, stable)]                   
7)      gvfs-fuse [1.38.1-5 (now, stable)]                       
8)      libpam-systemd [241-7~deb10u3 (now, stable)]             
9)      network-manager [1.14.6-2+deb10u1 (now, stable)]         
10)     network-manager-gnome [1.8.20-1.1 (now, stable)]         
11)     network-manager-openconnect [1.2.4-2 (now, stable)]     
12)     network-manager-openconnect-gnome [1.2.4-2 (now, stable)]
13)     network-manager-openvpn [1.8.10-1 (now, stable)]         
14)     network-manager-openvpn-gnome [1.8.10-1 (now, stable)]   
15)     network-manager-pptp [1.2.8-2 (now, stable)]             
16)     network-manager-pptp-gnome [1.2.8-2 (now, stable)]       
17)     network-manager-vpnc [1.2.6-2 (now, stable)]             
18)     network-manager-vpnc-gnome [1.2.6-2 (now, stable)]       
19)     policykit-1 [0.105-25 (now, stable)]                     
20)     policykit-1-gnome [0.105-7 (now, stable)]               
21)     rtkit [0.11-6 (now, stable)]                             
22)     systemd-sysv [241-7~deb10u3 (now, stable)]               
23)     udisks2 [2.8.1-4 (now, stable)]                         

      Leave the following dependencies unresolved:               
24)     dbus-user-session recommends systemd-sysv               
25)     galternatives recommends policykit-1                     
26)     gvfs-common recommends gvfs         
27)     pinentry-gnome3 recommends dbus-user-session             
28)     pulseaudio recommends rtkit                             
29)     pulseaudio recommends libpam-systemd                     
30)     pulseaudio recommends dbus-user-session                 
31)     systemd recommends libpam-systemd                       
32)     thunar recommends gvfs                                   
33)     thunar recommends policykit-1-gnome | polkit-1-auth-agent
34)     thunar recommends udisks2                               
35)     udisks2 recommends policykit-1                           
36)     upower recommends policykit-1                           
37)     xfce4-power-manager recommends libpam-systemd           
38)     xserver-xorg-core recommends libpam-systemd             

Accept this solution? [Y/n/q/?]

Of course, accepting this means losing connection to the Internet and consequent ability to fix it.
Posts: 6014
Joined: 2006-02-11 18:35

Re: Buster with sysvinit as PID1

Postby Head_on_a_Stick » 2020-05-01 09:13

Bulkley wrote:accepting this means losing connection to the Internet and consequent ability to fix it

Not really, just connect with ifupdown instead.

For wireless see https://wiki.debian.org/WiFi/HowToUse#W ... d_WPA2-PSK

And for a wired connection see https://wiki.debian.org/NetworkConfigur ... _Interface

I've just tried with a fresh SharpBang installation and switching to sysvinit removes NetworkManager, GVFS, udisks2 and policykit-1 but I didn't want those programs anyway :mrgreen:
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Return to System configuration

Who is online

Users browsing this forum: No registered users and 15 guests