LXDE quits right away, LX!t takes over.

Kernels & Hardware, configuring network, installing services

LXDE quits right away, LX!t takes over.

Postby jeffleiden » 2020-05-05 21:05

Hi,

Does anyone have any idea what my PC is doing? I recently installed debian 10 including support for LXDE as well as LXqt. In the login screen you can select between them, and either one will come up as desired. With one exception. When logging in as the main user and with LXDE selected, what looks like LXDE comes up briefly and then within a couple seconds the screen goes <flash> and I'm in LXqt -- just as if I had requested LXqt
jeffleiden
 
Posts: 4
Joined: 2020-05-05 20:44

Re: LXDE quits right away, LX!t takes over.

Postby jeffleiden » 2020-05-05 21:09

Sorry, that got posted prematurely (which goddamn key did I accidently hit??). But as I was saying, it's as if LXDE crashes and LXQt takes over seamlessly (no errors reported). And again, on the other accounts, this doesn't happen. I have no idea where to even look for a setting that might be involved. (And BTW, where is the login screen configuration stored?).

Thanks for your help!
jeffleiden
 
Posts: 4
Joined: 2020-05-05 20:44

Re: LXDE quits right away, LX!t takes over.

Postby arochester » 2020-05-05 21:27

Has it ever worked in LXDE?

Have you tried re-installing LXDE?
arochester
 
Posts: 1769
Joined: 2010-12-07 19:55

Re: LXDE quits right away, LX!t takes over.

Postby jeffleiden » 2020-05-05 21:33

arochester wrote:Has it ever worked in LXDE?



Oh yes, LXDE works fine when a different user logs in. That's why it's so frustrating to see it come up and then turn into LXQt when I log in as me!! If nothing else I might start running as a different user, but that would be a hassle. I just want to login with LXDE like every other user can when they use my computer (all zero of them ;-)

Ideas?
jeffleiden
 
Posts: 4
Joined: 2020-05-05 20:44

Re: LXDE quits right away, LX!t takes over.

Postby Head_on_a_Stick » 2020-05-06 11:36

Do you have a .xsession, .xsessionrc, .xinitrc or .dmrc file in your home directory that might be forcing the LXQt desktop? Also check ~/.profile
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: LXDE quits right away, LX!t takes over.

Postby jeffleiden » 2020-05-06 14:43

Head_on_a_Stick wrote:Do you have a .xsession, .xsessionrc, .xinitrc or .dmrc file in your home directory that might be forcing the LXQt desktop? Also check ~/.profile


Thanks! I checked .profile but its few lines don't appear related. My .dmrc file includes "Session=LXDE" so that hardly explains the problem. The other files you mention are not found in ~/ (could they be in a subdirectory?). I will look further when I get home. Also, mainly in order to narrow this problem down (but I might use it anyway!) I just downloaded support for xfce but haven't tried that yet. Will report back later. Thanks for the suggestions.
jeffleiden
 
Posts: 4
Joined: 2020-05-05 20:44

Re: LXDE quits right away, LX!t takes over.

Postby Head_on_a_Stick » 2020-05-06 19:12

jeffleiden wrote:I checked .profile but its few lines don't appear related

Compare and contrast the file in $HOME with /etc/skel/.profile to see if anything has been added (or just post the full content here if you're not sure).

jeffleiden wrote:The other files you mention are not found in ~/ (could they be in a subdirectory?).

No, I meant ~/.{xsession{,rc},xinitrc}.

Which display manager is this? You could try stopping it with
Code: Select all
# systemctl isolate multi-user.target

Then see what happens when you log in at the console and run 'startx'. That should run whatever is linked to /etc/alternatives x-session-manager, you can change that with
Code: Select all
# update-alternatives --config x-session-manager

^ Does setting that to LXDE run that desktop correctly with 'startx'?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12744
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to System configuration

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable