Eaton Network-M2 fail to load even with Github nut

Kernels & Hardware, configuring network, installing services

Eaton Network-M2 fail to load even with Github nut

Postby dvb » 2020-06-21 17:33

Hello,

I have an issue using "nut" and "Eaton 5PX" with Networkcard-M2.
I installed nut from GitHub, this version supports this new "M2 card" from Eaton :
- with my second UPS (using old network-card, not M2), all is OK.
- with M2 card, driver begins to load, but get stucks and never finish to load :

Code: Select all
    sudo /usr/local/ups/sbin/upsdrvctl start
    Network UPS Tools - UPS driver controller 2.7.4.1
    Network UPS Tools - Generic SNMP UPS driver 1.12 (2.7.4.1)
    >> System stops here. <<

/var/state/ups :
Code: Select all
    snmp-ups-MGE.pid
    >> Nothing else <<

I double checked all files.conf without finding anything :

Adding to /usr/local/ups/etc/nut.conf
Code: Select all
    MODE=standalone


Adding to /usr/local/ups/etc/ups.conf
Code: Select all
    [MGE]
    driver = snmp-ups
    port = 192.168.200.252
    desc = "Eaton Evolution S3000"
    community = public

Adding to /usr/local/ups/etc/upsd.conf

Code: Select all
    LISTEN 127.0.0.1 3493


Adding to /usr/local/ups/etc/upsd.users
Code: Select all
    [admin]
    password = me
    allowfrom = localhost
    upsmon master
    actions = SET
    instcmds = ALL

    [ups]
    password = me
    allowfrom = localhost
    upsmon master
    actions = SET
    instcmds = ALL

    [test]
    password = me
    allowfrom = localhost
    upsmon master
    actions = SET
    instcmds = ALL

Running with theses commands :

Code: Select all
  sudo /usr/local/ups/sbin/upsdrvctl start
    sudo /etc/init.d/nut-server start
    /usr/local/ups/bin/upsc -l

Does M2 card need a password before loading ?
Could you please help me to fix this issue ?

Thank you.
dvb
 
Posts: 6
Joined: 2020-01-05 15:39

Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable