System beep on invalid input

Kernels & Hardware, configuring network, installing services

System beep on invalid input

Postby CJL » 2020-07-14 20:45

My system is responding to invalid input (ex using Firefox's find function for a string with 0 results) by outputting a system beep/bell, rather than the sound coming from my computer's speakers. I don't know why its doing this, but I would like it to stop, as the sound of this system beep is irritating and there is no volume control for it.
CJL
 
Posts: 21
Joined: 2019-03-01 13:34

Re: System beep on invalid input

Postby Head_on_a_Stick » 2020-07-14 20:53

Code: Select all
# tee /etc/modprobe.d/shutup.conf <<<'blacklist snd-pcsp'
# reboot
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: System beep on invalid input

Postby CJL » 2020-07-16 00:58

It doesn't seem like shutup.conf did anything. Does it require a specific package to be effective?
CJL
 
Posts: 21
Joined: 2019-03-01 13:34

Re: System beep on invalid input

Postby cuckooflew » 2020-07-16 01:30

There are many ways to do what you want, Did you even try doing a search ?
If you copy/paste
Code: Select all
remove beep from debian 10
into your search engine, you shoudl find the answer to this, if you don't , try a different search engine, also, doing a search using the same text that H_O_A_S posted:
Code: Select all
tee /etc/modprobe.d/shutup.conf <<<'blacklist snd-pcsp'
actually gets results giving details on that.
Does it require a specific package to be effective?
No, but that might be another approach, I mean the 'beep' command,is a package. one could remove it all together, maybe you don't want to do that though...
Try doing some searches, this is to easy, but you have not done any searches, and do not use any logic.
Please Read What we expect you have already Done
Google knows a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 547
Joined: 2018-05-10 19:34
Location: Some where out west

Re: System beep on invalid input

Postby stevepusser » 2020-07-16 04:27

CJL wrote:It doesn't seem like shutup.conf did anything. Does it require a specific package to be effective?


Did you reboot, or try unloading the offending module manually first to see if that had any effect?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
stevepusser
 
Posts: 11891
Joined: 2009-10-06 05:53

Re: System beep on invalid input

Postby cuckooflew » 2020-07-16 18:00

The command posted by HOAS worked for me, it created the file:
Code: Select all
/etc/modprobe.d/shutup.conf

and "shutup.conf" has the line:
Code: Select all
blacklist snd-pcsp
in it.
did you look, to see if the file was created or modified as needed ?
You do need to be root to do this, use 'sudo' or 'su -' .

You can also completely disable 'beep' like this:
Code: Select all
# mv /bin/beep ex-beep

Disclaimer, I know this might affect other programs that use 'beep', and they will no longer be able to.
How ever, it is simple if you want to restore 'beep':
Code: Select all
# mv /bin/ex-beep beep


It is because, on older versions of Debian, the 'beep' command was not included as default, in a base install, and if I wanted 'beep', I had to install it. It is not a "essential" package, 'mv' see 'man mv' , just renames it, and does not uninstall or remove it, so then if you want it back it is easy to restore.
Last edited by cuckooflew on 2020-07-16 18:03, edited 1 time in total.
Please Read What we expect you have already Done
Google knows a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 547
Joined: 2018-05-10 19:34
Location: Some where out west

Re: System beep on invalid input

Postby Head_on_a_Stick » 2020-07-16 18:01

The module name might be wrong (although snd-pcsp also works for me) so perhaps try pcspkr instead.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: System beep on invalid input

Postby cuckooflew » 2020-07-16 18:10

According to this:https://debian-administration.org/article/110/Removing_annoying_console_beeps

Code: Select all
Edit:

"/etc/modprobe.d/blacklist"

and add line:

"blacklist pcspkr"

close editor and reboot

or:

"sudo modprobe -r pcspkr"

and reboot.
 

"pcspkr"
Please Read What we expect you have already Done
Google knows a lot, and
"If God had wanted computers to work all the time, He wouldn't have invented RESET buttons"
…one flew east, one flew west,
One flew over the cuckoo’s nest.
cuckooflew
 
Posts: 547
Joined: 2018-05-10 19:34
Location: Some where out west

Re: System beep on invalid input

Postby CJL » 2020-07-22 18:27

Head_on_a_Stick wrote:The module name might be wrong (although snd-pcsp also works for me) so perhaps try pcspkr instead.

I can do that.
CuckooFlew wrote:It is because, on older versions of Debian, the 'beep' command was not included as default, in a base install, and if I wanted 'beep', I had to install it. It is not a "essential" package, 'mv' see 'man mv' , just renames it, and does not uninstall or remove it, so then if you want it back it is easy to restore.

Funny thing is, I checked dpkg and apt. The package 'beep' isn't installed on my system.
And yeah, I ran searches, but not for disabling beep: I thought that it was a bug that 'invalid' inputs were causing beeps, not a feature.
Thanks to both of you for suggesting pcspkr. I'll try it now.

UPDATE: Adding 'blacklist pcspkr' to the shutup.conf file seems to have worked. Thanks!
Last edited by CJL on 2020-07-22 22:01, edited 1 time in total.
CJL
 
Posts: 21
Joined: 2019-03-01 13:34

Re: System beep on invalid input

Postby Head_on_a_Stick » 2020-07-22 19:34

CJL wrote:The package 'beep' isn't installed on my system

That package is for advanced control of the motherboard speaker, the speaker will still work without the beep package:
Code: Select all
printf "\a"
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable