possible permissions issue with netinstall + Fluxbox setup

Kernels & Hardware, configuring network, installing services

possible permissions issue with netinstall + Fluxbox setup

Postby tpprynn » 2020-10-26 21:14

Sorry that I could not make this more brief.

I'm thinking that these issues are related, and I'm hoping it's just my naivety that's making the issue drag on a bit and not a corrupted install. Mostly my system is working very well and I much prefer the speed and simplicity.

I recently made the break from using live CDs of full desktop environments, to using the netinstall iso and adding Fluxbox to this. I'm using PCManFM for a file manager and as far as possible the simplest option for programs, to minimise slowing things down. A few problems seem to have arisen from this which I'd like to resolve and learn from. I have had a few stabs at this with partial success.

(1) For example, when I used LightDm for a display manager there was no problem in running this in the terminal:

sudo leafpad /etc/default/grub

With both xdm and Slim as display manager, the terminal responds:

No protocol specified
leafpad: Cannot open display

The same happens if I use root to attempt the same task (which is just an example here, I don't need to change grub right now).

I can use nano in place of leafpad without issue.

It may have been a bad or dicey habit, but I used to use 'gksu nautilus' to do things like changing a line in a gtk theme when I used a full DE. I see that gksu is discontinued. I can't open PCManFM with sudo (though I used to with LXDE without any issue visible to me).

(2) This doesn't happen with LightDM, but with xdm if I try to run Audacity the terminal says this:

'ScreenToClient cannot work when toplevel window is shown.'

A smaller box comes up with the gtk theme headed 'an assertion failed', and then states what the terminal also does:

'../src/gtk/dcclient.cpp(2038): assert "m_window" failed in DoGetSize(): GetSize() doesn't work without window'

There were three installs of Debian 10 and one of them used a second download of the same iso, so I'm thinking the install is okay and that something just needs to be corrected.

Has this gone how it was bound to go due to my current probably naivety since adopting the netinstall method or have I seemed to make a mistake somewhere?

Why will Leafpad not run in the example given where nano will?

Most applications work, like Fadein (screenwriting software) or Gimp. Why are some applications working but not others? Why is PCManFM working less well than it does within LXDE in terms of not automounting the SD card?

(3) So, are these issues related? And if I'd added Xfce (as opposed to using the Xfce iso) instead of Fluxbox, for example, would these issues not have occurred? (I would really rather not change DE, as netinstall + Fluxbox seems noticeably smoother than using even the LXDE iso.)

Would appreciate assistance in solving this once and for all after a few weeks of partial success and working round/ ignoring things.


Edit: I removed the part about an SD card not automounting, preventing gmusicbrowser from using it, because since a full reboot this does not seem to be the case for whatever reason. It doesn't seem to be an issue now.
Posts: 131
Joined: 2011-04-11 18:09

Re: possible permissions issue with netinstall + Fluxbox set

Postby sickpig » 2020-10-26 23:37

seems like you need the below:
* add a polkit agent to your autostart if you haven't already
* add the relevant policies to /usr/share/polkit-1/actions for the corresponding apps which you need to open as root
* start openbox with
Code: Select all
dbus-launch --exit-with-session openbox
and then see if your pcmanfm volume auto mount settings stick?
User avatar
Posts: 589
Joined: 2019-01-23 10:34

Re: possible permissions issue with netinstall + Fluxbox set

Postby Bulkley » 2020-10-27 01:06

Why do you need a display manager. It is possible to boot to a CLI log in, enter your username and password and enter startx. If typing startx is annoying use x or s or your middle name. Edit ~/.bashrc , scroll down to "# some more ls aliases" and add
Code: Select all
alias sx="startx"
Where I have sx put anything you like.

Leafpad has been deprecated; it ended in stretch. Try Mousepad or one of several alternatives.

It may have been a bad or dicey habit, but I used to use 'gksu nautilus' to do things . . .
Agreed, it is a bad habit.

Netinstall is a very good method and you are to be to be commended for trying it. :!:
Posts: 6018
Joined: 2006-02-11 18:35

Re: possible permissions issue with netinstall + Fluxbox set

Postby tpprynn » 2020-10-27 11:12

This is promising, and once a grim three day migraine has passed I'll focus on doing the reading; but, audacity doesn't need to be run as root and is still showing the gripe I illustrated above. Is this still something that can be solved with polkit? Permissions seem odd in randomly system-wide fashion.

I had seen something about polkit during my initial attempts to solve this a few weeks back, but then lost the pages I found that seemed like a solution, so I'm encouraged to be on the road back to that.

I like the harcore idea of having no display manager but my eyesight is so bad that the enormous xdm login screen is quite handy! Once I have the other things solved I suppose it would be possible to enlarge the size of the pre-x font a bit. But I did remove xdm from one of the machines and see that it needs to be done with more finesse than I used, as Wicd is trying to start and boot kind of freezes while looking for the wifi. I will press on with this as the ibuprofen kicks in but if anything can be clarified regarding the above that would be great. Thanks.
Posts: 131
Joined: 2011-04-11 18:09

Re: possible permissions issue with netinstall + Fluxbox set

Postby Deb-fan » 2020-10-27 12:11

Read "man sudo" do some googling, done right it's no biggie but opening graphical apps with sudo is not good practice. Using sudo with commandline stuff is of course no problem ...

I still use gksu/do on Buster, no problemo, though yeppers policy files and stuff like pkexec and so forth are what's advised now whenever a nixer is wanting to open graphical apps with priv's. What a particular nixer settles on depends on them, individual tastes + skill level etc :D Though think best practice for more experienced nixers, is to advise newer nixers to learn current best practice. The polkit + policy files + pkexec things are what upstream advises. So likely best to learn them and focus on using that.

For the rest of it, really think you need to spend more time googling up and reading about doing minimal Debian netinstalls. Yes .. from the sounds of it, who knows what all pkgs-etc you're missing or what all you need to properly configure. This is clearly why doing this type of thing is suited for people who've learned enough to know what they're doing. Though absolutely nothing wrong with wanting to learn and surely there are good how-to's and tutes online aplenty which you can learn from. Definitely do that, that's why whomever put that material online, to share info about the process with people interested in the subject.

It's not at all reasonable to refuse to avail oneself of all those resources, pop up in forums and expect folks who put in the time/effort to step by step you through it and try to make sense of any + all questions you have. When I developed a similar interest to what you're apparently undergoing now, yep ... that's what I did, fire up a browser, google "minimal debian netinstall." and other relevant searches. Then started reading how-to's and tutorials on the topic.

Oops, thought of another poss tip, also you may want to spend some time using a more minimal Debian based OS, one of them which comes to mind is called Bunsenlabs gnu/Linux. Based on Debian stable and has Openbox. Spend some time with some of those more minimal OS's, though at least they do come ready to go out-of-box. Less gui'ey chuff, more editing of config files directly etc. Check distrowatch for distro's which by default use Fluxbox etc. Can help getting your feet wet first vs jumping in head first ... If someone is really interested in gnu/Linux then hades yeah, this type of thing is fully worthwhile. The learning about how it all works "under-the-hood", checking out the nuts and bolts etc. Ah no worries, stick to it, you'll get there. :)
Most powerful FREE tech-support tool on the planet * HERE. *
Posts: 968
Joined: 2012-08-14 12:27

Re: possible permissions issue with netinstall + Fluxbox set

Postby tpprynn » 2020-10-31 17:46

At present I'm having to take a step back from this as I'm not sure I can afford an optional stress 'in these times'. But what I've done is to put slightly different setups on the three computers, for the moment. The newest laptop has Debian Fluxbox/netinstall and LightDM. The mini desktop has the same but no DM. THe old Thinkpad has Ubuntu from the 'mini' iso with the same setup on top of that, Fluxbox and no DM. Sadly a new issue has come from this, bringing things to a close for now - the two Debian setups, Wicd keeps 'forgetting my wifi' and it doesn't necessarily happen after a reboot or a shutdown, it feels random.

I had a feeling, probably unnecessarily, that if I reinstalled with just sudo and no root account, the problems might go away. Seemingly with LightDM installed and running this is something like true.

The Ubuntu setup is problem-free, unfortunately, which makes me feel as if the Debian system is gasiighting me, ha ha. But the thing is, if LightDM stops the issue from occuring, the one(s) that seems to derive from Polkit and/ or my limited grasp of it, why is that? What is LightDM doing? what is Ubuntu doing? Did its makers say to themselves, "This is needless hassle, we'll change this bit." And if so, that's a good thing isn't it? The tool is working.

I have these questions and this curiosity, but not indefinitely. I've used Mint, Ubuntu and Debian since 2008, and had previously retreated from a netinstall kind of setup about eight years ago. I see the value of getting away from commercial things of all kinds but other matters in life mean I'm not cut out for daily wrestling with a computer. Obviously we could say one only has to learn these difficult-seeming things once, but that's true until the technology is superceded. A few years ago I remember having a headache with something called Elim or Ekim? That seemed to antagonise people all over forums and now it's not heard of as far as I can see. Metaphorically speaking, you go out at the moment and oddly some people on the other side of the road, though wearing a mask, put their hand to their mouths in apparent fear of catching something from me thirty feet away. Some people take to accepting hassle in all areas of life, amplified their own capacity for irrationality, and some of us won't or can't, the energy is needed elsewhere. I'm just baffled that it's random whether an item of software throws up the pkexec-type gripes but others don't. Are others truly not baffled? Does it make sense somewhere down the line? If someone is using Xfce or Gnome from a live DVD install, is all this polkit stuff preconfigured within the setup? I'd never heard of it until a couple of weeks ago. I've encountered nothing like it since 2008 - other issues have soon made some kind of sense.

The system was working well as far as I knew, I love the smoothness and simplicity as I've probably said, even compared to a couple of years of using LXDE from a live DVD. If you look at a thread and 120 people have clicked on it and two have answered, enthusiastically and helpfully or otherwise - still understandably - I'm inclined to think that over a hundred people there haven't encountered the problem or have and changed their system rather than wrestle with it. I'm not inclined to think nearly all of them were thinking, This naive man, what on earth is he doing?

It is unreasonable of course to want limitless help and ot do nothing for oneself, and I wouldn't want to be guilty of that. I don't believe in this idea of the help vampire either - that seems akin to someone with Narcissistic Personality Disorder coming up with a term for a person who accuses them of narcissistic abuse. A kind of dissembling and a value judgement. Problems can't be endlessly novel and most of a forum like this is problems.

Sorry and everything. Debian is great, Linux is great, there'll be no more Windows for me, but I think in the scheme of things it's also unreasonable and unhealthy to get dragged into this wrestling with technology that doesn't seem to have been constructed with proper consideration for the big picture.

Thanks for listening, ha ha, if you did. i'm sure i will arrive at a satisfactory system (or up to three) in the next couple of weeks. If anyone actually knows the exact problem i'm having and knows how to solve it, a middle way between cryptic prods and the whole answer - unless you'd actually like to administer that morphine! - would be much appreciated. (And why Wicd has now suddenly developed Alzhemier's is currently beyond me.)
Posts: 131
Joined: 2011-04-11 18:09

Return to System configuration

Who is online

Users browsing this forum: No registered users and 29 guests