apt-get update with strange error

Kernels & Hardware, configuring network, installing services

apt-get update with strange error

Postby kampmannpeine » 2020-11-13 14:11

I tried to install audacity and they told me to "apt-get update" .. However this produced the following messages including the errors at the end of the message:

root@primergy:/home/joerg# apt-get update
Holen:1 http://security.debian.org/debian-security stretch/updates InRelease [53,0 kB]
Ign:2 http://ftp.de.debian.org/debian stretch InRelease
OK:3 http://ftp.de.debian.org/debian stretch-updates InRelease
Holen:4 http://ftp.uni-kl.de/debian-multimedia stable InRelease [19,5 kB]
OK:5 http://ftp.de.debian.org/debian stretch Release
OK:6 https://repo.skype.com/deb stable InRelease
Holen:7 http://security.debian.org/debian-security stretch/updates/main Sources [273 kB]
Holen:9 http://security.debian.org/debian-security stretch/updates/main i386 Packages [614 kB]
Holen:10 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [614 kB]
OK:8 https://www.deb-multimedia.org stretch InRelease
Holen:12 http://security.debian.org/debian-security stretch/updates/main Translation-en [273 kB]
Es wurden 1.847 kB in 0 s geholt (1.852 kB/s).
AppStream system cache was updated, but problems were found: Metadaten-Dateien haben Fehler: /var/cache/app-info/xmls/fwupd.xml
Paketlisten werden gelesen... Fertig
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh-cache > /dev/null; fi'
E: Sub-process returned an error code
root@primergy:/home/joerg#

Can you tell me how to circumvent these messages?

I am running debian 9 and uname -a brings:
Linux primergy 4.9.0-14-amd64 #1 SMP Debian 4.9.240-2 (2020-10-30) x86_64 GNU/Linux

tia

Jörg Kampmann
kampmannpeine
 
Posts: 7
Joined: 2012-04-30 09:31

Re: apt-get update mit eigenartigem Fehler

Postby reinob » 2020-11-13 14:53

Apparently when appstream updates whatever it needs to update it fails, without even saying why or how :(

I had never heard of appstream until now. Seems to be some framework required by various desktop "app stores".
Perhaps, at least temporarily, you could remove the appstream package, do your updates, and then reinstall it.

As root, run "dpkg -P appstream". That should delete the package and its configuration.
(maybe also "apt-get --purge remove appstream" would work, but there's a risk of apt-get failing when removing the package that causes it to fail :)

Later you can "apt-get install appstream" to install it again and hopefully nobody will have noticed that the package was missing for some time.

Good luck!
reinob
 
Posts: 858
Joined: 2014-06-30 11:42


Re: apt-get update with strange error

Postby Head_on_a_Stick » 2020-11-14 17:57

Those foreign sources arose my suspicion, from where is the appstream package installed?
Code: Select all
LC_ALL=C apt policy appstream

The LC_ALL=C bit makes the output English.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12795
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to System configuration

Who is online

Users browsing this forum: arochester and 22 guests

fashionable