apt problems - dpkg and apt-listbugs

Kernels & Hardware, configuring network, installing services

apt problems - dpkg and apt-listbugs

Postby milomak » 2020-11-22 13:52

in sid, when running apt/apt-get/aptitude trying to remove a package, i am met with the following error message
Code: Select all
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'libedit2:amd64' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)


and then when trying to run apt-listbugs,
Code: Select all
# apt-listbugs
Traceback (most recent call last):
        19: from /usr/sbin/apt-listbugs:419:in `<main>'
        18: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
        17: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
        16: from /usr/lib/ruby/vendor_ruby/gettext.rb:19:in `<top (required)>'
        15: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
        14: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
        13: from /usr/lib/ruby/vendor_ruby/gettext/text_domain_manager.rb:14:in `<top (required)>'
        12: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
        11: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
        10: from /usr/lib/ruby/vendor_ruby/gettext/text_domain.rb:16:in `<top (required)>'
         9: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
         8: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
         7: from /usr/lib/ruby/vendor_ruby/gettext/mo.rb:22:in `<top (required)>'
         6: from /usr/lib/ruby/vendor_ruby/gettext/mo.rb:23:in `<module:GetText>'
         5: from /usr/lib/ruby/vendor_ruby/gettext/mo.rb:172:in `<class:MO>'
         4: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
         3: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
         2: from /usr/lib/ruby/2.7.0/prime.rb:15:in `<top (required)>'
         1: from /usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require'
/usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require': /usr/lib/ruby/2.7.0/singleton.rb:1: invalid multibyte char (UTF-8) (SyntaxError)
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby Head_on_a_Stick » 2020-11-22 14:55

milomak wrote:in sid, when running apt/apt-get/aptitude trying to remove a package, i am met with the following error message
Code: Select all
dpkg: unrecoverable fatal error, aborting:
 files list file for package 'libedit2:amd64' is missing final newline
E: Sub-process /usr/bin/dpkg returned an error code (2)

Try
Code: Select all
# rm /var/lib/dpkg/info/libedit2\:amd64.list
# apt reinstall libedit2

Reference: https://askubuntu.com/questions/909719/ ... e-linux-ge

milomak wrote:
Code: Select all
/usr/lib/ruby/vendor_ruby/rubygems/core_ext/kernel_require.rb:83:in `require': /usr/lib/ruby/2.7.0/singleton.rb:1: invalid multibyte char (UTF-8) (SyntaxError)

Is the rubygems-integration package installed?

This might just be a sid SNAFU though so perhaps wait a bit and then upgrade your system and try again.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-11-22 15:55

the problem is that i cannot install/reinstall as apt-listbugs runs which returns the ruby error
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-11-22 16:32

i commented out all the lines in /etc/apt/apt.conf.d/10apt-listbugs

it seems there are a whole lot libs that are messed up. i'll work through them piece by piece
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-11-22 17:21

there are a lot of packages missing final newline

a temporary fix is to move files out of /var/lib/dpkg/info/ into another folder

run the apt commands i want

is there a way to find out which of the files in the folder have this newline issue? what happens if i don't move them back into the info folder?
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby Head_on_a_Stick » 2020-11-23 18:29

milomak wrote:is there a way to find out which of the files in the folder have this newline issue?

Try
Code: Select all
# dpkg --verify

Sounds like the filesystem may be corrupted. Have you tried a SMART check on the drive?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-11-25 16:38

yeah this system is borked

will be a reinstall next

just need to think what conf files i'll what to keep
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-12-18 00:39

so i happen to have the kodi system running

so i thought what if i moved the files in /var/lib/dpkg/info into another directory

then did a rsync of the files from the kodi system? i figured there would be file differences given different update times of the system (kodi having been updated in the last few days)

but i gave it a shot. so in the directory, i ran rsync -av root@192.168.1.102:/var/lib/dpkg/info/ .

then did aptitude upgrade

for the most part it seems to be working.

iam getting some (and there are a number out of 1000 odd packages) of this
Code: Select all
dpkg: warning: files list file for package 'libcrypto++6' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'qml-module-org-kde-analitza:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libpotrace0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'libanjuta-3-0:amd64' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'kshisen' missing; assuming package has no files currently installed


i am hoping i have recovered the core the install

i am hoping something like aptitude install -f will fix
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-12-18 00:43

initial assessment seems like these are impacted packages. a win if this boots.
Code: Select all
Errors were encountered while processing:
 libmutter-7-0:amd64
 libgtk-3-0:amd64
 gstreamer1.0-plugins-good:amd64
 gstreamer1.0-plugins-good:i386
 libevview3-3:amd64
 cinnamon-session
 gnome-session-bin
 cinnamon-core
 epiphany-browser
 cinnamon
 gir1.2-gtk-3.0:amd64
 libplank1:amd64
 gedit-plugin-multi-edit
 yelp
 libgtk-3-bin
 libyelp0:amd64
 gedit-plugin-bookmarks
 gir1.2-nemo-3.0
 gedit-plugin-git
 ssh-askpass-gnome
 libnautilus-extension1a:amd64
 gir1.2-clutter-1.0:amd64
 gedit-plugin-translate
 qt5-gtk-platformtheme:amd64
 libcjs0:amd64
 libbudgie-plugin0
 gedit-plugin-find-in-files
 libcinnamon-desktop4:amd64
 libgail-3-0:amd64
 gedit-plugin-color-picker
 libcscreensaver0:amd64
 cinnamon-settings-daemon
 libmate-desktop-2-17:amd64
 budgie-core
 cinnamon-control-center
 gir1.2-gnomedesktop-3.0:amd64
 gedit-plugin-terminal
 malcontent-gui
 gir1.2-meta-muffin-0.0
 gedit-plugin-bracket-completion
 libbudgie-private0
 libtepl-5-0:amd64
 libspice-client-gtk-3.0-5:amd64
 xarchiver
 gedit-plugin-word-completion
 evince
 gedit-plugin-text-size
 gir1.2-handy-1:amd64
 lxterminal
 cinnamon-control-center-goa


oh and this was all via chroot into the system
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-12-18 00:53

some further searching found that dpkg -i /var/cache/apt/archives/*.deb brings the system closer to sanity. it is now applying a whole lot of what needed to be configured so i hope to reply later that everything updated.
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20

Re: apt problems - dpkg and apt-listbugs

Postby milomak » 2020-12-18 02:01

am i looking at the wrong thing
Code: Select all
dpkg: warning: files list file for package 'plasma-desktop-data' missing; assuming package has no files currently installed


then i do

# apt install plasma-desktop-data
Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
plasma-desktop-data is already the newest version (4:5.19.5-4).
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
Desktop: A320M-A PRO MAX, AMD Ryzen 5 3600, GALAX GeForce RTX™ 2060 Super EX (1-Click OC) - Sid, Win10, Arch Linux, Gentoo, Solus
Laptop: Lenovo ideapad Y700-15ISK - Sid, Win10, Solus
Kodi: AMD Athlon 5150 APU w/Radeon HD 8400 - Sid
milomak
 
Posts: 2085
Joined: 2009-06-09 22:20


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable
cron