Set ALSA with no soundcard

Kernels & Hardware, configuring network, installing services

Set ALSA with no soundcard

Postby Icaro » 2020-12-02 03:30

I'm having some trouble, my pc's onboard soundcard seems to be not working: I have used windows 7 and 10, and two other linux distros before and, despite a lot of trying, nothing made the sound work. I'm using debian 10 and I'm still having the same problem, and lspci gives:

Code: Select all
# lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 10)
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 02)

That Realtek line really says about a network thing, I use a usb wifi adapter, which was configured useing some realtek firmware thing.

So I'm trying to work this around with some streaming programs.

I use SoundWire, which successfully works for streaming the output for a cell phone, but I have tried some alternatives for the audio input and nothing worked. As long as I've understood, they usually try to talk to ALSA loopback or something like that, but the snd-aloop module is not enabled - worse, it is not even found by the system: lsmod | grep snd gives no output, and modprobe snd-aloop gives:

Code: Select all
modprobe: FATAL: Module snd-aloop not found in directory /lib/modules/4.19.0-6-amd64

But SoundWire works, and, unless I've misread it (really probable), it uses some PulseAudio ALSA emulation. And I'm thinking the problem lies here. Maybe some pulseaudio-layer thing is able to just accept there is no physical device, but the ALSA-layer can't. So I'd like to know if there is something to role-play ALSA to those programs without having hardware connection; or maybe some better explanation and solution, if this path doesn't make sense.

The pavucontrol information that I might have misread is:

ALSA plug-in [SoundWireServer]: ALSA Capture

It shows at the recording pane of pavucontrol (I was not able to send any screenshot, the forum didn't allow it).

The audio input program outputs:

Code: Select all
Audio loopback device not found.
Is snd_aloop loaded?
Posts: 1
Joined: 2020-12-02 02:47

Re: Set ALSA with no soundcard

Postby shep » 2020-12-04 17:23

This is extrapolating from FreeBSD sound configuration where sound card pins (nwid) are interrogated and grouped on boot. More often than not, HDMI capable video provides a sound nwid. Your lspci does not show any audio device, is your video HDMI capable?

I'm guessing you believe you have a bad chip. If so consider a PCI sound card, they are dirt cheap.

Edit: Also check your BIOS configuration - some allow deactivation of soundcards.
Posts: 407
Joined: 2011-03-15 15:22

Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests