hibernation/resume issue with nvidia-card

Kernels & Hardware, configuring network, installing services

hibernation/resume issue with nvidia-card

Postby morgon » 2020-12-10 12:52

Hi,

I have an old PC where I used an integrated gpu for many years without problems.

Then I added a GT 1030 and now I have a strange problem when my system resumes from hibernation.

With my old gpu I got straight back into my graphical session when resuming, however with the new card all I get is a completely blank screen.

I can then press eg. Ctrl-Alt-1 to access a virtual terminal (that works) and if I then press Ctrl-Alt-7 I am back in my graphical session.

Trying to access the graphical session immediately with Ctrl-Alt-7 does not work (nothing happens).

When I log into the system on a virtual terminal, I can see that the system is booted and even the X-server is running, but for whatever reason I only get the blank screen.

What could be the problem here?

I have a suspicion that maybe it has to do with my system now having 2 gpus installed (the nvidia and the integrated one), but I really don't understand what is going on here.

I run testing with the propietary nvidia drivers, lightdm and i3 and hibernate with "systemctl hibernate".

Many thanks!
morgon
 
Posts: 183
Joined: 2010-08-28 03:04

Re: hibernation/resume issue with nvidia-card

Postby stevepusser » 2020-12-11 00:17

Does your computer settings have an option to disable the iGPU?
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12182
Joined: 2009-10-06 05:53

Re: hibernation/resume issue with nvidia-card

Postby shaola » 2020-12-13 15:46

Is it kde?
Try to killl the screenlocker from the virtual terminal and go back to your graphical session:
Code: Select all
killall  kscreenlocker_greet
shaola
 
Posts: 4
Joined: 2013-06-12 20:13

Re: hibernation/resume issue with nvidia-card

Postby morgon » 2020-12-16 14:00

To quote myself: "I run testing with the propietary nvidia drivers, lightdm and i3 and hibernate with "systemctl hibernate", so no kde and no screenlocker.
morgon
 
Posts: 183
Joined: 2010-08-28 03:04


Return to System configuration

Who is online

Users browsing this forum: No registered users and 19 guests

fashionable