`nvidia-kernel-dkms` and `nvidia-driver` fail to install

Kernels & Hardware, configuring network, installing services

`nvidia-kernel-dkms` and `nvidia-driver` fail to install

Postby rzjnzk » 2020-12-21 11:58

Here is my terminal output when I simply run `sudo aptitude install`.

I have tried `sudo apt --fix-broken install` to no effect.

Code: Select all
/bin/zsh $ sudo aptitude install         
The following partially installed packages will be configured:
  nvidia-driver nvidia-kernel-dkms
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
Setting up nvidia-kernel-dkms (418.152.00-1) ...
Removing old nvidia-current-418.152.00 DKMS files...

-------- Uninstall Beginning --------
Module:  nvidia-current
Version: 418.152.00
Kernel:  4.19.0-13-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-current.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: failed to remove 'updates/dkms': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: failed to remove 'updates/dkms': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: failed to remove 'updates/dkms': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

DKMS: uninstall completed.

------------------------------
Deleting module version: 418.152.00
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-418.152.00 DKMS files...
Building for 4.19.0-13-amd64 5.9.0-15.1-liquorix-amd64
Building initial module for 4.19.0-13-amd64
Done.

nvidia-current.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

depmod...
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

DKMS: install completed.
Building initial module for 5.9.0-15.1-liquorix-amd64
Error! Bad return status for module build on kernel: 5.9.0-15.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/418.152.00/build/make.log for more information.
dpkg: error processing package nvidia-kernel-dkms (--configure):
 installed nvidia-kernel-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver:
 nvidia-driver depends on nvidia-kernel-dkms (= 418.152.00-1) | nvidia-kernel-418.152.00; however:
  Package nvidia-kernel-dkms is not configured yet.
  Package nvidia-kernel-418.152.00 is not installed.
  Package nvidia-kernel-dkms which provides nvidia-kernel-418.152.00 is not configured yet.

dpkg: error processing package nvidia-driver (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-kernel-dkms
 nvidia-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)
Setting up nvidia-kernel-dkms (418.152.00-1) ...
Removing old nvidia-current-418.152.00 DKMS files...

-------- Uninstall Beginning --------
Module:  nvidia-current
Version: 418.152.00
Kernel:  4.19.0-13-amd64 (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

nvidia-current.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: failed to remove 'updates/dkms': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-modeset.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: failed to remove 'updates/dkms': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-drm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
rmdir: failed to remove 'updates/dkms': Directory not empty
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.


nvidia-current-uvm.ko:
 - Uninstallation
   - Deleting from: /lib/modules/4.19.0-13-amd64/updates/dkms/
 - Original module
   - No original module was found for this module on this kernel.
   - Use the dkms install command to reinstall any previous module version.

depmod...

DKMS: uninstall completed.

------------------------------
Deleting module version: 418.152.00
completely from the DKMS tree.
------------------------------
Done.
Loading new nvidia-current-418.152.00 DKMS files...
Building for 4.19.0-13-amd64 5.9.0-15.1-liquorix-amd64
Building initial module for 4.19.0-13-amd64
Done.

nvidia-current.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

nvidia-current-modeset.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

nvidia-current-drm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

nvidia-current-uvm.ko:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/4.19.0-13-amd64/updates/dkms/

depmod...
Job for systemd-modules-load.service failed because the control process exited with error code.
See "systemctl status systemd-modules-load.service" and "journalctl -xe" for details.

DKMS: install completed.
Building initial module for 5.9.0-15.1-liquorix-amd64
Error! Bad return status for module build on kernel: 5.9.0-15.1-liquorix-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/418.152.00/build/make.log for more information.
dpkg: error processing package nvidia-kernel-dkms (--configure):
 installed nvidia-kernel-dkms package post-installation script subprocess returned error exit status 10
dpkg: dependency problems prevent configuration of nvidia-driver:
 nvidia-driver depends on nvidia-kernel-dkms (= 418.152.00-1) | nvidia-kernel-418.152.00; however:
  Package nvidia-kernel-dkms is not configured yet.
  Package nvidia-kernel-418.152.00 is not installed.
  Package nvidia-kernel-dkms which provides nvidia-kernel-418.152.00 is not configured yet.

dpkg: error processing package nvidia-driver (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nvidia-kernel-dkms
 nvidia-driver


Any help is much appreciated. Thank you in advance.
rzjnzk
 
Posts: 1
Joined: 2020-12-21 11:49

Re: `nvidia-kernel-dkms` and `nvidia-driver` fail to install

Postby Head_on_a_Stick » 2020-12-21 12:25

Looks like the NVIDIA module won't build for the Liquorix kernel so uninstall that and build it for the stock Debian buster kernel instead. This problem happens because NVIDIA are a bunch of ****s who don't give a **** about open source, you should throw that POS card away and buy an AMD card instead — the latest AMD cards outperform NVIDIA for games anyway.

EDIT: the board censors the f-word but not the c-word? :?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13041
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: `nvidia-kernel-dkms` and `nvidia-driver` fail to install

Postby sunrat » 2020-12-21 21:08

Probably you need a later version of nvidia-driver for that kernel. Try the version 450.xx from buster-backports. CUDA support for 5.9 kernels is still hiding in experimental currently though.
Or just install Liquorix 5.8 with its headers. I personally am using that with the 450.xx nvidia driver from backports and it works fine.
BTW, you don't need to specify nvidia-kernel-dkms separately, it is installed automatically when you install the nvidia-driver metapackage.

@HoaS - Nvidia are not alone in deficiency of Linux hardware support. Consider Broadcom, and Realtek who have about 7 million different drivers for different chipsets of which only about 2 million are included in the kernel.
And maybe the board's ancient creators didn't consider anyone would attempt to post the c word. :mrgreen:
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3335
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to System configuration

Who is online

Users browsing this forum: No registered users and 20 guests

fashionable