nvidia-legacy-390xx-driver not loaded

Kernels & Hardware, configuring network, installing services

nvidia-legacy-390xx-driver not loaded

Postby hgoeldner » 2021-01-04 07:30

Hi, I have been running into continual troubles when trying to install the proprietary Nvidia drivers onto my Debian configuration. I am fairly new to Debian and was hoping someone with more experience could help me out. For background information, I am running the latest version of Buster with KDE as the desktop environment. This is what I've done.

I installed nvidia-detect and got the following:

Code: Select all
Detected NVIDIA GPUs:
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF108M [GeForce GT 525M] [10de:0df5] (rev ff)

Checking card:  NVIDIA Corporation GF108M [GeForce GT 525M] (rev ff)
Your card is only supported up to the 390 legacy drivers series.
It is recommended to install the
    nvidia-legacy-390xx-driver
package.


Running lspci -v | grep "VGA" returns the following and based upon that I believe I have an Optimus type system (see https://wiki.debian.org/NVIDIA%20Optimus):

Code: Select all
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev ff) (prog-if ff)


I install the nvidia-legacy-390xx-driver and when running nvidia-settings I get the following error:

Code: Select all
ERROR: NVIDIA driver is not loaded


ERROR: Error querying enabled displays on GPU 0 (Missing Extension).


ERROR: Error querying connected displays on GPU 0 (Missing Extension).


I have tried running nvidia-xconfig and then also setting it up myself using various online tutorials. I considered using bumblebee along the way but heard about poor performance. I tried setting it up as only one GPU but got blank screens. Ideally I'd like to be able to use the "NVIDIA PRIME Render Offload" method mentioned here: https://wiki.debian.org/NVIDIA%20Optimus#PRIMEOffload

What should I do? As side note, how should I tell that the nvidia drivers are setup correctly and not using the default nouveau ones?
hgoeldner
 
Posts: 4
Joined: 2021-01-04 06:56

Re: nvidia-legacy-390xx-driver not loaded

Postby Head_on_a_Stick » 2021-01-04 08:53

hgoeldner wrote:I install the nvidia-legacy-390xx-driver and when running nvidia-settings I get the following error:

I think you have to either disable the integrated graphics chip from the firmware ("BIOS") options or prepend the command with optirun(1) but I've never used an Optimus system so I might be wrong.

hgoeldner wrote:I have tried running nvidia-xconfig

Did you not read the package description? That command is obsolete.

hgoeldner wrote:I tried setting it up as only one GPU but got blank screens.

What did you do, exactly? Did you check the X.Org log files?

hgoeldner wrote:Ideally I'd like to be able to use the "NVIDIA PRIME Render Offload" method mentioned here: https://wiki.debian.org/NVIDIA%20Optimus#PRIMEOffload

Have you actually read that page? It clearly says that method doesn't work for Debian buster.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13041
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: nvidia-legacy-390xx-driver not loaded

Postby stevepusser » 2021-01-04 20:29

Optimus is only found on laptops, so perhaps telling us whether you have a desktop or laptop would help?

If you really want to help, install inxi and copypaste the terminal output of "inxi -Fxxz" 's Machine and Graphics section here.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12182
Joined: 2009-10-06 05:53

Re: nvidia-legacy-390xx-driver not loaded

Postby hgoeldner » 2021-01-05 05:20

Head_on_a_Stick wrote:
hgoeldner wrote:I install the nvidia-legacy-390xx-driver and when running nvidia-settings I get the following error:

I think you have to either disable the integrated graphics chip from the firmware ("BIOS") options or prepend the command with optirun(1) but I've never used an Optimus system so I might be wrong.


Unfortunately my BIOS doesn't support disabling the integrated graphics chip. I'm trying to avoid optirun from the bumblebee project as there are reports of slower performance.

Head_on_a_Stick wrote:
hgoeldner wrote:I have tried running nvidia-xconfig

Did you not read the package description? That command is obsolete.


I did read that page however after reading that it solved issues for multiple users I thought I'd give it a try. When it failed I simply unrolled the changes it made.

Head_on_a_Stick wrote:
hgoeldner wrote:I tried setting it up as only one GPU but got blank screens.

What did you do, exactly? Did you check the X.Org log files?


Sorry, I didn't exactly elaborate here earlier. I followed the guide found here: https://wiki.debian.org/NVIDIA%20Optimus#Using_NVIDIA_GPU_as_the_primary_GPU As I am running KDE, I followed the steps for SDDM. The result was freezing graphics upon logging in. I tried configuring it multiple other ways using other people's guides. If you need specifics I can provide them.

With regards to the X.Org log files, I haven't checked them yet. They are quite long. Is there a specific section that would be beneficial?

Head_on_a_Stick wrote:
hgoeldner wrote:Ideally I'd like to be able to use the "NVIDIA PRIME Render Offload" method mentioned here: https://wiki.debian.org/NVIDIA%20Optimus#PRIMEOffload

Have you actually read that page? It clearly says that method doesn't work for Debian buster.


Yes, I read that page multiple times. Hence why I said "ideally." I am beginning to realize that perhaps using NvidiaXrun might be the way to go (see https://wiki.debian.org/NvidiaGraphicsDrivers/NvidiaXrun). Would this error be resolved by getting that setup or am I missing something?

stevepusser wrote:Optimus is only found on laptops, so perhaps telling us whether you have a desktop or laptop would help?

If you really want to help, install inxi and copypaste the terminal output of "inxi -Fxxz" 's Machine and Graphics section here.


I am running Debian on Dell 15" Laptop (I'm not sure the exact model) dated approximately 8 years old. The inxi -Fxxz gave the following results:

Code: Select all
System:    Host: InfinityTillIthacaFalls Kernel: 4.19.0-13-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           Desktop: KDE Plasma 5.14.5 tk: Qt 5.11.3 wm: kwin_x11 dm: SDDM Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Portable System: Dell product: Dell System XPS L502X v: N/A serial: <filter> Chassis: type: 8 v: 0.1
           serial: <filter>
           Mobo: Dell model: 0YR8NN v: A00 serial: <filter> UEFI [Legacy]: Dell v: A12 date: 09/07/2012
Battery:   ID-1: BAT0 charge: 47.2 Wh condition: 47.2/48.9 Wh (97%) volts: 12.4/11.1 model: LGC Dell serial: <filter>
           status: Full
           Device-1: hidpp_battery_0 model: Logitech MX Keys for Mac serial: <filter> charge: 50% (should be ignored)
           status: N/A
CPU:       Topology: Quad Core model: Intel Core i7-2670QM bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35119
           Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798 5: 798 6: 799 7: 798 8: 799
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:0116
           Device-2: NVIDIA GF108M [GeForce GT 525M] vendor: Dell driver: nvidia v: 390.138 bus ID: 01:00.0 chip ID: 10de:0df5
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa compositor: kwin_x11
           resolution: 1366x768~60Hz
           OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel
           bus ID: 00:1b.0 chip ID: 8086:1c20
           Device-2: NVIDIA GF108 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1
           chip ID: 10de:0bea
           Sound Server: ALSA v: k4.19.0-13-amd64
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 3000 bus ID: 03:00.0 chip ID: 8086:08b1
           IF: wlp3s0 state: up mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 2000
           bus ID: 06:00.0 chip ID: 10ec:8168
           IF: enp6s0 state: down mac: <filter>
Drives:    Local Storage: total: 223.57 GiB used: 6.26 GiB (2.8%)
           ID-1: /dev/sda vendor: Kingston model: SV300S37A240G size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> temp: 35 C
Partition: ID-1: / size: 218.12 GiB used: 6.26 GiB (2.9%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 975.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 216 Uptime: 45m Memory: 7.69 GiB used: 1.02 GiB (13.3%) Init: systemd v: 241 runlevel: 5 Compilers:
           gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: konsole inxi: 3.0.32


Edit:

As a test, I tried setting up bumblebee (roughly followed https://medium.com/@sumeet.mathpati/properly-install-bumblebee-on-debian-4b57467fc453). I ran optirun firefox as a test and got not errors. However, when running nvidia-settings I still get:

Code: Select all
ERROR: Error querying enabled displays on GPU 0 (Missing Extension).


ERROR: Error querying connected displays on GPU 0 (Missing Extension).


As well as a visual popup saying:

Code: Select all
You do not appear to be using the NVIDIA X Driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.


Would this mean that optirun is just using the default nouveau drivers? How can I tell which drivers are being used? I tried running the following as root and got no errors:

Code: Select all
echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf
hgoeldner
 
Posts: 4
Joined: 2021-01-04 06:56

Re: nvidia-legacy-390xx-driver not loaded

Postby Head_on_a_Stick » 2021-01-05 15:40

hgoeldner wrote:I followed the guide found here: https://wiki.debian.org/NVIDIA%20Optimus#Using_NVIDIA_GPU_as_the_primary_GPU As I am running KDE, I followed the steps for SDDM. The result was freezing graphics upon logging in. I tried configuring it multiple other ways using other people's guides. If you need specifics I can provide them.

I don't need anything, I wouldn't ever buy anything from those NVIDIA bastards so I have no idea how to make their crappy hardware work under GNU/Linux. But it would be best to post as much detail as possible for those who might be willing and able to assist you.

hgoeldner wrote:With regards to the X.Org log files, I haven't checked them yet. They are quite long. Is there a specific section that would be beneficial?

It's always best to share the full logs because you might not know what to look for. Upload it to a pastebin and share a link here if the file is very large.

hgoeldner wrote:when running nvidia-settings I still get

Did you try "optirun nvidia-settings"? I've no idea if that would work but it seems like an obvious thing to try.

hgoeldner wrote:How can I tell which drivers are being used?

You've already posted it: read your inxi output. The Intel card is using the i915 kernel driver and the modesetting DDX driver. The NVIDIA card is using v390.138 of the proprietary kernel driver, try prepending inxi with "optirun" to see if that will show the relevant DDX driver (given on the "Display" line in the "Graphics" section).

hgoeldner wrote:I tried running the following as root and got no errors:
Code: Select all
echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf

I don't think that is needed any more and you already have the kernel blob loaded. But I really don't know so I'll leave this thread for others who do.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13041
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: nvidia-legacy-390xx-driver not loaded

Postby hgoeldner » 2021-01-05 23:08

I managed to get the nvidia-settings to work as suggested by Head_on_a_Stick. The only difference was that I had to run:

Code: Select all
optirun nvidia-settings -c :8


As of now, it appears this has fixed my issues with the nvidia proprietary drivers.
hgoeldner
 
Posts: 4
Joined: 2021-01-04 06:56


Return to System configuration

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable